aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/rackmonkey
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-04-14 22:11:45 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-04-14 22:11:45 +0000
commitc102d59fbe7a2dcdb63a423db003f2f92ae58b22 (patch)
treec408d27f7621a960430dca971666bb4e96890177 /net-mgmt/rackmonkey
parent5b805f79e08ce5ea15f1955f5300a043c32623d9 (diff)
downloadports-c102d59fbe7a2dcdb63a423db003f2f92ae58b22.tar.gz
ports-c102d59fbe7a2dcdb63a423db003f2f92ae58b22.zip
Notes
Diffstat (limited to 'net-mgmt/rackmonkey')
-rw-r--r--net-mgmt/rackmonkey/Makefile14
-rw-r--r--net-mgmt/rackmonkey/files/pkg-message.in5
2 files changed, 12 insertions, 7 deletions
diff --git a/net-mgmt/rackmonkey/Makefile b/net-mgmt/rackmonkey/Makefile
index 90d489c16478..dc061ae28b53 100644
--- a/net-mgmt/rackmonkey/Makefile
+++ b/net-mgmt/rackmonkey/Makefile
@@ -1,6 +1,6 @@
# Ports collection makefile for: RackMonkey
-# Date created: February 10, 2010
-# Whom: Eric F Crist <ecrist@secure-computing.net>
+# Date created: 2010-02-10
+# Whom: Eric F Crist <ecrist@secure-computing.net>
#
# $FreeBSD$
#
@@ -9,7 +9,9 @@ PORTNAME= rackmonkey
PORTVERSION= 1.2.5
PORTREVISION= 2
CATEGORIES= net-mgmt www
-MASTER_SITES= SF
+MASTER_SITES= SF \
+ ftp://ftp.secure-computing.net/pub/FreeBSD/ports/${PORTNAME}/ \
+ ftp://ftp2.secure-computing.net/pub/FreeBSD/ports/${PORTNAME}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= ecrist@secure-computing.net
@@ -63,10 +65,10 @@ do-install:
if [ -e "${WWWDIR}/rackmonkey.db" ]; then \
${ECHO} "Database exists, skipping initalization..."; \
else \
- /usr/local/bin/sqlite3 ${WWWDIR}/rackmonkey.db < ${WRKSRC}/sql/schema/schema.sqlite.sql; \
- /usr/local/bin/sqlite3 ${WWWDIR}/rackmonkey.db < ${WRKSRC}/sql/data/default_data.sql; \
+ ${LOCALBASE}/bin/sqlite3 ${WWWDIR}/rackmonkey.db < ${WRKSRC}/sql/schema/schema.sqlite.sql; \
+ ${LOCALBASE}/bin/sqlite3 ${WWWDIR}/rackmonkey.db < ${WRKSRC}/sql/data/default_data.sql; \
if [ "${WITH_SAMPLE}" ]; then \
- /usr/local/bin/sqlite3 ${WWWDIR}/rackmonkey.db < ${WRKSRC}/sql/data/sample_data.sql; \
+ ${LOCALBASE}/bin/sqlite3 ${WWWDIR}/rackmonkey.db < ${WRKSRC}/sql/data/sample_data.sql; \
fi \
fi \
fi \
diff --git a/net-mgmt/rackmonkey/files/pkg-message.in b/net-mgmt/rackmonkey/files/pkg-message.in
index 8a887e2459b8..a23c06932911 100644
--- a/net-mgmt/rackmonkey/files/pkg-message.in
+++ b/net-mgmt/rackmonkey/files/pkg-message.in
@@ -17,12 +17,15 @@ WEBSERVER SETUP:
If using the Apache web server, simply add the following
to the appropriate place in your config files:
+Alias /rackmonkey %%WWWDIR%%
<Location /rackmonkey>
+ Order allow,deny
+ Allow from all
Options ExecCGI FollowSymLinks Includes
AddHandler cgi-script .pl
AddType text/html .shtml
AddHandler server-parsed .shtml
DirectoryIndex rackmonkey.pl index.shtml index.html
- SetEnv RACKMONKEY_CONF /usr/local/www/rackmonkey/rackmonkey.conf
+ SetEnv RACKMONKEY_CONF %%WWWDIR%%/rackmonkey.conf
</Location>