aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ramond
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-01-27 13:04:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-01-27 13:04:35 +0000
commit4189dac3d8164b628cbba8121df427fe6fdfb5cc (patch)
treeeb7f8a62421ecc8cf5e41ac76c09d6ac5aef905c /net-mgmt/ramond
parenta602da42ebcaeb8628e37731d352cb82e2c53adc (diff)
downloadports-4189dac3d8164b628cbba8121df427fe6fdfb5cc.tar.gz
ports-4189dac3d8164b628cbba8121df427fe6fdfb5cc.zip
Notes
Diffstat (limited to 'net-mgmt/ramond')
-rw-r--r--net-mgmt/ramond/Makefile42
-rw-r--r--net-mgmt/ramond/distinfo3
-rw-r--r--net-mgmt/ramond/files/patch-ramond.conf.example21
-rw-r--r--net-mgmt/ramond/files/ramon.in23
-rw-r--r--net-mgmt/ramond/pkg-descr10
-rw-r--r--net-mgmt/ramond/pkg-plist5
6 files changed, 104 insertions, 0 deletions
diff --git a/net-mgmt/ramond/Makefile b/net-mgmt/ramond/Makefile
new file mode 100644
index 000000000000..fb515faad6c3
--- /dev/null
+++ b/net-mgmt/ramond/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: ramond
+# Date created: 2010-01-25
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= ramond
+PORTVERSION= 0.4
+CATEGORIES= net-mgmt ipv6
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/_${PORTVERSION}/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= On-link IPv6 router advertisment monitoring and reporting daemon
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_BZIP2= YES
+USE_GNOME= libxml2
+USE_RC_SUBR= ramon
+
+PORTDOCS= README
+
+.include <bsd.port.pre.mk>
+
+LIB_DEPENDS+= apr-1.3:${PORTSDIR}/devel/apr
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ramond ${PREFIX}/sbin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.dtd \
+ ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/demo.pl \
+ ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ramond.conf.example ${PREFIX}/etc/
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/ramond/distinfo b/net-mgmt/ramond/distinfo
new file mode 100644
index 000000000000..b77a39df6dd5
--- /dev/null
+++ b/net-mgmt/ramond/distinfo
@@ -0,0 +1,3 @@
+MD5 (ramond-0.4.tar.bz2) = 8bd66500685a10e028bbeb51781f1bc8
+SHA256 (ramond-0.4.tar.bz2) = ddef0f711864e985bf0b786773d8de403de975532a7efa92074e8f763ea8284e
+SIZE (ramond-0.4.tar.bz2) = 14143
diff --git a/net-mgmt/ramond/files/patch-ramond.conf.example b/net-mgmt/ramond/files/patch-ramond.conf.example
new file mode 100644
index 000000000000..425fe2b890db
--- /dev/null
+++ b/net-mgmt/ramond/files/patch-ramond.conf.example
@@ -0,0 +1,21 @@
+
+$FreeBSD$
+
+--- ramond.conf.example.orig
++++ ramond.conf.example
+@@ -1,5 +1,5 @@
+ <?xml version="1.0" encoding="ISO-8859-15"?>
+-<!DOCTYPE ramond SYSTEM "ramond.conf.dtd">
++<!DOCTYPE ramond SYSTEM "%%PREFIX%%/share/ramond/ramond.conf.dtd">
+ <ramond>
+
+ <!--
+@@ -41,7 +41,7 @@
+ <rule mac="ecs-routers" lifetime="0">
+ <execute>/home/james/ramond/demo.pl native-router-killed</execute>
+ </rule>
+- <rule mac="ecs-routers" prefix="2001:630:d0:f000::/52">
++ <rule mac="ecs-routers" prefix="2001:db8:d0:f000::/52">
+ <!-- do nothing -->
+ </rule>
+
diff --git a/net-mgmt/ramond/files/ramon.in b/net-mgmt/ramond/files/ramon.in
new file mode 100644
index 000000000000..ce46db746185
--- /dev/null
+++ b/net-mgmt/ramond/files/ramon.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: ramon
+# REQUIRE: DAEMON NETWORKING
+#
+
+. %%RC_SUBR%%
+
+name="ramon"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/ramond"
+required_files=%%PREFIX%%/etc/ramond.conf
+
+load_rc_config $name
+
+: ${ramon_enable="NO"}
+
+command_args="-c %%PREFIX%%/etc/ramond.conf"
+
+run_rc_command "$1"
diff --git a/net-mgmt/ramond/pkg-descr b/net-mgmt/ramond/pkg-descr
new file mode 100644
index 000000000000..81f2a76d37e5
--- /dev/null
+++ b/net-mgmt/ramond/pkg-descr
@@ -0,0 +1,10 @@
+ramond monitors IPv6 networks for router advertisements.
+When an advert is received, a configurable action occurs.
+
+The tool was designed to `clear' (by sending spoofed zero
+lifetime adverts) rogue-routes sent by users running 6to4
+gateways on a campus network.
+
+WWW: http://ramond.sourceforge.net
+
+Janos Mohacsi <janos.mohacsi@bsd.hu>
diff --git a/net-mgmt/ramond/pkg-plist b/net-mgmt/ramond/pkg-plist
new file mode 100644
index 000000000000..d49cf0eef2f3
--- /dev/null
+++ b/net-mgmt/ramond/pkg-plist
@@ -0,0 +1,5 @@
+sbin/ramond
+%%DATADIR%%/ramond.conf.dtd
+%%DATADIR%%/demo.pl
+@dirrmtry %%DATADIR%%
+etc/ramond.conf.example