aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/rancid/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-28 17:13:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-28 17:13:55 +0000
commitdeff2fcb952b98b23a3d835ad997acb18db8ef82 (patch)
tree989074707e56093a12508ba4101f154931fa8a05 /net-mgmt/rancid/Makefile
parentb8be7df70921d61583865c64718793c6e713c737 (diff)
downloadports-deff2fcb952b98b23a3d835ad997acb18db8ef82.tar.gz
ports-deff2fcb952b98b23a3d835ad997acb18db8ef82.zip
Notes
Diffstat (limited to 'net-mgmt/rancid/Makefile')
-rw-r--r--net-mgmt/rancid/Makefile37
1 files changed, 28 insertions, 9 deletions
diff --git a/net-mgmt/rancid/Makefile b/net-mgmt/rancid/Makefile
index 3c834ec446f0..347978c990fb 100644
--- a/net-mgmt/rancid/Makefile
+++ b/net-mgmt/rancid/Makefile
@@ -7,9 +7,9 @@
PORTNAME= rancid
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.shrubbery.net/pub/rancid/
-#DISTNAME= ${PORTNAME}-2.3.rc1
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Really Awesome New Cisco confIg Differ
@@ -24,9 +24,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
USE_GMAKE= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= \
- --prefix=${PREFIX}/rancid
-
-MANPREFIX= ${PREFIX}/rancid
+ --prefix=${PREFIX}/ \
+ --localstatedir=${PREFIX}/var/${PORTNAME}/ \
+ --bindir=${PREFIX}/libexec/${PORTNAME}/ \
+ --sysconfdir=${PREFIX}/etc/${PORTNAME}/
MAN1= alogin.1 blogin.1 cat5rancid.1 clogin.1 control_rancid.1 \
cssrancid.1 elogin.1 erancid.1 f10rancid.1 flogin.1 fnrancid.1 \
@@ -40,31 +41,49 @@ MAN5= lg.conf.5 cloginrc.5 rancid.conf.5 router.db.5
OLDCONFIG_FILE1= bin/env
OLDCONFIG_FILE2= util/lg/lg.conf
-NEWCONFIG_FILES= etc/rancid.conf etc/lg.conf
+NEWERCONFIG_FILES1= etc/rancid.conf
+NEWERCONFIG_FILES2= etc/lg.conf
+NEWCONFIG_FILES= rancid.conf lg.conf
pre-everything::
@ ${ECHO} "Make sure your rancid repository is quit before upgrading; disable rancid cron jobs"
post-install:
- @ ${SED} -e "s:%%INSTDIR%%:${PREFIX}/rancid:g" pkg-message >${PKGMESSAGE}
+ ${LN} -s ${PREFIX}/libexec/${PORTNAME}/rancid-cvs ${PREFIX}/bin
+ ${LN} -s ${PREFIX}/libexec/${PORTNAME}/rancid-run ${PREFIX}/bin
+ @ ${SED} -e "s:%%INSTDIR%%:${PREFIX}:g" pkg-message >${PKGMESSAGE}
.if !defined(BATCH)
@ ${ECHO}
@ ${CAT} ${PKGMESSAGE}
@ ${ECHO}
.endif
.for file in ${NEWCONFIG_FILES}
- @ if [ -f ${PREFIX}/rancid/${file} ] ; then \
+ @ if [ -f ${PREFIX}/etc/${PORTNAME}/${file} ] ; then \
${ECHO} "WARNING: *** new ${file} file is installed as ${PREFIX}/rancid/${file}.sample"; \
${ECHO} " : *** review ${file}.sample for new/deprecated switches or install in place ${file}"; \
fi
.endfor
+ @ if [ -f ${PREFIX}/rancid/$NEWERCONFIG_FILE1} ] ; then \
+ ${ECHO} "WARNING: *** ${PREFIX}/rancid/${NEWERCONFIG_FILE1} has been replaced with "; \
+ ${ECHO} " : *** ${PREFIX}/etc/${PORTNAME}/rancid.conf. Merge from sample and old file "; \
+ fi
+ @ if [ -f ${PREFIX}/rancid/${NEWERCONFIG_FILE2} ] ; then \
+ ${ECHO} "WARNING: *** ${PREFIX}/rancid/${NEWERCONFIG_FILE2} has been replaced with "; \
+ ${ECHO} " : *** ${PREFIX}/etc/${PORTNAME}/lg.conf. Merge from sample and old file "; \
+ fi
+ @ if [ -f ${PREFIX}/rancid/${NEWERCONFIG_FILE1} -o \
+ -f ${PREFIX}/rancid/${NEWERCONFIG_FILE2} ] ; then \
+ ${ECHO} "WARNING: *** New CVS Repository will be stored ${PREFIX}/var/${PORTNAME}/ "; \
+ ${ECHO} " : *** Copy the repository if you want to keep the history "; \
+ fi
+
@ if [ -f ${PREFIX}/rancid/${OLDCONFIG_FILE1} ] ; then \
${ECHO} "WARNING: *** ${PREFIX}/rancid/${OLDCONFIG_FILE1} has been replaced with "; \
- ${ECHO} " : *** ${PREFIX}/rancid/etc/rancid.conf. Merge from sample and old file "; \
+ ${ECHO} " : *** ${PREFIX}/etc/${PORTNAME}/rancid.conf. Merge from sample and old file "; \
fi
@ if [ -f ${PREFIX}/rancid/${OLDCONFIG_FILE2} ] ; then \
${ECHO} "WARNING: *** ${PREFIX}/rancid/${OLDCONFIG_FILE2} has been replaced with "; \
- ${ECHO} " : *** ${PREFIX}/rancid/etc/lg.conf. Merge from sample and old file "; \
+ ${ECHO} " : *** ${PREFIX}/etc/${PORTNAME}/lg.conf. Merge from sample and old file "; \
fi
@ if [ -f ${PREFIX}/rancid/${OLDCONFIG_FILE1} -o \
-f ${PREFIX}/rancid/${OLDCONFIG_FILE2} ] ; then \