aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/rancid3/Makefile
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-08-17 18:13:36 +0000
committerMark Felder <feld@FreeBSD.org>2016-08-17 18:13:36 +0000
commit60ca6f044d7ee5af0720e69afdd8bd3cd81b3bc8 (patch)
treea0c007ed0f8921b02dd5183f139c98ffcf04fc1b /net-mgmt/rancid3/Makefile
parentb6618efec35b9ae47b2007b43ea8f85da837d111 (diff)
downloadports-60ca6f044d7ee5af0720e69afdd8bd3cd81b3bc8.tar.gz
ports-60ca6f044d7ee5af0720e69afdd8bd3cd81b3bc8.zip
Notes
Diffstat (limited to 'net-mgmt/rancid3/Makefile')
-rw-r--r--net-mgmt/rancid3/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/net-mgmt/rancid3/Makefile b/net-mgmt/rancid3/Makefile
index 000b0bb2040f..dcefa2c6ca02 100644
--- a/net-mgmt/rancid3/Makefile
+++ b/net-mgmt/rancid3/Makefile
@@ -34,15 +34,22 @@ NEWERCONFIG_FILES1= etc/rancid.conf
NEWERCONFIG_FILES2= etc/lg.conf
NEWCONFIG_FILES= rancid.conf lg.conf
-OPTIONS_DEFINE= SVN
+OPTIONS_DEFINE= COMWARE SVN
OPTIONS_DEFAULT=
+COMWARE_DESC= Add experimental support for Comware devices
SVN_DESC= Use Subversion instead of CVS
CONFLICTS= rancid-[0-9]*
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MCOMWARE}
+PLIST_SUB+= COMWARE=""
+.else
+PLIST_SUB+= COMWARE="@comment "
+.endif
+
.if ${PORT_OPTIONS:MSVN}
CONFIGURE_ARGS+= --with-svn
BUILD_DEPENDS+= svn:devel/subversion
@@ -57,6 +64,9 @@ pre-everything::
@ ${ECHO} "Make sure your rancid repository is quiet before upgrading; disable rancid cron jobs"
post-patch:
+.if ${PORT_OPTIONS:MCOMWARE}
+ ${CAT} ${FILESDIR}/comware_types.conf >> ${WRKSRC}/etc/rancid.types.base
+.endif
${REINPLACE_CMD} "s|par.1|rancid-par.1|" ${WRKSRC}/man/Makefile.in
${MV} ${WRKSRC}/man/par.1 ${WRKSRC}/man/rancid-par.1
${REINPLACE_CMD} "s|3des|3des-cbc|g" ${WRKSRC}/bin/*.in ${WRKSRC}/cloginrc.sample \
@@ -65,6 +75,10 @@ post-patch:
post-install:
${LN} -s ${PREFIX}/libexec/${PORTNAME}/rancid-cvs ${STAGEDIR}${PREFIX}/bin
${LN} -s ${PREFIX}/libexec/${PORTNAME}/rancid-run ${STAGEDIR}${PREFIX}/bin
+.if ${PORT_OPTIONS:MCOMWARE}
+ ${INSTALL_DATA} ${FILESDIR}/cmw.pm ${STAGEDIR}/${PREFIX}/lib/rancid
+ ${INSTALL_SCRIPT} ${FILESDIR}/cmwlogin ${STAGEDIR}/${PREFIX}/libexec/rancid
+.endif
.for file in ${NEWCONFIG_FILES}
@ if [ -f ${PREFIX}/etc/${PORTNAME}/${file} ] ; then \
${ECHO} "WARNING: *** new ${file} file is installed as ${PREFIX}/rancid/${file}.sample"; \