aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/rtrlib/Makefile
diff options
context:
space:
mode:
authorMahdi Mokhtari <mmokhi@FreeBSD.org>2018-02-03 15:01:06 +0000
committerMahdi Mokhtari <mmokhi@FreeBSD.org>2018-02-03 15:01:06 +0000
commit917c955c7e3b098e9e6e023866aa1f05cb709ae1 (patch)
treec29aefde23494fcaf8fa4eb884263dc09f5d86dd /net-mgmt/rtrlib/Makefile
parent9c95f146645c66280a2306f5c1b4d8f73b825346 (diff)
Notes
Diffstat (limited to 'net-mgmt/rtrlib/Makefile')
-rw-r--r--net-mgmt/rtrlib/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net-mgmt/rtrlib/Makefile b/net-mgmt/rtrlib/Makefile
new file mode 100644
index 000000000000..e0a975b3c4d8
--- /dev/null
+++ b/net-mgmt/rtrlib/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= rtrlib
+PORTVERSION= 0.5.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net-mgmt sysutils
+
+MAINTAINER= freebsd@bodems.net
+COMMENT= Open-source C implementation of the RPKI/Router Protocol client
+
+LICENSE= MIT
+
+LIB_DEPENDS= libssh.so:security/libssh
+BUILD_DEPENDS= cmake:devel/cmake
+
+USES= cmake
+USE_LDCONFIG= yes
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE=Release
+
+USE_GITHUB= yes
+GH_ACCOUNT= rtrlib
+
+.include <bsd.port.mk>