aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/seafile-gui
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-05-29 13:46:33 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-05-29 13:46:33 +0000
commit0d7897f162bf6144177bb01d96d3b26ecce8bb21 (patch)
tree028ee51afa96416b8ed1b52da6d28e8bb3941640 /net-mgmt/seafile-gui
parentb978ce4393fbbcf4936cd6e0b44ed52719b90616 (diff)
downloadports-0d7897f162bf6144177bb01d96d3b26ecce8bb21.tar.gz
ports-0d7897f162bf6144177bb01d96d3b26ecce8bb21.zip
Notes
Diffstat (limited to 'net-mgmt/seafile-gui')
-rw-r--r--net-mgmt/seafile-gui/Makefile22
-rw-r--r--net-mgmt/seafile-gui/distinfo4
-rw-r--r--net-mgmt/seafile-gui/files/patch-CMakeLists.txt49
-rw-r--r--net-mgmt/seafile-gui/pkg-plist2
4 files changed, 43 insertions, 34 deletions
diff --git a/net-mgmt/seafile-gui/Makefile b/net-mgmt/seafile-gui/Makefile
index 07c6594db5fa..956cd19878f6 100644
--- a/net-mgmt/seafile-gui/Makefile
+++ b/net-mgmt/seafile-gui/Makefile
@@ -1,17 +1,17 @@
# $FreeBSD$
PORTNAME= seafile-gui
-PORTVERSION= 4.1.0
-PORTREVISION= 1
+PORTVERSION= 5.1.1
DISTVERSIONPREFIX= v
-CATEGORIES= net-mgmt
+CATEGORIES= net-mgmt devel
MAINTAINER= ultima1252@gmail.com
-COMMENT= Seafile desktop client
+COMMENT= Open Source Cloud Storage (Client)
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS+= libglib-2.0.so:devel/glib20 \
+LIB_DEPENDS= libglib-2.0.so:devel/glib20 \
libsearpc.so:devel/libsearpc \
libseafile.so:net-mgmt/seafile \
libsqlite3.so:databases/sqlite3 \
@@ -22,18 +22,18 @@ USE_GITHUB= yes
GH_ACCOUNT= haiwen
GH_PROJECT= seafile-client
-USES= cmake pkgconfig
-USE_QT4= corelib dbus gui network \
- qmake_build moc_build rcc_build uic_build \
- linguist_build
+USES= compiler:c++11-lang cmake pkgconfig shebangfix
+SHEBANG_FILES= extensions/*.sh scripts/*.sh fsplugin/*.sh \
+ scripts/*.py
USE_OPENSSL= yes
+USE_QT5= core dbus gui network testlib widgets \
+ qmake_build buildtools_build linguisttools_build
INSTALLS_ICONS= yes
-LRELEASE= ${PREFIX}/bin/lrelease-qt4
CMAKE_ARGS+= -DCMAKE_INCLUDE_PATH:PATH=include/glib-2.0 \
-DOPENSSL_INCLUDE_DIRS=${OPENSSLINC} \
-DOPENSSL_LIBRARIES="-L${OPENSSLLIB} -lcrypto"
-CMAKE_BUILD_TYPE= Release
+OPTIONS_DEFINE= DEBUG
# Note that per PR 197984, cairo must be built with X11 and XCB options
# otherwise configure fails with "cairo needs x11 enabled" message
diff --git a/net-mgmt/seafile-gui/distinfo b/net-mgmt/seafile-gui/distinfo
index ce8aae31724b..f0345d0d6ae3 100644
--- a/net-mgmt/seafile-gui/distinfo
+++ b/net-mgmt/seafile-gui/distinfo
@@ -1,2 +1,2 @@
-SHA256 (haiwen-seafile-client-v4.1.0_GH0.tar.gz) = 3e50ad0b3885b794e96c289aa90d138ab3ac09e82417f88cb48822916e8fca13
-SIZE (haiwen-seafile-client-v4.1.0_GH0.tar.gz) = 1002135
+SHA256 (haiwen-seafile-client-v5.1.1_GH0.tar.gz) = 0148cbdb97dcd58e6ebec738c8f6bc476192f0b9156f0783199f1213c4d0322f
+SIZE (haiwen-seafile-client-v5.1.1_GH0.tar.gz) = 2123048
diff --git a/net-mgmt/seafile-gui/files/patch-CMakeLists.txt b/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
index d8743863792e..c735257a5083 100644
--- a/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
+++ b/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
@@ -1,24 +1,15 @@
---- CMakeLists.txt.orig 2015-02-05 08:43:51 UTC
+--- CMakeLists.txt.orig 2016-04-29 04:32:14 UTC
+++ CMakeLists.txt
-@@ -98,7 +98,7 @@ IF(USE_QT5)
- SET(USE_QT_LIBRARIES ${USE_QT_LIBRARIES} "WebKit" "WebKitWidgets")
- ADD_DEFINITIONS(-DHAVE_SHIBBOLETH_SUPPORT)
+@@ -81,7 +81,7 @@ IF (WIN32)
ENDIF()
-- IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-+ IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
- SET(USE_QT_LIBRARIES ${USE_QT_LIBRARIES} "DBus")
- ENDIF()
- FIND_PACKAGE(Qt5 REQUIRED ${USE_QT_LIBRARIES})
-@@ -113,7 +113,7 @@ ELSE()
- SET(QtWebKit "QtWebKit")
- ADD_DEFINITIONS(-DHAVE_SHIBBOLETH_SUPPORT)
- ENDIF()
-- IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
-+ IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
- SET(QtDBus "QtDBus")
- ENDIF()
- FIND_PACKAGE(Qt4 REQUIRED QtCore QtGui QtNetwork ${QtDBus} ${QtWebKit})
-@@ -263,7 +263,7 @@ PKG_CHECK_MODULES(LIBCCNET REQUIRED libc
+ SET(platform_specific_moc_headers src/ext-handler.h)
+ SET(platform_specific_sources src/ext-handler.cpp)
+-ELSEIF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD")
++ELSEIF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
+ INCLUDE_DIRECTORIES(${QT_QTDBUS_INCLUDE_DIR})
+ LINK_DIRECTORIES(${QT_QTDBUS_LIBRARIES})
+ SET(EXTRA_LIBS ${EXTRA_LIBS} ${QT_QTDBUS_LIBRARIES})
+@@ -318,7 +318,7 @@ PKG_CHECK_MODULES(LIBCCNET REQUIRED libc
PKG_CHECK_MODULES(LIBSEARPC REQUIRED libsearpc>=1.0)
@@ -26,4 +17,22 @@
+#PKG_CHECK_MODULES(OPENSSL REQUIRED openssl>=0.98)
PKG_CHECK_MODULES(LIBSEAFILE REQUIRED libseafile>=1.7)
- ####################
+
+@@ -515,7 +515,7 @@ IF (WIN32)
+ src/utils/registry.cpp
+ src/utils/utils-win.cpp
+ )
+-ELSEIF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD")
++ELSEIF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
+ LIST(APPEND utils_sources
+ src/utils/process-linux.cpp
+ )
+@@ -714,7 +714,7 @@ QT5_USE_MODULES(seafile-applet ${WEBKIT_
+ ENDIF()
+
+ ## QtBus
+-IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD")
++IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
+ TARGET_LINK_LIBRARIES(seafile-applet
+ ${QT_QTDBUS_LIBRARIES}
+ )
diff --git a/net-mgmt/seafile-gui/pkg-plist b/net-mgmt/seafile-gui/pkg-plist
index 8b2e6dd97a60..7b3fff74b962 100644
--- a/net-mgmt/seafile-gui/pkg-plist
+++ b/net-mgmt/seafile-gui/pkg-plist
@@ -1,4 +1,4 @@
-%%QT_BINDIR%%/seafile-applet
+bin/seafile-applet
share/applications/seafile.desktop
share/icons/hicolor/128x128/apps/seafile.png
share/icons/hicolor/16x16/apps/seafile.png