aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/smokeping
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2006-07-26 12:55:58 +0000
committerLars Thegler <lth@FreeBSD.org>2006-07-26 12:55:58 +0000
commitc96404e983e8157b45c5b7442a1d61b2789423d8 (patch)
tree25d274b7f0745b1ea9d7c6cfc68246056f15c559 /net-mgmt/smokeping
parent52c6c749268711a2ff76910ba9f14f0fbb0ff5de (diff)
downloadports-c96404e983e8157b45c5b7442a1d61b2789423d8.tar.gz
ports-c96404e983e8157b45c5b7442a1d61b2789423d8.zip
Notes
Diffstat (limited to 'net-mgmt/smokeping')
-rw-r--r--net-mgmt/smokeping/Makefile15
-rw-r--r--net-mgmt/smokeping/distinfo6
-rw-r--r--net-mgmt/smokeping/files/patch-bin-smokeping.dist2
-rw-r--r--net-mgmt/smokeping/files/patch-bin-tSmoke.dist2
-rw-r--r--net-mgmt/smokeping/files/patch-htdocs-smokeping.cgi.dist2
-rw-r--r--net-mgmt/smokeping/pkg-descr2
-rw-r--r--net-mgmt/smokeping/pkg-install25
-rw-r--r--net-mgmt/smokeping/pkg-plist3
8 files changed, 18 insertions, 39 deletions
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index 8218c674aad2..b0f549bae80f 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smokeping
-PORTVERSION= 2.0.8
+PORTVERSION= 2.0.9
CATEGORIES= net www
MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/smokeping/pub/
@@ -119,15 +119,12 @@ PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
USER= smokeping
+SMOKEPING_UID= 117
GROUP= smokeping
-WWW_USER= www
-WWW_UID= 80
-WWW_GROUP= www
-WWW_GID= 80
+SMOKEPING_GID= 117
-FILES_SUB= USER=${USER} GROUP=${GROUP} \
- WWW_USER=${WWW_USER} WWW_UID=${WWW_UID} \
- WWW_GROUP=${WWW_GROUP} WWW_GID=${WWW_GID} \
+FILES_SUB= USER=${USER} UID=${SMOKEPING_UID} \
+ GROUP=${GROUP} GID=${SMOKEPING_GID} \
PERL=${PERL} PREFIX=${PREFIX}
DOC1= CHANGES CONTRIBUTORS COPYING COPYRIGHT README TODO
@@ -262,7 +259,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/htdocs/smokeping.cgi ${PREFIX}/smokeping/htdocs/smokeping.cgi
@${CP} -R ${WRKSRC}/lib ${PREFIX}/smokeping/
@${MKDIR} ${PREFIX}/var/smokeping
- @${CHOWN} ${USER}:${GROUP} ${PREFIX}/var/smokeping
+ @${CHOWN} -R ${USER}:${GROUP} ${PREFIX}/var/smokeping
@${MKDIR} ${PREFIX}/smokeping/htdocs/img
@${CHOWN} ${WWW_USER}:${WWW_GROUP} ${PREFIX}/smokeping/htdocs/img
@if [ ! -f ${PREFIX}/etc/rc.d/smokeping.sh ]; then \
diff --git a/net-mgmt/smokeping/distinfo b/net-mgmt/smokeping/distinfo
index 0c0f5690fc6b..8191165b37a6 100644
--- a/net-mgmt/smokeping/distinfo
+++ b/net-mgmt/smokeping/distinfo
@@ -1,3 +1,3 @@
-MD5 (smokeping-2.0.8.tar.gz) = ad983643ddf04c50eb967a7aac50bf76
-SHA256 (smokeping-2.0.8.tar.gz) = 858347165709023d32a111467c6f36599c43dd3d78dff86c0a74f8906e138b22
-SIZE (smokeping-2.0.8.tar.gz) = 382530
+MD5 (smokeping-2.0.9.tar.gz) = 512c0bc38176451df7d664050b1283d9
+SHA256 (smokeping-2.0.9.tar.gz) = c9fc10d04afae31ac5283101f0211e842faf98784301178833ada1e3e4a0dcf5
+SIZE (smokeping-2.0.9.tar.gz) = 393777
diff --git a/net-mgmt/smokeping/files/patch-bin-smokeping.dist b/net-mgmt/smokeping/files/patch-bin-smokeping.dist
index a5283edc50b8..1221dc933b5c 100644
--- a/net-mgmt/smokeping/files/patch-bin-smokeping.dist
+++ b/net-mgmt/smokeping/files/patch-bin-smokeping.dist
@@ -9,7 +9,7 @@
-use lib qw(lib);
+use lib qw(%%PREFIX%%/smokeping/lib);
- use Smokeping 2.000008;
+ use Smokeping 2.000009;
-Smokeping::main("etc/config.dist");
+Smokeping::main("%%PREFIX%%/etc/smokeping/config");
diff --git a/net-mgmt/smokeping/files/patch-bin-tSmoke.dist b/net-mgmt/smokeping/files/patch-bin-tSmoke.dist
index 596e75ea47c0..0e07d3b0ed0c 100644
--- a/net-mgmt/smokeping/files/patch-bin-tSmoke.dist
+++ b/net-mgmt/smokeping/files/patch-bin-tSmoke.dist
@@ -14,7 +14,7 @@
-use lib "/usr/local/rrdtool-1.0.39/lib/perl";
+use lib qw(%%PREFIX%%/smokeping/lib);
- use Smokeping 2.000008;
+ use Smokeping 2.000009;
use Net::SMTP;
@@ -60,7 +59,7 @@
use RRDs;
diff --git a/net-mgmt/smokeping/files/patch-htdocs-smokeping.cgi.dist b/net-mgmt/smokeping/files/patch-htdocs-smokeping.cgi.dist
index 2e1fe745f3f3..ae61a621367a 100644
--- a/net-mgmt/smokeping/files/patch-htdocs-smokeping.cgi.dist
+++ b/net-mgmt/smokeping/files/patch-htdocs-smokeping.cgi.dist
@@ -10,7 +10,7 @@
+use lib qw(%%PREFIX%%/smokeping/lib);
use CGI::Carp qw(fatalsToBrowser);
- use Smokeping 2.000008;
+ use Smokeping 2.000009;
-Smokeping::cgi("/home/oetiker/data/projects/AADJ-smokeping/dist/etc/config");
+Smokeping::cgi("%%PREFIX%%/etc/smokeping/config");
diff --git a/net-mgmt/smokeping/pkg-descr b/net-mgmt/smokeping/pkg-descr
index 4142f66a6688..4be1823b5287 100644
--- a/net-mgmt/smokeping/pkg-descr
+++ b/net-mgmt/smokeping/pkg-descr
@@ -2,7 +2,7 @@ SmokePing is a latency logging and graphing system. It consists of a
daemon process which organizes the latency measurements and a CGI
which presents the graphs.
-WWW: http://people.ee.ethz.ch/~oetiker/webtools/smokeping/
+WWW: http://oss.oetiker.ch/smokeping/
--lars
lars@thegler.dk
diff --git a/net-mgmt/smokeping/pkg-install b/net-mgmt/smokeping/pkg-install
index b0c96b325b67..593c79f0135e 100644
--- a/net-mgmt/smokeping/pkg-install
+++ b/net-mgmt/smokeping/pkg-install
@@ -5,29 +5,8 @@
case $2 in
PRE-INSTALL)
- if ! pw groupshow %%WWW_GROUP%% 2>/dev/null 1>&2; then
- if pw groupadd %%WWW_GROUP%% -g %%WWW_GID%%; then
- echo 'Added group "%%WWW_GROUP%%".'
- else
- echo 'Adding group "%%WWW_GROUP%%" failed...'
- exit 1
- fi
- fi
-
- if ! pw usershow %%WWW_USER%% 2>/dev/null 1>&2; then
- if pw useradd %%WWW_USER%% -u %%WWW_UID%% -g %%WWW_GROUP%% -h - \
- -s /sbin/nologin -d /nonexistent \
- -c "World Wide Web Owner"; \
- then
- echo 'Added user "%%WWW_USER%%".'
- else
- echo 'Adding user "%%WWW_USER%%" failed...'
- exit 1
- fi
- fi
-
if ! pw groupshow %%GROUP%% 2>/dev/null 1>&2; then
- if pw groupadd %%GROUP%%; then
+ if pw groupadd %%GROUP%% -g %%GID%% ; then
echo 'Added group "%%GROUP%%".'
else
echo 'Adding group "%%GROUP%%" failed...'
@@ -36,7 +15,7 @@ PRE-INSTALL)
fi
if ! pw usershow %%USER%% 2>/dev/null 1>&2; then
- if pw useradd %%USER%% -g %%GROUP%% -h - \
+ if pw useradd %%USER%% -u %%UID%% -g %%GROUP%% -h - \
-s /nonexistent -c "SmokePing Daemon"; \
then
echo 'Added user "%%USER%%".'
diff --git a/net-mgmt/smokeping/pkg-plist b/net-mgmt/smokeping/pkg-plist
index 564a10446dc3..3a00a70d121b 100644
--- a/net-mgmt/smokeping/pkg-plist
+++ b/net-mgmt/smokeping/pkg-plist
@@ -113,6 +113,8 @@ smokeping/htdocs/smokeping.cgi
smokeping/lib/Smokeping.pm
smokeping/lib/Smokeping/ciscoRttMonMIB.pm
smokeping/lib/Smokeping/matchers/base.pm
+smokeping/lib/Smokeping/matchers/CheckLatency.pm
+smokeping/lib/Smokeping/matchers/CheckLoss.pm
smokeping/lib/Smokeping/matchers/Median.pm
smokeping/lib/Smokeping/matchers/Avgratio.pm
smokeping/lib/Smokeping/probes/AnotherDNS.pm
@@ -136,6 +138,7 @@ smokeping/lib/Smokeping/probes/LDAP.pm
smokeping/lib/Smokeping/probes/Radius.pm
smokeping/lib/Smokeping/probes/RemoteFPing.pm
smokeping/lib/Smokeping/probes/SSH.pm
+smokeping/lib/Smokeping/probes/TacacsPlus.pm
smokeping/lib/Smokeping/probes/TelnetIOSPing.pm
smokeping/lib/Smokeping/probes/base.pm
smokeping/lib/Smokeping/probes/basefork.pm