aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/snmp++
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 07:53:34 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-07 07:53:34 +0000
commit19e8252e6524c6552a6344163be3a81954f4dc11 (patch)
tree732ea434e6a327746d4ef534eb53788d5b3aa252 /net-mgmt/snmp++
parent934dc5b8166074365a934c04abe6fe97e3675ecb (diff)
downloadports-19e8252e6524c6552a6344163be3a81954f4dc11.tar.gz
ports-19e8252e6524c6552a6344163be3a81954f4dc11.zip
Notes
Diffstat (limited to 'net-mgmt/snmp++')
-rw-r--r--net-mgmt/snmp++/Makefile26
-rw-r--r--net-mgmt/snmp++/distinfo3
-rw-r--r--net-mgmt/snmp++/files/Makefile.FreeBSD48
-rw-r--r--net-mgmt/snmp++/pkg-descr16
-rw-r--r--net-mgmt/snmp++/pkg-plist41
5 files changed, 134 insertions, 0 deletions
diff --git a/net-mgmt/snmp++/Makefile b/net-mgmt/snmp++/Makefile
new file mode 100644
index 000000000000..b5a7abb5d5c3
--- /dev/null
+++ b/net-mgmt/snmp++/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: snmp++
+# Date created: 2007-05-14
+# Whom: nicolai@catpipe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= snmp++
+PORTVERSION= 3.2.22
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.agentpp.com/
+DISTNAME= ${PORTNAME}v${PORTVERSION}
+
+MAINTAINER= nicolai@catpipe.net
+COMMENT= SNMP C++ library with V3 support
+
+MAKEFILE= Makefile.FreeBSD
+WRKSRC= ${WRKDIR}/${PORTNAME}/src
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+post-extract:
+ ${CP} ${FILESDIR}/Makefile.FreeBSD ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/snmp++/distinfo b/net-mgmt/snmp++/distinfo
new file mode 100644
index 000000000000..47493405b7c5
--- /dev/null
+++ b/net-mgmt/snmp++/distinfo
@@ -0,0 +1,3 @@
+MD5 (snmp++v3.2.22.tar.gz) = 8cdbbca21d783e0120374ee1305368d7
+SHA256 (snmp++v3.2.22.tar.gz) = 229e4333ac1d011fc9e2d1d07196bac321dcdd19c54f21354b77caf2ecfc6316
+SIZE (snmp++v3.2.22.tar.gz) = 261879
diff --git a/net-mgmt/snmp++/files/Makefile.FreeBSD b/net-mgmt/snmp++/files/Makefile.FreeBSD
new file mode 100644
index 000000000000..5e730102d232
--- /dev/null
+++ b/net-mgmt/snmp++/files/Makefile.FreeBSD
@@ -0,0 +1,48 @@
+ ############################################################################
+ ##
+ ## Makefile.FreeBSD
+ ##
+ ## SNMP++v3.2.22
+ ## -----------------------------------------------
+ ## Copyright (c) 2001-2006 Jochen Katz, Frank Fock
+ ##
+ ## This software is based on SNMP++2.6 from Hewlett Packard:
+ ##
+ ## Copyright (c) 1996
+ ## Hewlett-Packard Company
+ ##
+ ## ATTENTION: USE OF THIS SOFTWARE IS SUBJECT TO THE FOLLOWING TERMS.
+ ## Permission to use, copy, modify, distribute andor sell this software
+ ## andor its documentation is hereby granted without fee. User agrees
+ ## to display the above copyright notice and this license notice in all
+ ## copies of the software and any documentation of the software. User
+ ## agrees to assume all liability for the use of the software;
+ ## Hewlett-Packard and Jochen Katz make no representations about the
+ ## suitability of this software for any purpose. It is provided
+ ## "AS-IS" without warranty of any kind, either express or implied. User
+ ## hereby grants a royalty-free license to any and all derivatives based
+ ## upon this software code base.
+ ##
+ ## Stuttgart, Germany, Tue Nov 21 22:12:16 CET 2006
+ ##
+ ##########################################################################*
+
+#
+# Flags: compiler options, search paths
+#
+
+COPTIONS = -D_XPG4_EXTENDED -D__unix -Wall -D_USE_OPENSSL# -DHEADER_DES_LOCL_H # -D_DEBUG
+TEMPOPTS = -I.
+
+USEROPTS = -g
+CFLAGS = $(COPTIONS) $(CINCDIRS) $(USEROPTS)
+LDFLAGS = $(CFLAGS)
+SHARED = -fPIC -shared
+
+#
+# Compilation rules
+#
+CC = g++
+LD = ld
+
+include common.mk
diff --git a/net-mgmt/snmp++/pkg-descr b/net-mgmt/snmp++/pkg-descr
new file mode 100644
index 000000000000..9ad99552e729
--- /dev/null
+++ b/net-mgmt/snmp++/pkg-descr
@@ -0,0 +1,16 @@
+SNMP++v3.x is a C++ API which supports SNMP v1, v2c, and v3.
+
+SNMP++v3.x is based on SNMP++v2.8 from HP* and extends it by support
+for SNMPv3 and a couple of bug fixes.
+
+The v3 support to SNMP++ and AGENT++ is provided by courtesy of
+Jochen Katz (katz07@agentpp.com).
+
+SNMP++v3.x extends the original SNMP++v2.8 by the following:
+# SNMPv3 including User Security Model (USM) with:
+# MD5 and SHA authentication
+# DES and IDEA privacy
+# Thread-safety
+# Bug-fixes
+
+WWW: http://www.agentpp.com/snmp_pp3_x/snmp_pp3_x.html for further details.
diff --git a/net-mgmt/snmp++/pkg-plist b/net-mgmt/snmp++/pkg-plist
new file mode 100644
index 000000000000..a0e465778c64
--- /dev/null
+++ b/net-mgmt/snmp++/pkg-plist
@@ -0,0 +1,41 @@
+include/snmp_pp/address.h
+include/snmp_pp/asn1.h
+include/snmp_pp/auth_priv.h
+include/snmp_pp/collect.h
+include/snmp_pp/collect1.h
+include/snmp_pp/collect2.h
+include/snmp_pp/config_snmp_pp.h
+include/snmp_pp/counter.h
+include/snmp_pp/ctr64.h
+include/snmp_pp/eventlist.h
+include/snmp_pp/eventlistholder.h
+include/snmp_pp/gauge.h
+include/snmp_pp/idea.h
+include/snmp_pp/integer.h
+include/snmp_pp/log.h
+include/snmp_pp/md5.h
+include/snmp_pp/mp_v3.h
+include/snmp_pp/msec.h
+include/snmp_pp/msgqueue.h
+include/snmp_pp/notifyqueue.h
+include/snmp_pp/octet.h
+include/snmp_pp/oid.h
+include/snmp_pp/oid_def.h
+include/snmp_pp/pdu.h
+include/snmp_pp/reentrant.h
+include/snmp_pp/sha.h
+include/snmp_pp/smi.h
+include/snmp_pp/smival.h
+include/snmp_pp/snmp_pp.h
+include/snmp_pp/snmperrs.h
+include/snmp_pp/snmpmsg.h
+include/snmp_pp/target.h
+include/snmp_pp/timetick.h
+include/snmp_pp/usm_v3.h
+include/snmp_pp/uxsnmp.h
+include/snmp_pp/v3.h
+include/snmp_pp/vb.h
+lib/libsnmp++.a
+lib/libsnmp++.so
+
+@dirrm include/snmp_pp