aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/snmp++
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-10-26 18:31:35 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-10-26 18:31:35 +0000
commit5fd91d2d9302908e7e38ae7526910d6b6eae66ad (patch)
tree06ad354e55cdfe3300f683e9527130b619b7a5b8 /net-mgmt/snmp++
parent628d08e8894b121ca6c5e615ad1bf772ddbd7135 (diff)
downloadports-5fd91d2d9302908e7e38ae7526910d6b6eae66ad.tar.gz
ports-5fd91d2d9302908e7e38ae7526910d6b6eae66ad.zip
Notes
Diffstat (limited to 'net-mgmt/snmp++')
-rw-r--r--net-mgmt/snmp++/Makefile2
-rw-r--r--net-mgmt/snmp++/files/patch-asn1.cpp14
2 files changed, 15 insertions, 1 deletions
diff --git a/net-mgmt/snmp++/Makefile b/net-mgmt/snmp++/Makefile
index a8565da56bd6..effa8f5d195e 100644
--- a/net-mgmt/snmp++/Makefile
+++ b/net-mgmt/snmp++/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp++
PORTVERSION= 3.2.22
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://www.agentpp.com/
DISTNAME= ${PORTNAME}v${PORTVERSION}
diff --git a/net-mgmt/snmp++/files/patch-asn1.cpp b/net-mgmt/snmp++/files/patch-asn1.cpp
new file mode 100644
index 000000000000..a5ede28c23bf
--- /dev/null
+++ b/net-mgmt/snmp++/files/patch-asn1.cpp
@@ -0,0 +1,14 @@
+--- asn1.cpp.orig 2007-10-26 20:24:08.000000000 +0200
++++ asn1.cpp 2007-10-26 20:25:34.000000000 +0200
+@@ -550,8 +550,9 @@ unsigned char * asn_parse_length( unsign
+ memcpy((char *)length, (char *)data + 1, (int)lengthbyte);
+ *length = ntohl(*length);
+ // ntohl even on ALPHA (DEC/COMPAQ) 64bit platforms works on 32bit int,
+- // whereas long is 64bit - therefore:
+-#ifdef __osf__
++ // whereas long is 64bit. The same is true for FreeBSD (and probably
++ // for lots of other platforms). Therefore:
++#if defined(__osf__) || defined(__FreeBSD__)
+ *length >>= (8 * ((sizeof(int)) - lengthbyte));
+ #else
+ *length >>= (8 * ((sizeof(long)) - lengthbyte));