aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/snmp4nagios/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-28 22:36:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-28 22:36:14 +0000
commitff271f99964216898a2fb2b96affbad7672eaebb (patch)
treecb75e376e187319d86aeda0c54ae00dac2f51d89 /net-mgmt/snmp4nagios/Makefile
parentfd5134686adaad0d6af00f07d2348ec42c011c0c (diff)
downloadports-ff271f99964216898a2fb2b96affbad7672eaebb.tar.gz
ports-ff271f99964216898a2fb2b96affbad7672eaebb.zip
Notes
Diffstat (limited to 'net-mgmt/snmp4nagios/Makefile')
-rw-r--r--net-mgmt/snmp4nagios/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-mgmt/snmp4nagios/Makefile b/net-mgmt/snmp4nagios/Makefile
new file mode 100644
index 000000000000..95f4757b11e5
--- /dev/null
+++ b/net-mgmt/snmp4nagios/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: snmp4nagios
+# Date created: 22 June 2008
+# Whom: Ryan Steinmetz
+#
+# $FreeBSD$
+#
+
+PORTNAME= SNMP4Nagios
+PORTVERSION= 0.4
+CATEGORIES= net-mgmt
+MASTER_SITES= SFE/snmp4nagios
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= rpsfa@rit.edu
+COMMENT= Vendor specific SNMP plugins for Nagios
+
+BUILD_DEPENDS= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp
+RUN_DEPENDS= snmpcheck:${PORTSDIR}/net-mgmt/net-snmp
+
+GNU_CONFIGURE= yes
+
+NAGIOSWWWDIR?= www/nagios
+NAGIOSDIR?= /var/spool/nagios
+
+OPTIONS= RRDTOOL "Build with rrdtool support" OFF
+
+CONFIGURE_ARGS= --sbindir=${PREFIX}/${NAGIOSWWWDIR}/cgi-bin \
+ --bindir=${PREFIX}/libexec/nagios \
+ --libexecdir=${PREFIX}/libexec/nagios \
+ --datadir=${PREFIX}/share \
+ --sysconfdir=${PREFIX}/etc/nagios \
+ --localstatedir=${NAGIOSDIR} \
+ --with-rrddir=${NAGIOSDIR}/snmp4nagios/rrd \
+ --with-pngdir=${NAGIOSDIR}/snmp4nagios/png \
+ --prefix=${PREFIX}
+
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_RRDTOOL)
+LIB_DEPENDS+= rrd:${PORTSDIR}/databases/rrdtool
+CONFIGURE_ARGS+=--with-rrd
+PLIST_SUB+= RRD=""
+.else
+CONFIGURE_ARGS+=--with-rrd=no
+PLIST_SUB+= RRD="@comment "
+.endif
+
+.include <bsd.port.post.mk>