aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/snmptt/Makefile
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2014-09-20 15:31:38 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2014-09-20 15:31:38 +0000
commitee24eeeb4459d1a6b2cd9849ead6f8a8a9303aca (patch)
tree18995f10b0fe02892819f5c10687548bc3ec244f /net-mgmt/snmptt/Makefile
parentd4773d7a7889305b77a71a2263b4120220121e50 (diff)
downloadports-ee24eeeb4459d1a6b2cd9849ead6f8a8a9303aca.tar.gz
ports-ee24eeeb4459d1a6b2cd9849ead6f8a8a9303aca.zip
Notes
Diffstat (limited to 'net-mgmt/snmptt/Makefile')
-rw-r--r--net-mgmt/snmptt/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/net-mgmt/snmptt/Makefile b/net-mgmt/snmptt/Makefile
index 0de9beca35a5..1fdd54ad1d8b 100644
--- a/net-mgmt/snmptt/Makefile
+++ b/net-mgmt/snmptt/Makefile
@@ -9,6 +9,9 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= nistor@snickers.org
COMMENT= SNMP trap handler/translator/swiss-army-knife
+NO_BUILD= yes
+LICENSE= GPLv2
+
USES= perl5 shebangfix tar:tgz
USE_RC_SUBR= snmptt
@@ -21,32 +24,26 @@ RUN_DEPENDS= net-snmp>=0:${PORTSDIR}/net-mgmt/net-snmp \
DOCS= faqs.html index.html layout1.css snmptt.html \
snmpttconvert.html snmpttconvertmib.html
+OPTIONS_DEFINE= DOCS
+
SCRIPTS= snmptt snmptt-net-snmp-test snmpttconvert \
snmpttconvertmib snmptthandler
SHEBANG_FILES= ${SCRIPTS}
-.include <bsd.port.pre.mk>
-
-do-build:
- @echo Skipping building ${PORTNAME}
do-install:
- @echo Installing ${PORTNAME} ${PORTVERSION}
-
.for _SCRIPT in ${SCRIPTS}
@${INSTALL_SCRIPT} ${WRKSRC}/${_SCRIPT} ${STAGEDIR}${PREFIX}/sbin
.endfor
${MKDIR} ${STAGEDIR}${PREFIX}/etc/snmp
- ${INSTALL_DATA} ${WRKSRC}/snmptt.ini ${STAGEDIR}${PREFIX}/etc/snmp/snmptt.ini-dist
- ${INSTALL_DATA} ${WRKSRC}/examples/snmptt.conf.generic ${STAGEDIR}${PREFIX}/etc/snmp/snmptt.conf.generic-dist
+ ${INSTALL_DATA} ${WRKSRC}/snmptt.ini ${STAGEDIR}${PREFIX}/etc/snmp/snmptt.ini.sample
+ ${INSTALL_DATA} ${WRKSRC}/examples/snmptt.conf.generic ${STAGEDIR}${PREFIX}/etc/snmp/snmptt.conf.generic.sample
-.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for _DOC in ${DOCS}
${INSTALL_MAN} ${WRKSRC}/docs/${_DOC} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>