aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/spectools
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2007-10-29 13:56:05 +0000
committerErwin Lansing <erwin@FreeBSD.org>2007-10-29 13:56:05 +0000
commit1b3455b6927cfb66c93221b7cabf0ec41ef697ed (patch)
treee19677f7d326f0de83a1bae4b24306d7029d0206 /net-mgmt/spectools
parent68ca94070f8ecd8f35100a3b223a9105d0d21e4f (diff)
downloadports-1b3455b6927cfb66c93221b7cabf0ec41ef697ed.tar.gz
ports-1b3455b6927cfb66c93221b7cabf0ec41ef697ed.zip
Notes
Diffstat (limited to 'net-mgmt/spectools')
-rw-r--r--net-mgmt/spectools/Makefile30
-rw-r--r--net-mgmt/spectools/distinfo6
-rw-r--r--net-mgmt/spectools/files/patch-configure39
-rw-r--r--net-mgmt/spectools/pkg-descr2
-rw-r--r--net-mgmt/spectools/pkg-message2
-rw-r--r--net-mgmt/spectools/pkg-plist7
6 files changed, 55 insertions, 31 deletions
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 9064490aee54..5cb86f78a4f1 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -1,25 +1,24 @@
-# New ports collection makefile for: wispy-tools
-# Date created: 13 Dec 2006
+# New ports collection makefile for: spectools
+# Date created: 09 Oct 2007
# Whom: Henrik Brix Andersen <henrik@brixandersen.dk>
#
# $FreeBSD$
#
-PORTNAME= wispy-tools
-PORTVERSION= 200609.r1
-PORTREVISION= 1
+PORTNAME= spectools
+PORTVERSION= 200710.r1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.kismetwireless.net/code/
-DISTNAME= wispy-tools-2006-09-R1
+DISTNAME= spectools-2007-10-R1
MAINTAINER= henrik@brixandersen.dk
-COMMENT= Tools for the 2.4GHz Wi-Spy spectrum analyzer from MetaGeek LLC
+COMMENT= Tools for the 2.4GHz Wi-Spy spectrum analyzers from MetaGeek LLC
LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
PORTDOCS= README
@@ -34,10 +33,10 @@ IGNORE= is unsupported on systems prior to FreeBSD v602101
IGNORE= is unsupported on systems prior to FreeBSD v700027
.endif
-ALL_TARGET= wispy_curses wispy_log wispy_raw
+ALL_TARGET= spectool_net spectool_raw
.if defined(WITH_GTK)
-ALL_TARGET+= wispy_gtk
+ALL_TARGET+= spectool_gtk
LIB_DEPENDS+= gtk:${PORTSDIR}/x11-toolkits/gtk20
PLIST_SUB= GTK=""
.else
@@ -45,17 +44,16 @@ PLIST_SUB= GTK="@comment "
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/wispy_curses ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/wispy_log ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/wispy_raw ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/spectool_net ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/spectool_raw ${PREFIX}/bin
.if defined(WITH_GTK)
- ${INSTALL_PROGRAM} ${WRKSRC}/wispy_gtk ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/spectool_gtk ${PREFIX}/bin
.endif
post-install:
-.ifndef(NOPORTDOCS)
+.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
diff --git a/net-mgmt/spectools/distinfo b/net-mgmt/spectools/distinfo
index 2a41efceaac6..158aaa4b1585 100644
--- a/net-mgmt/spectools/distinfo
+++ b/net-mgmt/spectools/distinfo
@@ -1,3 +1,3 @@
-MD5 (wispy-tools-2006-09-R1.tar.gz) = c05a18813bca976450262f7b0e98b0cb
-SHA256 (wispy-tools-2006-09-R1.tar.gz) = 41b25d1d63f01f596925dbd39389668b9d4169b28e5b8a2e00e0ac66574d330f
-SIZE (wispy-tools-2006-09-R1.tar.gz) = 135474
+MD5 (spectools-2007-10-R1.tar.gz) = f38ac4d04680a2b62d9bfb9cff6b2ab3
+SHA256 (spectools-2007-10-R1.tar.gz) = e11b150db4c562f365ed77968bf1a3d02a33ddb55c88765656a77cf555e471b7
+SIZE (spectools-2007-10-R1.tar.gz) = 190822
diff --git a/net-mgmt/spectools/files/patch-configure b/net-mgmt/spectools/files/patch-configure
index 41b13addb85b..78c2e8a6e9ae 100644
--- a/net-mgmt/spectools/files/patch-configure
+++ b/net-mgmt/spectools/files/patch-configure
@@ -1,6 +1,19 @@
---- configure.in.orig Sun Nov 19 18:04:52 2006
-+++ configure.in Sun Nov 19 18:01:44 2006
-@@ -204,7 +204,7 @@
+--- configure.in.orig 2007-10-08 18:29:44.000000000 +0200
++++ configure.in 2007-10-09 18:28:21.000000000 +0200
+@@ -135,10 +135,10 @@ dnl Let them override the gtk version
+ AC_ARG_WITH(gtk-version,
+ [ --with-gtk-version=\[1|2\] Force a GTK version instead of autodetect ],
+ [
+- if test "$withval" == "1" ; then
++ if test "$withval" = "1" ; then
+ AC_MSG_WARN(*** Overriding GTK detection to use GTK1 only ***)
+ forcegtk=1
+- elif test "$withval" == "2" ; then
++ elif test "$withval" = "2" ; then
+ AC_MSG_WARN(*** Overriding GTK detection to use GTK2 only ***)
+ forcegtk=2
+ fi
+@@ -193,7 +193,7 @@ if test "$GTK_CONFIG"x != "x"; then
GTKLIBS="$LIBS"
LIBS="$olfl"
@@ -9,9 +22,23 @@
AC_DEFINE(HAVE_LIB_GTK2, 1, we have libgtk2.x)
else
AC_MSG_WARN(*** GTK1 being used. GTK2 is preferred and GTK1 support may vanish in future releases ***)
---- configure.orig Sun Nov 19 18:04:45 2006
-+++ configure Sun Nov 19 18:01:18 2006
-@@ -4185,7 +4185,7 @@
+--- configure.orig 2007-10-08 18:29:44.000000000 +0200
++++ configure 2007-10-09 18:32:58.000000000 +0200
+@@ -4573,11 +4573,11 @@ fi
+ # Check whether --with-gtk-version was given.
+ if test "${with_gtk_version+set}" = set; then
+ withval=$with_gtk_version;
+- if test "$withval" == "1" ; then
++ if test "$withval" = "1" ; then
+ { echo "$as_me:$LINENO: WARNING: *** Overriding GTK detection to use GTK1 only ***" >&5
+ echo "$as_me: WARNING: *** Overriding GTK detection to use GTK1 only ***" >&2;}
+ forcegtk=1
+- elif test "$withval" == "2" ; then
++ elif test "$withval" = "2" ; then
+ { echo "$as_me:$LINENO: WARNING: *** Overriding GTK detection to use GTK2 only ***" >&5
+ echo "$as_me: WARNING: *** Overriding GTK detection to use GTK2 only ***" >&2;}
+ forcegtk=2
+@@ -4889,7 +4889,7 @@ _ACEOF
GTKLIBS="$LIBS"
LIBS="$olfl"
diff --git a/net-mgmt/spectools/pkg-descr b/net-mgmt/spectools/pkg-descr
index f4e1f0be4855..58e74b18dfff 100644
--- a/net-mgmt/spectools/pkg-descr
+++ b/net-mgmt/spectools/pkg-descr
@@ -1,4 +1,4 @@
A set of open source tools for accessing the 2.4GHz Wi-Spy USB
spectrum analyzer by Metageek LLC, http://www.metageek.net/
-WWW: http://www.kismetwireless.net/wispy.shtml
+WWW: http://www.kismetwireless.net/spectools/
diff --git a/net-mgmt/spectools/pkg-message b/net-mgmt/spectools/pkg-message
index 4845df27dcb4..e22659b3d3a0 100644
--- a/net-mgmt/spectools/pkg-message
+++ b/net-mgmt/spectools/pkg-message
@@ -1,4 +1,4 @@
====
In order to use the tools you need read/write access to the ugen(4)
-device node corresponding to the Wi-Spy device.
+device node(s) corresponding to the Wi-Spy device(s).
====
diff --git a/net-mgmt/spectools/pkg-plist b/net-mgmt/spectools/pkg-plist
index 9d17d8dbc686..b8a8ec06016e 100644
--- a/net-mgmt/spectools/pkg-plist
+++ b/net-mgmt/spectools/pkg-plist
@@ -1,4 +1,3 @@
-bin/wispy_curses
-%%GTK%%bin/wispy_gtk
-bin/wispy_log
-bin/wispy_raw
+%%GTK%%bin/spectool_gtk
+bin/spectool_net
+bin/spectool_raw