aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/sting
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-05-22 08:35:10 +0000
committerWill Andrews <will@FreeBSD.org>2000-05-22 08:35:10 +0000
commitda5eed337ab4d6dbd0c193d60de50f3f95080071 (patch)
treefd8e3990e5bee3544b9385cb1641cbd063c5535d /net-mgmt/sting
parent471943a49eef231a51f7482cf87adab95fd15d83 (diff)
downloadports-da5eed337ab4d6dbd0c193d60de50f3f95080071.tar.gz
ports-da5eed337ab4d6dbd0c193d60de50f3f95080071.zip
Notes
Diffstat (limited to 'net-mgmt/sting')
-rw-r--r--net-mgmt/sting/Makefile24
-rw-r--r--net-mgmt/sting/distinfo1
-rw-r--r--net-mgmt/sting/files/patch-aa11
-rw-r--r--net-mgmt/sting/files/patch-ab11
-rw-r--r--net-mgmt/sting/files/patch-ac11
-rw-r--r--net-mgmt/sting/pkg-comment1
-rw-r--r--net-mgmt/sting/pkg-descr10
-rw-r--r--net-mgmt/sting/pkg-plist2
8 files changed, 71 insertions, 0 deletions
diff --git a/net-mgmt/sting/Makefile b/net-mgmt/sting/Makefile
new file mode 100644
index 000000000000..3f70effc3bc7
--- /dev/null
+++ b/net-mgmt/sting/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: sting
+# Date created: 10 May 2000
+# Whom: benno@netizen.com.au
+#
+# $FreeBSD$
+#
+
+PORTNAME= sting
+PORTVERSION= 0.7
+CATEGORIES= net
+MASTER_SITES= http://www.cs.washington.edu/homes/savage/sting/
+DISTNAME= sting
+
+MAINTAINER= kbyanc@posi.net
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sting ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/README.sting
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/sting/distinfo b/net-mgmt/sting/distinfo
new file mode 100644
index 000000000000..a5ae317e5f3b
--- /dev/null
+++ b/net-mgmt/sting/distinfo
@@ -0,0 +1 @@
+MD5 (sting.tar.gz) = 7b0d22f96bbde22f94ed5eb0f4a39e29
diff --git a/net-mgmt/sting/files/patch-aa b/net-mgmt/sting/files/patch-aa
new file mode 100644
index 000000000000..87417fd343fa
--- /dev/null
+++ b/net-mgmt/sting/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile Fri Nov 5 06:00:22 1999
++++ Makefile.new Wed May 10 11:11:23 2000
+@@ -42,7 +42,7 @@
+ INCLS = -I. -I$(LIBPCAP)
+ DEFS = -DRETSIGTYPE=void -DHAVE_SIGACTION=1
+ CFLAGS = -Wall $(CCOPT) $(DEFS) $(INCLS)
+-LIBS = -lm $(LIBPCAP)/libpcap.a
++LIBS = -lm -lpcap
+
+ all: sting
+
diff --git a/net-mgmt/sting/files/patch-ab b/net-mgmt/sting/files/patch-ab
new file mode 100644
index 000000000000..11ec20827f7b
--- /dev/null
+++ b/net-mgmt/sting/files/patch-ab
@@ -0,0 +1,11 @@
+--- gmt2local.c Fri Nov 5 06:00:22 1999
++++ gmt2local.c.new Wed May 10 11:10:05 2000
+@@ -32,7 +32,7 @@
+ #include <time.h>
+ #endif
+
+-#include "gnuc.h"
++/* #include "gnuc.h" */
+ #ifdef HAVE_OS_PROTO_H
+ #include "os-proto.h"
+ #endif
diff --git a/net-mgmt/sting/files/patch-ac b/net-mgmt/sting/files/patch-ac
new file mode 100644
index 000000000000..346d2c9cb3ef
--- /dev/null
+++ b/net-mgmt/sting/files/patch-ac
@@ -0,0 +1,11 @@
+--- setsignal.c Fri Nov 5 06:00:22 1999
++++ setsignal.c.new Wed May 10 11:10:59 2000
+@@ -34,7 +34,7 @@
+ #include <string.h>
+ #endif
+
+-#include "gnuc.h"
++/* #include "gnuc.h" */
+ #ifdef HAVE_OS_PROTO_H
+ #include "os-proto.h"
+ #endif
diff --git a/net-mgmt/sting/pkg-comment b/net-mgmt/sting/pkg-comment
new file mode 100644
index 000000000000..d1050a3c894e
--- /dev/null
+++ b/net-mgmt/sting/pkg-comment
@@ -0,0 +1 @@
+A tool that measures end-to-end TCP connection characteristics
diff --git a/net-mgmt/sting/pkg-descr b/net-mgmt/sting/pkg-descr
new file mode 100644
index 000000000000..a989bbf4db19
--- /dev/null
+++ b/net-mgmt/sting/pkg-descr
@@ -0,0 +1,10 @@
+sting is a TCP-based network measurement tool that measures end-to-end
+network path characteristics. sting is unique because it can estimate
+one-way properties, such as loss rate, through careful manipulation and
+observation of TCP behavior. In addition, using TCP allows sting to
+leverage the existing Internet infrastructure -- any TCP server can be
+used as a de facto measurement service -- and it avoids increasing
+problems with ICMP-based network measurement (blocking, spoofing, rate
+limiting, etc).
+
+WWW: http://www.cs.washington.edu/homes/savage/sting/
diff --git a/net-mgmt/sting/pkg-plist b/net-mgmt/sting/pkg-plist
new file mode 100644
index 000000000000..8fb50dd64617
--- /dev/null
+++ b/net-mgmt/sting/pkg-plist
@@ -0,0 +1,2 @@
+bin/sting
+share/doc/README.sting