aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/tcptrack
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-11-07 00:24:43 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-11-07 00:24:43 +0000
commitbccb3194668d6bd641f1d5f5b1b97ca06707fc38 (patch)
tree9854585d62d5d7e5e036357d247655f28c563868 /net-mgmt/tcptrack
parent84453d1c9357f97df3295a559fb85671406c4b54 (diff)
downloadports-bccb3194668d6bd641f1d5f5b1b97ca06707fc38.tar.gz
ports-bccb3194668d6bd641f1d5f5b1b97ca06707fc38.zip
Notes
Diffstat (limited to 'net-mgmt/tcptrack')
-rw-r--r--net-mgmt/tcptrack/Makefile30
-rw-r--r--net-mgmt/tcptrack/distinfo2
-rw-r--r--net-mgmt/tcptrack/pkg-descr11
3 files changed, 43 insertions, 0 deletions
diff --git a/net-mgmt/tcptrack/Makefile b/net-mgmt/tcptrack/Makefile
new file mode 100644
index 000000000000..2a8a10b3151d
--- /dev/null
+++ b/net-mgmt/tcptrack/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: tcptrack
+# Date created: 2004-10-11
+# Whom: Tor Halvard "Squat" Furulund <squat@squat.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcptrack
+PORTVERSION= 1.1.4
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.rhythm.cx/~steve/devel/tcptrack/
+MASTER_SITE_SUBDIR= release/${PORTVERSION}/source/
+
+MAINTAINER= squat@squat.no
+COMMENT= Packet sniffer which displays TCP information like top(1)
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+PLIST_FILES= bin/tcptrack
+MAN1= tcptrack.1
+PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/tcptrack/distinfo b/net-mgmt/tcptrack/distinfo
new file mode 100644
index 000000000000..d18dd79ae80c
--- /dev/null
+++ b/net-mgmt/tcptrack/distinfo
@@ -0,0 +1,2 @@
+MD5 (tcptrack-1.1.4.tar.gz) = a4e2b556b8ea607d8bfd786e3f78f8f7
+SIZE (tcptrack-1.1.4.tar.gz) = 111945
diff --git a/net-mgmt/tcptrack/pkg-descr b/net-mgmt/tcptrack/pkg-descr
new file mode 100644
index 000000000000..aac8d4f68170
--- /dev/null
+++ b/net-mgmt/tcptrack/pkg-descr
@@ -0,0 +1,11 @@
+tcptrack is a sniffer which displays information about TCP connections it
+sees on a network interface. It passively watches for connections on the
+network interface, keeps track of their state and displays a list of
+connections in a manner similar to the unix 'top' command. It displays
+source and destination addresses and ports, connection state, idle time, and
+bandwidth usage.
+
+WWW: http://www.rhythm.cx/~steve/devel/tcptrack
+
+- Squat
+squat@squat.no