aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/vidalia/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-30 12:03:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-30 12:03:25 +0000
commit2f467433e949f2a117018e146fb180a2b3486dc1 (patch)
treed528b8c2cb609539ded236c2b2bd8e6fee3a3265 /net-mgmt/vidalia/Makefile
parent9ebb415877fc81d7952ee1429b6530dd0fe56739 (diff)
- Update to 0.1.9
PR: 127323 Submitted by: Fabian Keil <fk@fabiankeil.de> (maintainer)
Notes
Notes: svn path=/head/; revision=221035
Diffstat (limited to 'net-mgmt/vidalia/Makefile')
-rw-r--r--net-mgmt/vidalia/Makefile22
1 files changed, 4 insertions, 18 deletions
diff --git a/net-mgmt/vidalia/Makefile b/net-mgmt/vidalia/Makefile
index ee50973bb683..8cc59b089dc4 100644
--- a/net-mgmt/vidalia/Makefile
+++ b/net-mgmt/vidalia/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vidalia
-PORTVERSION= 0.0.16
-PORTREVISION= 1
+PORTVERSION= 0.1.9
CATEGORIES= net-mgmt security
MASTER_SITES= http://www.vidalia-project.net:8001/vidalia/\
http://tor.eff.org/dist/vidalia-bundles/
@@ -15,14 +14,10 @@ MASTER_SITES= http://www.vidalia-project.net:8001/vidalia/\
MAINTAINER= fk@fabiankeil.de
COMMENT= A graphical Tor controller based on Qt 4.x
-PLIST_FILES= bin/${PORTNAME}
-MAN1= ${PORTNAME}.1
-
-HAS_CONFIGURE= yes
-
-USE_GMAKE= yes
+USE_CMAKE= yes
+CMAKE_USE_PTHREAD= yes
USE_QT_VER= 4
-QT_COMPONENTS= gui moc qmake rcc uic network xml linguist
+QT_COMPONENTS= gui moc_build qmake_build rcc_build uic_build network xml linguist
HAVE_TOR!= if pkg_info -I tor-\* >/dev/null 2>&1 ; then ${ECHO} YES; fi
@@ -59,13 +54,4 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/tor:${PORTSDIR}/security/tor-devel
RUN_DEPENDS+= ${LOCALBASE}/bin/tor:${PORTSDIR}/security/tor
.endif
-post-extract:
- ${REINPLACE_CMD} -e 's@/bin/lrelease@/bin/lrelease-qt4@' ${WRKSRC}/configure
-
-post-configure:
-.if defined(TOR_CONTROL_ADDR)
- ${REINPLACE_CMD} -e 's@127\.0\.0\.1@${TOR_CONTROL_ADDR}@' ${WRKSRC}/src/config/torsettings.cpp
-.endif
- ${REINPLACE_CMD} -E -e 's@(INCPATH +=)@\1 -I${LOCALBASE}/include@' -e 's@/share(/man/man1)@\1@' ${WRKSRC}/Makefile
-
.include <bsd.port.post.mk>