aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/xymon-client
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-01-28 11:56:56 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-01-28 11:56:56 +0000
commitcff03bf167c582af08e6ad8185dc3952552f6514 (patch)
tree8a567b4ccb5c36456e47cb09b4159db8b9e859ae /net-mgmt/xymon-client
parent57855df4a576c537e42d982dfdda8749275ccdbe (diff)
downloadports-cff03bf167c582af08e6ad8185dc3952552f6514.tar.gz
ports-cff03bf167c582af08e6ad8185dc3952552f6514.zip
Notes
Diffstat (limited to 'net-mgmt/xymon-client')
-rw-r--r--net-mgmt/xymon-client/Makefile38
-rw-r--r--net-mgmt/xymon-client/distinfo3
-rw-r--r--net-mgmt/xymon-client/files/Makefile30
-rw-r--r--net-mgmt/xymon-client/files/hobbit-client.sh.in25
-rw-r--r--net-mgmt/xymon-client/files/patch-Makefile18
-rw-r--r--net-mgmt/xymon-client/pkg-descr15
-rw-r--r--net-mgmt/xymon-client/pkg-plist49
7 files changed, 178 insertions, 0 deletions
diff --git a/net-mgmt/xymon-client/Makefile b/net-mgmt/xymon-client/Makefile
new file mode 100644
index 000000000000..8432be3d2205
--- /dev/null
+++ b/net-mgmt/xymon-client/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: hobbit-client
+# Date created: 24 Jan 2008
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= hobbit
+PORTVERSION= 4.2.0
+CATEGORIES= net-mgmt www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= hobbitmon
+PKGNAMESUFFIX= -client${PKGNAMESUFFIX2}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= System for monitoring servers and networks - Client
+
+# Options
+BBUSER?= hobbit
+BBHOSTIP?= 127.0.0.1
+
+USE_GMAKE= yes
+CONFIGURE_ENV= MAKE=gmake
+MAKE_ENV+= BBUSER="${BBUSER}"
+MAKE_ENV+= BBHOSTIP="${BBHOSTIP}"
+USE_RC_SUBR= hobbit-client.sh
+PLIST_SUB+= BBUSER="${BBUSER}"
+
+# Configure script is interactive
+do-configure:
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}/
+
+pre-install:
+ if ! pw groupshow ${BBUSER}; then pw groupadd ${BBUSER} -g 280; fi
+ if ! pw usershow ${BBUSER}; then pw useradd ${BBUSER} -g ${BBUSER} -u 280 \
+ -h - -d ${NONEXISTENT} -s /usr/sbin/nologin -c "Hobbit Monitor"; fi
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/xymon-client/distinfo b/net-mgmt/xymon-client/distinfo
new file mode 100644
index 000000000000..ae7b9ebf2057
--- /dev/null
+++ b/net-mgmt/xymon-client/distinfo
@@ -0,0 +1,3 @@
+MD5 (hobbit-4.2.0.tar.gz) = 120fd876b8494e249de0bf0366fcdd9a
+SHA256 (hobbit-4.2.0.tar.gz) = 0c2ab43668921316ec435e736a499853d047f0f88a87aa362ccbb8637d2c8d3e
+SIZE (hobbit-4.2.0.tar.gz) = 2341167
diff --git a/net-mgmt/xymon-client/files/Makefile b/net-mgmt/xymon-client/files/Makefile
new file mode 100644
index 000000000000..94df6fed50fc
--- /dev/null
+++ b/net-mgmt/xymon-client/files/Makefile
@@ -0,0 +1,30 @@
+# Toplevel Makefile for Hobbit
+# $FreeBSD$
+BUILDTOPDIR=`pwd`
+CLIENTONLY = yes
+LOCALCLIENT = no
+
+# configure settings for Hobbit
+#
+# Toplevel dir
+BBTOPDIR = ${PREFIX}/www/hobbit
+# Server home dir for etc/, www/
+BBHOME = ${PREFIX}/www/hobbit/client
+
+# hobbit settings follows
+#
+# Username running hobbit
+#BBUSER = nobody
+# Hobbit server IP-address
+#BBHOSTIP = 127.0.0.1
+# Large File Support settings
+LFSDEF = -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+
+include build/Makefile.FreeBSD
+
+
+#
+# Add local CFLAGS etc. settings here
+
+include build/Makefile.rules
+
diff --git a/net-mgmt/xymon-client/files/hobbit-client.sh.in b/net-mgmt/xymon-client/files/hobbit-client.sh.in
new file mode 100644
index 000000000000..38c480c247e7
--- /dev/null
+++ b/net-mgmt/xymon-client/files/hobbit-client.sh.in
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: hobbit_client
+# REQUIRE: DAEMON
+
+. "%%RC_SUBR%%"
+
+name="hobbit_client"
+rcvar=`set_rcvar`
+
+load_rc_config "$name"
+: ${hobbit_client_enable:="NO"}
+
+command="%%PREFIX%%/www/hobbit/client/runclient.sh"
+start_cmd="%%PREFIX%%/www/hobbit/client/runclient.sh start"
+stop_cmd="%%PREFIX%%/www/hobbit/client/runclient.sh stop"
+status_cmd="%%PREFIX%%/www/hobbit/client/runclient.sh status"
+reload_cmd="%%PREFIX%%/www/hobbit/client/runclient.sh restart"
+pidfile="%%PREFIX%%/www/hobbit/client/logs/clientlaunch.`hostname`.pid"
+
+run_rc_command "$1"
+# eof
diff --git a/net-mgmt/xymon-client/files/patch-Makefile b/net-mgmt/xymon-client/files/patch-Makefile
new file mode 100644
index 000000000000..77d6d6045367
--- /dev/null
+++ b/net-mgmt/xymon-client/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- client/Makefile.orig 2006-08-09 22:09:58.000000000 +0200
++++ client/Makefile 2008-01-28 12:01:34.000000000 +0100
+@@ -63,12 +63,12 @@
+ if test ! -d $(INSTALLROOT)$(BBHOME)/tmp ; then mkdir -p $(INSTALLROOT)$(BBHOME)/tmp ; fi
+ if test ! -d $(INSTALLROOT)$(BBHOME)/logs; then mkdir -p $(INSTALLROOT)$(BBHOME)/logs; fi
+ if test ! -d $(INSTALLROOT)$(BBHOME)/ext ; then mkdir -p $(INSTALLROOT)$(BBHOME)/ext ; fi
+- if test ! -f $(INSTALLROOT)$(BBHOME)/etc/localclient.cfg ; then cp localclient.cfg $(INSTALLROOT)$(BBHOME)/etc/ ; fi
++ if test ! -f $(INSTALLROOT)$(BBHOME)/etc/localclient.cfg ; then cp localclient.cfg $(INSTALLROOT)$(BBHOME)/etc/localclient.cfg-dist ; fi
+ cp -fp runclient.sh $(INSTALLROOT)$(BBHOME)
+ cp -fp $(PROGRAMS) hobbitclient*.sh $(COMMONTOOLS) $(EXTRATOOLS) $(INSTALLROOT)$(BBHOME)/bin/
+
+- ../build/merge-sects clientlaunch.cfg $(INSTALLROOT)$(BBHOME)/etc/clientlaunch.cfg
+- ../build/merge-lines hobbitclient.cfg $(INSTALLROOT)$(BBHOME)/etc/hobbitclient.cfg
++ ../build/merge-sects clientlaunch.cfg $(INSTALLROOT)$(BBHOME)/etc/clientlaunch.cfg-dist
++ ../build/merge-lines hobbitclient.cfg $(INSTALLROOT)$(BBHOME)/etc/hobbitclient.cfg-dist
+ ifndef PKGBUILD
+ chown -R $(BBUSER) $(INSTALLROOT)$(BBHOME)
+ endif
diff --git a/net-mgmt/xymon-client/pkg-descr b/net-mgmt/xymon-client/pkg-descr
new file mode 100644
index 000000000000..848c6c0f2445
--- /dev/null
+++ b/net-mgmt/xymon-client/pkg-descr
@@ -0,0 +1,15 @@
+Hobbit is a system for monitoring servers and networks. It has a great deal
+of inspiration from the Big Brother monitor, but unlike Big Brother it is
+designed to work well whether you need to monitor small network with just
+a handful of hosts, or large networks with thousands of hosts.
+
+Hobbit is the successor to the bbgen toolkit, which has been available as
+an add-on to Big Brother since late 2002. The name change was decided upon
+when Hobbit acquired enough functionality to be a stand-alone product.
+The tools that formed the bbgen toolkit are still present in Hobbit
+and are quite important for it, so if you have used bbgen before,
+Hobbit will seem quite familiar.
+
+This is the client.
+
+WWW: http://hobbitmon.sourceforge.net/
diff --git a/net-mgmt/xymon-client/pkg-plist b/net-mgmt/xymon-client/pkg-plist
new file mode 100644
index 000000000000..68a253276fa8
--- /dev/null
+++ b/net-mgmt/xymon-client/pkg-plist
@@ -0,0 +1,49 @@
+@exec if ! pw groupshow %%BBUSER%% 2>/dev/null; then pw groupadd %%BBUSER%% -g 280; fi
+@exec if ! pw usershow %%BBUSER%% 2>/dev/null; then pw useradd %%BBUSER%% -g %%BBUSER%% -u 280 -h - -d /nonexistent -s /usr/sbin/nologin -c "Hobbit Monitor"; fi
+@unexec if pw usershow %%BBUSER%%; then pw userdel %%BBUSER%%; fi
+%%WWWDIR%%/client/bin/bb
+%%WWWDIR%%/client/bin/bbcmd
+%%WWWDIR%%/client/bin/bbdigest
+%%WWWDIR%%/client/bin/bbhostgrep
+%%WWWDIR%%/client/bin/bbhostshow
+%%WWWDIR%%/client/bin/clientupdate
+%%WWWDIR%%/client/bin/freebsd-meminfo
+%%WWWDIR%%/client/bin/hobbitclient-aix.sh
+%%WWWDIR%%/client/bin/hobbitclient-darwin.sh
+%%WWWDIR%%/client/bin/hobbitclient-freebsd.sh
+%%WWWDIR%%/client/bin/hobbitclient-hp-ux.sh
+%%WWWDIR%%/client/bin/hobbitclient-irix.sh
+%%WWWDIR%%/client/bin/hobbitclient-linux.sh
+%%WWWDIR%%/client/bin/hobbitclient-netbsd.sh
+%%WWWDIR%%/client/bin/hobbitclient-openbsd.sh
+%%WWWDIR%%/client/bin/hobbitclient-osf1.sh
+%%WWWDIR%%/client/bin/hobbitclient-sco_sv.sh
+%%WWWDIR%%/client/bin/hobbitclient-sunos.sh
+%%WWWDIR%%/client/bin/hobbitclient.sh
+%%WWWDIR%%/client/bin/hobbitlaunch
+%%WWWDIR%%/client/bin/logfetch
+%%WWWDIR%%/client/bin/msgcache
+%%WWWDIR%%/client/bin/orcahobbit
+@unexec if cmp -s %D/%%WWWDIR%%/client/etc/clientlaunch.cfg %D/%%WWWDIR%%/client/etc/clientlaunch.cfg-dist; then rm -f %D/%%WWWDIR%%/client/etc/clientlaunch.cfg; fi
+@unexec if cmp -s %D/%%WWWDIR%%/client/etc/hobbitclient.cfg %D/%%WWWDIR%%/client/etc/hobbitclient.cfg-dist; then rm -f %D/%%WWWDIR%%/client/etc/hobbitclient.cfg; fi
+@unexec if cmp -s %D/%%WWWDIR%%/client/etc/localclient.cfg %D/%%WWWDIR%%/client/etc/localclient.cfg-dist; then rm -f %D/%%WWWDIR%%/client/etc/localclient.cfg; fi
+%%WWWDIR%%/client/etc/clientlaunch.cfg-dist
+@exec [ ! -f %B/clientlaunch.cfg ] && cp %B/%f %B/clientlaunch.cfg
+%%WWWDIR%%/client/etc/hobbitclient.cfg-dist
+@exec [ ! -f %B/hobbitclient.cfg ] && cp %B/%f %B/hobbitclient.cfg
+%%WWWDIR%%/client/etc/localclient.cfg-dist
+@exec [ ! -f %B/localclient.cfg ] && cp %B/%f %B/localclient.cfg
+%%WWWDIR%%/client/runclient.sh
+@exec mkdir %D/%%WWWDIR%%/client/ext
+@exec mkdir %D/%%WWWDIR%%/client/logs
+@exec mkdir %D/%%WWWDIR%%/client/tmp
+@exec chown %%BBUSER%% %D/%%WWWDIR%%/client/ext
+@exec chown %%BBUSER%% %D/%%WWWDIR%%/client/logs
+@exec chown %%BBUSER%% %D/%%WWWDIR%%/client/tmp
+@dirrm %%WWWDIR%%/client/tmp
+@dirrm %%WWWDIR%%/client/logs
+@dirrm %%WWWDIR%%/client/ext
+@dirrm %%WWWDIR%%/client/etc
+@dirrm %%WWWDIR%%/client/bin
+@dirrm %%WWWDIR%%/client
+@dirrmtry %%WWWDIR%%