aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix2-frontend
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2018-04-08 12:19:58 +0000
committerBernard Spil <brnrd@FreeBSD.org>2018-04-08 12:19:58 +0000
commit08ff31ee65597a72a9c91166e840b66ef4a142ba (patch)
treed794783d43677df5e473fbaddc2b7f25f4908e9f /net-mgmt/zabbix2-frontend
parent79426f758a8bf5df6e80dc7827db7b82c2b61317 (diff)
downloadports-08ff31ee65597a72a9c91166e840b66ef4a142ba.tar.gz
ports-08ff31ee65597a72a9c91166e840b66ef4a142ba.zip
Notes
Diffstat (limited to 'net-mgmt/zabbix2-frontend')
-rw-r--r--net-mgmt/zabbix2-frontend/Makefile23
1 files changed, 6 insertions, 17 deletions
diff --git a/net-mgmt/zabbix2-frontend/Makefile b/net-mgmt/zabbix2-frontend/Makefile
index 65b806873dc2..bb7305c3ce8c 100644
--- a/net-mgmt/zabbix2-frontend/Makefile
+++ b/net-mgmt/zabbix2-frontend/Makefile
@@ -14,7 +14,7 @@ PLIST= ${PKGDIR}/pkg-plist.frontend
USE_PHP= bcmath ctype gd pcre snmp sockets mbstring session dom xml \
xmlreader xmlwriter simplexml gettext ldap
-WANT_PHP_WEB= yes
+USES= php:web
OPTIONS_DEFINE= MYSQL MYSQLI PGSQL SQLITE ORACLE
OPTIONS_DEFAULT= MYSQL MYSQLI
@@ -22,23 +22,12 @@ MYSQLI_DESC= MySQLI backend
MYSQL_VARS= IGNORE_WITH_PHP+=70
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= mysql
-.endif
-
-.if ${PORT_OPTIONS:MMYSQLI}
-USE_PHP+= mysqli
-.endif
+MYSQL_USE= PHP=mysql
+MYSQLI_USE= PHP=mysqli
+PGSQL_USE= PHP=pgsql
+SQLITE_USE= PHP=sqlite3
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pgsql
-.endif
-
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= sqlite3
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MORACLE}
ZABBIX_REQUIRE=