aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix2-frontend
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-13 22:30:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-13 22:30:18 +0000
commit391c68d29c56317c38c9ba153c558dd36d8b62dc (patch)
tree9acac72bca2b91360000dcc1ddb2900b79b7c987 /net-mgmt/zabbix2-frontend
parent94e62a7ca7045514babb2c2994caf68e7a90b313 (diff)
downloadports-391c68d29c56317c38c9ba153c558dd36d8b62dc.tar.gz
ports-391c68d29c56317c38c9ba153c558dd36d8b62dc.zip
Notes
Diffstat (limited to 'net-mgmt/zabbix2-frontend')
-rw-r--r--net-mgmt/zabbix2-frontend/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-mgmt/zabbix2-frontend/Makefile b/net-mgmt/zabbix2-frontend/Makefile
new file mode 100644
index 000000000000..a57bfff739e2
--- /dev/null
+++ b/net-mgmt/zabbix2-frontend/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: zabbix-frontend
+# Date created: 2009-12-09
+# Whom: Jim Riggs <ports@christianserving.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zabbix
+PKGNAMESUFFIX= -frontend
+
+MASTERDIR= ${.CURDIR}/../zabbix-server
+
+NO_BUILD= yes
+PATCHDIR=
+PLIST= ${PKGDIR}/pkg-plist.frontend
+
+USE_PHP= bcmath gd pcre snmp sockets
+IGNORE_WITH_PHP= 4
+WANT_PHP_WEB= yes
+
+OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
+OPTIONS= MYSQL "Use MySQL backend" on \
+ PGSQL "Use PostgreSQL backend" off \
+ SQLITE "Use SQLite backend" off
+
+.include <bsd.port.options.mk>
+
+.ifndef WITHOUT_MYSQL
+USE_PHP+= mysql
+.endif
+
+.ifdef WITH_MYSQLI
+USE_PHP+= mysqli
+.endif
+
+.ifdef WITH_PGSQL
+USE_PHP+= pgsql
+.endif
+
+.ifdef WITH_SQLITE
+USE_PHP+= sqlite
+.endif
+
+do-install:
+ @${INSTALL} -d ${WWWDIR}
+ @cd ${WRKSRC}/frontends/php/ && ${COPYTREE_SHARE} . ${WWWDIR}
+
+.include "${MASTERDIR}/Makefile"