aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix2-server/Makefile
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2011-10-15 01:26:35 +0000
committerEitan Adler <eadler@FreeBSD.org>2011-10-15 01:26:35 +0000
commita62c6c03949509b0df9a8548802d2e2894e541eb (patch)
tree4e272b19a12d305a56efa873aa5dd44a2567563c /net-mgmt/zabbix2-server/Makefile
parent4ed9440d08766a083c6a3f6f94e3337790e70c94 (diff)
downloadports-a62c6c03949509b0df9a8548802d2e2894e541eb.tar.gz
ports-a62c6c03949509b0df9a8548802d2e2894e541eb.zip
Notes
Diffstat (limited to 'net-mgmt/zabbix2-server/Makefile')
-rw-r--r--net-mgmt/zabbix2-server/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index 1cabcee84b7f..39af04f6ba0e 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zabbix
-PORTVERSION= 1.8.5
-PORTREVISION= 1
+PORTVERSION= 1.8.8
PORTEPOCH= 2
CATEGORIES= net-mgmt
MASTER_SITES= SF/zabbix/ZABBIX%20Latest%20Stable/${PORTVERSION}
@@ -47,10 +46,10 @@ SUB_LIST= ZABBIX_BUILD=${ZABBIX_BUILD} ZABBIX_REQUIRE=${ZABBIX_REQUIRE}
MAKE_ARGS+= ARCH=freebsd
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD}
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
.if ${ZABBIX_BUILD} != "agent"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp \
execinfo:${PORTSDIR}/devel/libexecinfo
@@ -140,9 +139,9 @@ CONFIGURE_ARGS+= --enable-ipv6
post-patch:
@${GREP} -rl "/etc/zabbix" ${WRKSRC} \
- | ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g' \
- && ${FIND} ${WRKSRC} -type f -name '*.bak' -exec ${RM} -f {} +
+ | ${XARGS} ${REINPLACE_CMD} -e 's#/etc/zabbix#${ETCDIR}#g'
@${REINPLACE_CMD} -e 's#/usr/sbin/fping#${LOCALBASE}/sbin/fping#g' ${WRKSRC}/misc/conf/${PORTNAME}_*.conf
+ @${FIND} ${WRKSRC} -type f \( -name '*.bak' -or -name '*.orig' \) -exec ${RM} -f {} +
.if ${ZABBIX_BUILD} != "agent"
.ifdef WITHOUT_FPING