aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix34-frontend
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2017-08-25 23:25:42 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2017-08-25 23:25:42 +0000
commit4ce0e08ab161b80cdf0fd18ea957e8ea60beecd1 (patch)
tree4bf2d6845e43ca5457ec344650d03ed8df5c998f /net-mgmt/zabbix34-frontend
parent336c3bb09a077303d6a645a3bbbcad9dea23ce87 (diff)
Notes
Diffstat (limited to 'net-mgmt/zabbix34-frontend')
-rw-r--r--net-mgmt/zabbix34-frontend/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-mgmt/zabbix34-frontend/Makefile b/net-mgmt/zabbix34-frontend/Makefile
new file mode 100644
index 000000000000..8ba64031efc9
--- /dev/null
+++ b/net-mgmt/zabbix34-frontend/Makefile
@@ -0,0 +1,52 @@
+# Created by: Pakhom Golynga <pg@pakhom.spb.ru>
+# $FreeBSD$
+
+PORTNAME= zabbix34
+CATEGORIES= net-mgmt
+PKGNAMESUFFIX= -frontend
+
+MASTERDIR= ${.CURDIR}/../zabbix34-server
+
+NO_BUILD= yes
+NO_ARCH= yes
+PATCHDIR=
+PLIST= ${PKGDIR}/pkg-plist.frontend
+
+USE_PHP= bcmath ctype dom gd gettext json ldap mbstring pcre \
+ session simplexml snmp sockets xml xmlreader xmlwriter
+USES+= php:web
+
+OPTIONS_DEFINE= MYSQL MYSQLI PGSQL SQLITE ORACLE
+OPTIONS_DEFAULT= MYSQLI
+MYSQLI_DESC= MySQLI backend
+
+MYSQL_VARS= IGNORE_WITH_PHP+=70 71
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMYSQL}
+USE_PHP+= mysql
+.endif
+
+.if ${PORT_OPTIONS:MMYSQLI}
+USE_PHP+= mysqli
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PHP+= pgsql
+.endif
+
+.if ${PORT_OPTIONS:MSQLITE}
+USE_PHP+= sqlite3
+.endif
+
+.if ${PORT_OPTIONS:MORACLE}
+CONFIGURE_ARGS+= --with-oracle
+.endif
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC}/frontends/php && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include "${MASTERDIR}/Makefile"