aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-06-13 13:53:11 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-06-13 13:53:11 +0000
commit283d436a2ed45cc0fdc29617f9fc3a43ed3120a1 (patch)
treef2b1444968dba0df35e639d90a6ef41e1fdea175 /net-mgmt/zabbix
parenta09dfc79ecacabdba8e10edb88e236a3b868cca7 (diff)
downloadports-283d436a2ed45cc0fdc29617f9fc3a43ed3120a1.tar.gz
ports-283d436a2ed45cc0fdc29617f9fc3a43ed3120a1.zip
Notes
Diffstat (limited to 'net-mgmt/zabbix')
-rw-r--r--net-mgmt/zabbix/Makefile126
-rw-r--r--net-mgmt/zabbix/distinfo6
-rw-r--r--net-mgmt/zabbix/files/patch-src__libs__zbxsysinfo__simple__simple.c10
-rw-r--r--net-mgmt/zabbix/files/pkg-message.in15
-rw-r--r--net-mgmt/zabbix/files/zabbix_agentd.sh.in17
-rw-r--r--net-mgmt/zabbix/pkg-plist331
-rw-r--r--net-mgmt/zabbix/scripts/dbsetup.sh6
7 files changed, 148 insertions, 363 deletions
diff --git a/net-mgmt/zabbix/Makefile b/net-mgmt/zabbix/Makefile
index 25b4798b0e95..012b175458b0 100644
--- a/net-mgmt/zabbix/Makefile
+++ b/net-mgmt/zabbix/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zabbix
-PORTVERSION= 1.1.7
-PORTREVISION= 1
+PORTVERSION= 1.4
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -15,79 +14,52 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Application and network monitoring solution
-.ifdef(ZABBIX_AGENT_ONLY)
-PKGNAMESUFFIX= -agent
-CATEGORIES= net
-CONFLICTS= zabbix-[0-9]*
-.else
-CONFLICTS= zabbix-agent-[0-9]*
-OPTIONS= PGSQL "Use a PostgreSQL backend" off \
- MYSQL "Use a MySQL backend" on \
+LIB_DEPENDS= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp \
+ iksemel.3:${PORTSDIR}/textproc/iksemel \
+ curl.4:${PORTSDIR}/ftp/curl
+
+OPTIONS= MYSQL "Use MySQL backend" on \
+ PGSQL "Use PostgreSQL backend" off \
+ SQLITE "Use SQLite backend" off \
+ LDAP "Support for checking LDAP servers" on \
FPING "Use fping for pinging hosts" on
-.endif
USE_GMAKE= yes
-CONFIGURE_ARGS+=--enable-agent
-.ifdef(ZABBIX_AGENT_ONLY)
-PKGNAMESUFFIX= -agent
-PLIST= ""
-.else # ZABBIX_AGENT_ONLY
-CONFIGURE_ARGS+=--enable-server
-# TODO add snmp knob
-LIB_DEPENDS= netsnmp.10:${PORTSDIR}/net-mgmt/net-snmp
-USE_PHP= gd snmp sockets pcre
+USE_PHP= gd snmp sockets pcre bcmath
+USE_RC_SUBR= zabbix_server.sh
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-agent --enable-server --with-net-snmp --with-jabber
+MAKE_ARGS= ARCH=freebsd
SUB_FILES= pkg-message
-.endif # ZABBIX_AGENT_ONLY
.include <bsd.port.pre.mk>
-.ifndef(WITHOUT_FPING)
-RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
+.ifndef WITHOUT_LDAP
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+=--with-ldap
+LIB_DEPENDS+= gnutls.15:${PORTSDIR}/security/gnutls \
+ sasl2.2:${PORTSDIR}/security/cyrus-sasl2
.endif
-
-.ifndef(ZABBIX_AGENT_ONLY)
-.ifndef(WITH_PGSQL)
-.ifdef(WITHOUT_MYSQL)
-IGNORE= you should configure to use either a MySQL or PostgreSQL backend
-.endif
-.endif
-
-.ifdef(WITH_PGSQL)
-USE_PGSQL= yes
-CONFIGURE_ARGS+=--with-pgsql
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pgsql.so:${PORTSDIR}/${pgsql_DEPENDS}
+.ifndef WITHOUT_FPING
+RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
-.ifndef(WITHOUT_MYSQL)
-USE_MYSQL= yes
+.ifndef WITHOUT_MYSQL
+USE_PHP+= mysql
CONFIGURE_ARGS+=--with-mysql
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/mysql.so:${PORTSDIR}/${mysql_DEPENDS}
-.endif
-CONFIGURE_ARGS+=--with-net-snmp
-.endif # ZABBIX_AGENT_ONLY
-
-USE_RC_SUBR= zabbix_agentd.sh
-.ifndef(ZABBIX_AGENT_ONLY)
-USE_RC_SUBR+= zabbix_server.sh
-.endif
-
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
-CPPFLAGS= -I${LOCALBASE}/include
-
-ZABBIX_BIN= agent agentd get sender
-ZABBIX_CFG= agent agentd
-.ifndef(ZABBIX_AGENT_ONLY)
-ZABBIX_BIN+= server
-ZABBIX_CFG+= server
+.elifdef WITH_PGSQL
+USE_PHP+= pgsql
+CONFIGURE_ARGS+=--with-pgsql
+.elifdef WITH_SQLITE
+USE_PHP+= sqlite
+CONFIGURE_ARGS+=--with-sqlite
+.else
+IGNORE= zabbix needs a database backend
.endif
-ZABBIX_BINFILES= ${ZABBIX_BIN:S|^|zabbix_|:C|.+|&/&|:S|agentd/|agent/|}
-ZABBIX_CFGFILES= ${ZABBIX_CFG:S|^|zabbix_|:S|$|.conf|}
-PLIST_FILES= ${ZABBIX_BIN:S|^|bin/zabbix_|} \
- ${ZABBIX_CFG:S|^|etc/zabbix/zabbix_|:S|$|.conf.sample|}
post-patch:
- @${FIND} ${WRKSRC}/src -type f -print0 | ${XARGS} -0 \
+ @${FIND} ${WRKSRC}/src/ -type f|${XARGS} \
${REINPLACE_CMD} -Ee 's|(/etc/zabbix)|${PREFIX}\1|;s|/usr/sbin|${LOCALBASE}/sbin|'
+ @${REINPLACE_CMD} -e '/test.*rf/s|-rf|-f|;/LDFLAGS/s|-static||' ${WRKSRC}/configure
.ifdef WITHOUT_FPING
@${ECHO} 'DisablePinger=yes' >> ${WRKSRC}/misc/conf/zabbix_server.conf
.endif
@@ -98,31 +70,13 @@ post-configure:
.endif
do-install:
- @${ECHO_CMD} '@unexec rmdir %D/etc/zabbix 2>/dev/null || true' >> ${TMPPLIST}
- ${INSTALL_PROGRAM} ${ZABBIX_BINFILES:S,^,${WRKSRC}/src/,} ${PREFIX}/bin/
- ${INSTALL} -d ${PREFIX}/etc/zabbix/
-.for FILE in ${ZABBIX_CFGFILES}
- ${INSTALL_DATA} ${WRKSRC}/misc/conf/${FILE} ${PREFIX}/etc/zabbix/${FILE}.sample
-.endfor
-.ifndef(ZABBIX_AGENT_ONLY)
- ${INSTALL} -d ${DATADIR}/create/
- ${CP} -Rf ${WRKSRC}/frontends/ ${WRKSRC}/upgrades/dbpatches ${DATADIR}/
- ${CP} -Rf ${WRKSRC}/create/ ${DATADIR}/create/
- ${INSTALL_SCRIPT} ${MASTERDIR}/scripts/dbsetup.sh ${DATADIR}/create/
-.endif
- ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-.ifndef(ZABBIX_AGENT_ONLY)
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/zabbix_server/zabbix_server ${PREFIX}/bin/
+ @${INSTALL} -d ${PREFIX}/etc/zabbix/ ${DATADIR}/create/
+ @${INSTALL_DATA} ${WRKSRC}/misc/conf/zabbix_server.conf\
+ ${PREFIX}/etc/zabbix/zabbix_server.conf.sample
+ @${CP} -Rf ${WRKSRC}/frontends/ ${WRKSRC}/upgrades/dbpatches ${DATADIR}/
+ @${CP} -Rf ${WRKSRC}/create/data ${WRKSRC}/create/schema ${DATADIR}/create/
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${CAT} ${PKGMESSAGE}
-.endif
-
-# This target is only meant to be used by the port maintainer.
-x-generate-plist:
- (${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
- | ${SED} -E \
- 's,.*share/nls/.+$$,,g \
- ;s,.*/rc.d/.+,,g \
- ;s,@dirrm share/man(/.*)?$$,,g \
- ;s,share/zabbix,%%DATADIR%%,g \
- ' | ${TR} -s '\n') > temp-pkg-plist
.include <bsd.port.post.mk>
diff --git a/net-mgmt/zabbix/distinfo b/net-mgmt/zabbix/distinfo
index 5a06e2338757..30a3b6723ef4 100644
--- a/net-mgmt/zabbix/distinfo
+++ b/net-mgmt/zabbix/distinfo
@@ -1,3 +1,3 @@
-MD5 (zabbix-1.1.7.tar.gz) = ac24ab58ef1a985c1e2a5217386d5dba
-SHA256 (zabbix-1.1.7.tar.gz) = 6354cd7ab311212f027e71ca78ff607f50b6323fe044d50ec1b76dc6b2878f20
-SIZE (zabbix-1.1.7.tar.gz) = 1515333
+MD5 (zabbix-1.4.tar.gz) = 29f605d939c10c571dac79a107a7745f
+SHA256 (zabbix-1.4.tar.gz) = ed1cb9437a5bd3d3f81b3969303c7bfb3d395f3e636fd19ddcbc52a1a800ba66
+SIZE (zabbix-1.4.tar.gz) = 3141667
diff --git a/net-mgmt/zabbix/files/patch-src__libs__zbxsysinfo__simple__simple.c b/net-mgmt/zabbix/files/patch-src__libs__zbxsysinfo__simple__simple.c
new file mode 100644
index 000000000000..fb6147c46d93
--- /dev/null
+++ b/net-mgmt/zabbix/files/patch-src__libs__zbxsysinfo__simple__simple.c
@@ -0,0 +1,10 @@
+--- ./src/libs/zbxsysinfo/simple/simple.c.orig Wed Jun 13 15:21:51 2007
++++ ./src/libs/zbxsysinfo/simple/simple.c Wed Jun 13 15:22:02 2007
+@@ -37,6 +37,7 @@
+ };
+
+ #ifdef HAVE_LDAP
++#include "ldap.h"
+
+ static int check_ldap(char *hostname, short port, int *value_int)
+ {
diff --git a/net-mgmt/zabbix/files/pkg-message.in b/net-mgmt/zabbix/files/pkg-message.in
index 99c664bc233a..ae4bcaaa37bf 100644
--- a/net-mgmt/zabbix/files/pkg-message.in
+++ b/net-mgmt/zabbix/files/pkg-message.in
@@ -1,8 +1,7 @@
-====================================================
-ACHTUNG!!!
-
-Run dbsetup.sh from %%PREFIX%%/share/zabbix/create
-to setup database tables. Arguments, given to
-it will be passed to mysql client, allowing
-connection do non-local MySQL server
-====================================================
+===============================================================
+You can prepare a database for zabbix this way:
+% cd %%DATADIR%%/
+% cat schema/<db>.sql data/data.sql data/images_<db>.sql\
+% | <db_client>
+where <db> is your preferred database engine.
+===============================================================
diff --git a/net-mgmt/zabbix/files/zabbix_agentd.sh.in b/net-mgmt/zabbix/files/zabbix_agentd.sh.in
deleted file mode 100644
index 0be45c4d2b66..000000000000
--- a/net-mgmt/zabbix/files/zabbix_agentd.sh.in
+++ /dev/null
@@ -1,17 +0,0 @@
-#!/bin/sh
-# PROVIDE: zabbix_agentd
-# REQUIRE: DAEMON
-# KEYWORD: shutdown
-
-. %%RC_SUBR%%
-
-name="zabbix_agentd"
-rcvar=${name}_enable
-load_rc_config $name
-eval : \${${rcvar}='NO'}
-
-command="%%PREFIX%%/bin/${name}"
-required_files="%%PREFIX%%/etc/zabbix/${name}.conf"
-
-
-run_rc_command "$1"
diff --git a/net-mgmt/zabbix/pkg-plist b/net-mgmt/zabbix/pkg-plist
index bef816446120..08224a370ca7 100644
--- a/net-mgmt/zabbix/pkg-plist
+++ b/net-mgmt/zabbix/pkg-plist
@@ -1,143 +1,77 @@
+bin/zabbix_server
+etc/zabbix/zabbix_server.conf.sample
%%DATADIR%%/create/data/data.sql
-%%DATADIR%%/create/data/images.sql
+%%DATADIR%%/create/data/images_mysql.sql
%%DATADIR%%/create/data/images_oracle.sql
%%DATADIR%%/create/data/images_pgsql.sql
-%%DATADIR%%/create/dbsetup.sh
-%%DATADIR%%/create/mysql/schema.sql
-%%DATADIR%%/create/oracle/schema.sql
-%%DATADIR%%/create/postgresql/schema.sql
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Hub.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Hub_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Network.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Network_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Notebook.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Notebook_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Phone.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Phone_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Printer.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Printer_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Router.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Router_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Satellite.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Satellite_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Server.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Server_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/UPS.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/UPS_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Workstation.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/Workstation_small.png
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0_to_1.1alpha1/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha10_to_1.0alpha11/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha10_to_1.0alpha11/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha11_to_1.0alpha12/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha11_to_1.0alpha12/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha12_to_1.0beta1/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha12_to_1.0beta1/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha3_to_1.0alpha4/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha3_to_1.0alpha4/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha4_to_1.0alpha5/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha4_to_1.0alpha5/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha6_to_1.0alpha7/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha6_to_1.0alpha7/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha7_to_1.0alpha8/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha7_to_1.0alpha8/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha8_to_1.0alpha9/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha8_to_1.0alpha9/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha9_to_1.0alpha10/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0alpha9_to_1.0alpha10/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta10_to_1.0beta11/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta10_to_1.0beta11/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta12_to_1.0beta13/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta12_to_1.0beta13/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta13_to_1.0beta14/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta13_to_1.0beta14/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta2_to_1.0beta3/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta2_to_1.0beta3/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta3_to_1.0beta4/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta3_to_1.0beta4/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta4_to_1.0beta5/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta4_to_1.0beta5/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta5_to_1.0beta6/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta5_to_1.0beta6/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta6_to_1.0beta7/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta6_to_1.0beta7/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta7_to_1.0beta8/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta7_to_1.0beta8/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta8_to_1.0beta9/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta8_to_1.0beta9/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta9_to_1.0beta10/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.0beta9_to_1.0beta10/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha10_to_1.1alpha11/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha10_to_1.1alpha11/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha11_to_1.1alpha12/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha11_to_1.1alpha12/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha12_to_1.1beta1/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha12_to_1.1beta1/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha2_to_1.1alpha3/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha2_to_1.1alpha3/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha3_to_1.1alpha4/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha3_to_1.1alpha4/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha4_to_1.1alpha5/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha4_to_1.1alpha5/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha8_to_1.1alpha9/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha8_to_1.1alpha9/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha9_to_1.1alpha10/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1alpha9_to_1.1alpha10/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta11_to_1.1beta12/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta11_to_1.1beta12/oracle/patch.sql
-%%DATADIR%%/dbpatches/1.1beta11_to_1.1beta12/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta12_to_1.1/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta12_to_1.1/oracle/patch.sql
-%%DATADIR%%/dbpatches/1.1beta12_to_1.1/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta1_to_1.1beta2/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta1_to_1.1beta2/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta2_to_1.1beta3/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta2_to_1.1beta3/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta4_to_1.1beta5/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta4_to_1.1beta5/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta5_to_1.1beta6/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta5_to_1.1beta6/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta6_to_1.1beta7/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta6_to_1.1beta7/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta7_to_1.1beta8/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta7_to_1.1beta8/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta8_to_1.1beta9/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta8_to_1.1beta9/postgresql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta9_to_1.1beta10/mysql/patch.sql
-%%DATADIR%%/dbpatches/1.1beta9_to_1.1beta10/postgresql/patch.sql
+%%DATADIR%%/create/data/images_sqlite3.sql
+%%DATADIR%%/create/schema/Makefile
+%%DATADIR%%/create/schema/Makefile.am
+%%DATADIR%%/create/schema/Makefile.in
+%%DATADIR%%/create/schema/mysql.sql
+%%DATADIR%%/create/schema/oracle.sql
+%%DATADIR%%/create/schema/postgresql.sql
+%%DATADIR%%/create/schema/sqlite.sql
+%%DATADIR%%/dbpatches/1.4/mysql/patch.sql
+%%DATADIR%%/dbpatches/1.4/oracle/patch.sql
+%%DATADIR%%/dbpatches/1.4/postgresql/patch.sql
%%DATADIR%%/php/acknow.php
%%DATADIR%%/php/actionconf.php
%%DATADIR%%/php/actions.php
-%%DATADIR%%/php/alarms.php
-%%DATADIR%%/php/audio/disaster_on.wav
-%%DATADIR%%/php/audio/warning_off.wav
-%%DATADIR%%/php/audio/warning_on.wav
+%%DATADIR%%/php/audio/trigger_off.wav
+%%DATADIR%%/php/audio/trigger_on.wav
+%%DATADIR%%/php/audio/trigger_on_average.wav
+%%DATADIR%%/php/audio/trigger_on_disaster.wav
+%%DATADIR%%/php/audio/trigger_on_high.wav
+%%DATADIR%%/php/audio/trigger_on_warning.wav
%%DATADIR%%/php/audit.php
-%%DATADIR%%/php/bulkloader.php
%%DATADIR%%/php/chart.php
%%DATADIR%%/php/chart2.php
+%%DATADIR%%/php/chart3.php
%%DATADIR%%/php/chart4.php
%%DATADIR%%/php/chart5.php
%%DATADIR%%/php/chart_sla.php
%%DATADIR%%/php/charts.php
+%%DATADIR%%/php/conf/COPYING
%%DATADIR%%/php/config.php
+%%DATADIR%%/php/create/data.sql
+%%DATADIR%%/php/create/mysql.sql
%%DATADIR%%/php/css.css
+%%DATADIR%%/php/discovery.php
+%%DATADIR%%/php/discoveryconf.php
%%DATADIR%%/php/events.php
-%%DATADIR%%/php/graph.php
+%%DATADIR%%/php/exp_imp.php
%%DATADIR%%/php/graphs.php
%%DATADIR%%/php/history.php
%%DATADIR%%/php/hostprofiles.php
%%DATADIR%%/php/hosts.php
+%%DATADIR%%/php/httpconf.php
+%%DATADIR%%/php/httpdetails.php
+%%DATADIR%%/php/httpmon.php
%%DATADIR%%/php/image.php
%%DATADIR%%/php/images/flash/zbxclock.swf
%%DATADIR%%/php/images/general/closed.gif
+%%DATADIR%%/php/images/general/error_small.gif
%%DATADIR%%/php/images/general/help.gif
+%%DATADIR%%/php/images/general/inst_completed.gif
+%%DATADIR%%/php/images/general/inst_current.gif
+%%DATADIR%%/php/images/general/inst_step.gif
%%DATADIR%%/php/images/general/opened.gif
%%DATADIR%%/php/images/general/sortdown.gif
%%DATADIR%%/php/images/general/sortdown_off.gif
%%DATADIR%%/php/images/general/sortup.gif
%%DATADIR%%/php/images/general/sortup_off.gif
+%%DATADIR%%/php/images/general/tick.png
+%%DATADIR%%/php/images/general/tree/I.gif
+%%DATADIR%%/php/images/general/tree/L.gif
+%%DATADIR%%/php/images/general/tree/O.gif
+%%DATADIR%%/php/images/general/tree/T.gif
+%%DATADIR%%/php/images/general/tree/X.gif
+%%DATADIR%%/php/images/general/tree/Xc.gif
+%%DATADIR%%/php/images/general/tree/Y.gif
+%%DATADIR%%/php/images/general/tree/Yc.gif
+%%DATADIR%%/php/images/general/tree/point.gif
+%%DATADIR%%/php/images/general/warning_small.gif
%%DATADIR%%/php/images/general/zabbix.png
%%DATADIR%%/php/images/gradients/blink1.gif
%%DATADIR%%/php/images/gradients/blink2.gif
@@ -176,11 +110,10 @@
%%DATADIR%%/php/include/acknow.inc.php
%%DATADIR%%/php/include/actions.inc.php
%%DATADIR%%/php/include/audit.inc.php
-%%DATADIR%%/php/include/autoregistration.inc.php
-%%DATADIR%%/php/include/bulkloader.inc.php
%%DATADIR%%/php/include/classes/.htaccess
%%DATADIR%%/php/include/classes/cbutton.inc.php
%%DATADIR%%/php/include/classes/ccheckbox.inc.php
+%%DATADIR%%/php/include/classes/ccolor.inc.php
%%DATADIR%%/php/include/classes/ccombobox.inc.php
%%DATADIR%%/php/include/classes/cfile.inc.php
%%DATADIR%%/php/include/classes/cflash.inc.php
@@ -192,9 +125,9 @@
%%DATADIR%%/php/include/classes/ciframe.inc.php
%%DATADIR%%/php/include/classes/cimg.inc.php
%%DATADIR%%/php/include/classes/clink.inc.php
-%%DATADIR%%/php/include/classes/clistbox.inc.php
+%%DATADIR%%/php/include/classes/clist.inc.php
%%DATADIR%%/php/include/classes/cmap.inc.php
-%%DATADIR%%/php/include/classes/cpassbox.inc.php
+%%DATADIR%%/php/include/classes/cpumenu.inc.php
%%DATADIR%%/php/include/classes/cserverinfo.mod.php
%%DATADIR%%/php/include/classes/cspan.inc.php
%%DATADIR%%/php/include/classes/ctable.inc.php
@@ -202,20 +135,24 @@
%%DATADIR%%/php/include/classes/ctag.inc.php
%%DATADIR%%/php/include/classes/ctextarea.inc.php
%%DATADIR%%/php/include/classes/ctextbox.inc.php
+%%DATADIR%%/php/include/classes/ctree.inc.php
%%DATADIR%%/php/include/classes/ctriggerinfo.mod.php
%%DATADIR%%/php/include/classes/cvar.inc.php
%%DATADIR%%/php/include/classes/graph.inc.php
-%%DATADIR%%/php/include/classes/table.inc.php
%%DATADIR%%/php/include/config.inc.php
%%DATADIR%%/php/include/copt.lib.php
%%DATADIR%%/php/include/db.inc.php
%%DATADIR%%/php/include/defines.inc.php
-%%DATADIR%%/php/include/escalations.inc.php
+%%DATADIR%%/php/include/discovery.inc.php
%%DATADIR%%/php/include/events.inc.php
+%%DATADIR%%/php/include/export.inc.php
%%DATADIR%%/php/include/forms.inc.php
%%DATADIR%%/php/include/graphs.inc.php
%%DATADIR%%/php/include/hosts.inc.php
%%DATADIR%%/php/include/html.inc.php
+%%DATADIR%%/php/include/httptest.inc.php
+%%DATADIR%%/php/include/images.inc.php
+%%DATADIR%%/php/include/import.inc.php
%%DATADIR%%/php/include/items.inc.php
%%DATADIR%%/php/include/locales/cn_zh.inc.php
%%DATADIR%%/php/include/locales/de_de.inc.php
@@ -225,28 +162,45 @@
%%DATADIR%%/php/include/locales/ja_jp.inc.php
%%DATADIR%%/php/include/locales/lv_lv.inc.php
%%DATADIR%%/php/include/locales/nl_nl.inc.php
-%%DATADIR%%/php/include/locales/pt_br.inc.php
%%DATADIR%%/php/include/locales/ru_ru.inc.php
%%DATADIR%%/php/include/locales/sp_sp.inc.php
%%DATADIR%%/php/include/locales/sv_se.inc.php
%%DATADIR%%/php/include/locales.inc.php
%%DATADIR%%/php/include/maps.inc.php
%%DATADIR%%/php/include/media.inc.php
+%%DATADIR%%/php/include/nodes.inc.php
+%%DATADIR%%/php/include/page_footer.php
+%%DATADIR%%/php/include/page_header.php
%%DATADIR%%/php/include/perm.inc.php
%%DATADIR%%/php/include/profiles.inc.php
%%DATADIR%%/php/include/screens.inc.php
%%DATADIR%%/php/include/services.inc.php
+%%DATADIR%%/php/include/setup.inc.php
%%DATADIR%%/php/include/triggers.inc.php
%%DATADIR%%/php/include/users.inc.php
%%DATADIR%%/php/include/validate.inc.php
%%DATADIR%%/php/index.php
+%%DATADIR%%/php/instal.php
%%DATADIR%%/php/items.php
+%%DATADIR%%/php/js/common.js
+%%DATADIR%%/php/js/cookies.js
+%%DATADIR%%/php/js/menu.js
+%%DATADIR%%/php/js/services.js
+%%DATADIR%%/php/js/tree.js
%%DATADIR%%/php/latest.php
%%DATADIR%%/php/map.php
%%DATADIR%%/php/maps.php
-%%DATADIR%%/php/media.php
+%%DATADIR%%/php/media_types.php
+%%DATADIR%%/php/nodes.php
%%DATADIR%%/php/overview.php
%%DATADIR%%/php/popup.php
+%%DATADIR%%/php/popup_gitem.php
+%%DATADIR%%/php/popup_httpstep.php
+%%DATADIR%%/php/popup_media.php
+%%DATADIR%%/php/popup_right.php
+%%DATADIR%%/php/popup_trexpr.php
+%%DATADIR%%/php/popup_users.php
+%%DATADIR%%/php/popup_usrgrp.php
%%DATADIR%%/php/profile.php
%%DATADIR%%/php/queue.php
%%DATADIR%%/php/report1.php
@@ -258,141 +212,29 @@
%%DATADIR%%/php/screenedit.php
%%DATADIR%%/php/screens.php
%%DATADIR%%/php/services.php
+%%DATADIR%%/php/services_form.php
+%%DATADIR%%/php/setup.php
%%DATADIR%%/php/srv_status.php
%%DATADIR%%/php/sysmap.php
%%DATADIR%%/php/sysmaps.php
%%DATADIR%%/php/tr_comments.php
+%%DATADIR%%/php/tr_events.php
%%DATADIR%%/php/tr_status.php
%%DATADIR%%/php/triggers.php
%%DATADIR%%/php/users.php
%%DATADIR%%/php/vtext.php
@dirrm %%DATADIR%%/create/data
-@dirrm %%DATADIR%%/create/mysql
-@dirrm %%DATADIR%%/create/oracle
-@dirrm %%DATADIR%%/create/postgresql
+@dirrm %%DATADIR%%/create/schema
@dirrm %%DATADIR%%/create
-@dirrm %%DATADIR%%/dbpatches/1.0_to_1.1alpha1/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0_to_1.1alpha1/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0_to_1.1alpha1
-@dirrm %%DATADIR%%/dbpatches/1.0alpha10_to_1.0alpha11/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha10_to_1.0alpha11/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha10_to_1.0alpha11
-@dirrm %%DATADIR%%/dbpatches/1.0alpha11_to_1.0alpha12/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha11_to_1.0alpha12/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha11_to_1.0alpha12
-@dirrm %%DATADIR%%/dbpatches/1.0alpha12_to_1.0beta1/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha12_to_1.0beta1/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha12_to_1.0beta1
-@dirrm %%DATADIR%%/dbpatches/1.0alpha3_to_1.0alpha4/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha3_to_1.0alpha4/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha3_to_1.0alpha4
-@dirrm %%DATADIR%%/dbpatches/1.0alpha4_to_1.0alpha5/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha4_to_1.0alpha5/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha4_to_1.0alpha5
-@dirrm %%DATADIR%%/dbpatches/1.0alpha6_to_1.0alpha7/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha6_to_1.0alpha7/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha6_to_1.0alpha7
-@dirrm %%DATADIR%%/dbpatches/1.0alpha7_to_1.0alpha8/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha7_to_1.0alpha8/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha7_to_1.0alpha8
-@dirrm %%DATADIR%%/dbpatches/1.0alpha8_to_1.0alpha9/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha8_to_1.0alpha9/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha8_to_1.0alpha9
-@dirrm %%DATADIR%%/dbpatches/1.0alpha9_to_1.0alpha10/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha9_to_1.0alpha10/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0alpha9_to_1.0alpha10
-@dirrm %%DATADIR%%/dbpatches/1.0beta10_to_1.0beta11/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta10_to_1.0beta11/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta10_to_1.0beta11
-@dirrm %%DATADIR%%/dbpatches/1.0beta12_to_1.0beta13/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta12_to_1.0beta13/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta12_to_1.0beta13
-@dirrm %%DATADIR%%/dbpatches/1.0beta13_to_1.0beta14/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta13_to_1.0beta14/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta13_to_1.0beta14
-@dirrm %%DATADIR%%/dbpatches/1.0beta2_to_1.0beta3/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta2_to_1.0beta3/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta2_to_1.0beta3
-@dirrm %%DATADIR%%/dbpatches/1.0beta3_to_1.0beta4/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta3_to_1.0beta4/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta3_to_1.0beta4
-@dirrm %%DATADIR%%/dbpatches/1.0beta4_to_1.0beta5/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta4_to_1.0beta5/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta4_to_1.0beta5
-@dirrm %%DATADIR%%/dbpatches/1.0beta5_to_1.0beta6/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta5_to_1.0beta6/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta5_to_1.0beta6
-@dirrm %%DATADIR%%/dbpatches/1.0beta6_to_1.0beta7/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta6_to_1.0beta7/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta6_to_1.0beta7
-@dirrm %%DATADIR%%/dbpatches/1.0beta7_to_1.0beta8/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta7_to_1.0beta8/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta7_to_1.0beta8
-@dirrm %%DATADIR%%/dbpatches/1.0beta8_to_1.0beta9/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta8_to_1.0beta9/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta8_to_1.0beta9
-@dirrm %%DATADIR%%/dbpatches/1.0beta9_to_1.0beta10/mysql
-@dirrm %%DATADIR%%/dbpatches/1.0beta9_to_1.0beta10/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.0beta9_to_1.0beta10
-@dirrm %%DATADIR%%/dbpatches/1.1alpha10_to_1.1alpha11/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha10_to_1.1alpha11/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha10_to_1.1alpha11
-@dirrm %%DATADIR%%/dbpatches/1.1alpha11_to_1.1alpha12/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha11_to_1.1alpha12/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha11_to_1.1alpha12
-@dirrm %%DATADIR%%/dbpatches/1.1alpha12_to_1.1beta1/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha12_to_1.1beta1/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha12_to_1.1beta1
-@dirrm %%DATADIR%%/dbpatches/1.1alpha2_to_1.1alpha3/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha2_to_1.1alpha3/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha2_to_1.1alpha3
-@dirrm %%DATADIR%%/dbpatches/1.1alpha3_to_1.1alpha4/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha3_to_1.1alpha4/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha3_to_1.1alpha4
-@dirrm %%DATADIR%%/dbpatches/1.1alpha4_to_1.1alpha5/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha4_to_1.1alpha5/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha4_to_1.1alpha5
-@dirrm %%DATADIR%%/dbpatches/1.1alpha8_to_1.1alpha9/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha8_to_1.1alpha9/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha8_to_1.1alpha9
-@dirrm %%DATADIR%%/dbpatches/1.1alpha9_to_1.1alpha10/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha9_to_1.1alpha10/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1alpha9_to_1.1alpha10
-@dirrm %%DATADIR%%/dbpatches/1.1beta11_to_1.1beta12/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta11_to_1.1beta12/oracle
-@dirrm %%DATADIR%%/dbpatches/1.1beta11_to_1.1beta12/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta11_to_1.1beta12
-@dirrm %%DATADIR%%/dbpatches/1.1beta12_to_1.1/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta12_to_1.1/oracle
-@dirrm %%DATADIR%%/dbpatches/1.1beta12_to_1.1/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta12_to_1.1
-@dirrm %%DATADIR%%/dbpatches/1.1beta1_to_1.1beta2/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta1_to_1.1beta2/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta1_to_1.1beta2
-@dirrm %%DATADIR%%/dbpatches/1.1beta2_to_1.1beta3/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta2_to_1.1beta3/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta2_to_1.1beta3
-@dirrm %%DATADIR%%/dbpatches/1.1beta4_to_1.1beta5/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta4_to_1.1beta5/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta4_to_1.1beta5
-@dirrm %%DATADIR%%/dbpatches/1.1beta5_to_1.1beta6/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta5_to_1.1beta6/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta5_to_1.1beta6
-@dirrm %%DATADIR%%/dbpatches/1.1beta6_to_1.1beta7/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta6_to_1.1beta7/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta6_to_1.1beta7
-@dirrm %%DATADIR%%/dbpatches/1.1beta7_to_1.1beta8/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta7_to_1.1beta8/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta7_to_1.1beta8
-@dirrm %%DATADIR%%/dbpatches/1.1beta8_to_1.1beta9/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta8_to_1.1beta9/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta8_to_1.1beta9
-@dirrm %%DATADIR%%/dbpatches/1.1beta9_to_1.1beta10/mysql
-@dirrm %%DATADIR%%/dbpatches/1.1beta9_to_1.1beta10/postgresql
-@dirrm %%DATADIR%%/dbpatches/1.1beta9_to_1.1beta10
+@dirrm %%DATADIR%%/dbpatches/1.4/mysql
+@dirrm %%DATADIR%%/dbpatches/1.4/oracle
+@dirrm %%DATADIR%%/dbpatches/1.4/postgresql
+@dirrm %%DATADIR%%/dbpatches/1.4
@dirrm %%DATADIR%%/dbpatches
@dirrm %%DATADIR%%/php/audio
+@dirrm %%DATADIR%%/php/create
@dirrm %%DATADIR%%/php/images/flash
+@dirrm %%DATADIR%%/php/images/general/tree
@dirrm %%DATADIR%%/php/images/general
@dirrm %%DATADIR%%/php/images/gradients
@dirrm %%DATADIR%%/php/images/sysmaps/old
@@ -401,5 +243,8 @@
@dirrm %%DATADIR%%/php/include/classes
@dirrm %%DATADIR%%/php/include/locales
@dirrm %%DATADIR%%/php/include
-@dirrm %%DATADIR%%/php
-@dirrm %%DATADIR%%
+@dirrm %%DATADIR%%/php/js
+@dirrmtry %%DATADIR%%/php/conf
+@dirrmtry %%DATADIR%%/php
+@dirrmtry %%DATADIR%%
+@dirrmtry etc/zabbix
diff --git a/net-mgmt/zabbix/scripts/dbsetup.sh b/net-mgmt/zabbix/scripts/dbsetup.sh
deleted file mode 100644
index 240f46157640..000000000000
--- a/net-mgmt/zabbix/scripts/dbsetup.sh
+++ /dev/null
@@ -1,6 +0,0 @@
-#!/bin/sh
-
-{
- echo "create database zabbix; use zabbix;"
- cat mysql/schema.sql data/data.sql
-} | mysql ${*}