aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zenpack-deviceadvdetail
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-10-21 20:12:02 +0000
committerChris Rees <crees@FreeBSD.org>2011-10-21 20:12:02 +0000
commit1e1818762ee58bcafa46f733462225660b63a346 (patch)
tree66b159c1d7b1fa9df378f85c6799421a75795928 /net-mgmt/zenpack-deviceadvdetail
parentba3d0a0cf70ac5e40e2abb3124609ea599854da0 (diff)
downloadports-1e1818762ee58bcafa46f733462225660b63a346.tar.gz
ports-1e1818762ee58bcafa46f733462225660b63a346.zip
Notes
Diffstat (limited to 'net-mgmt/zenpack-deviceadvdetail')
-rw-r--r--net-mgmt/zenpack-deviceadvdetail/Makefile25
-rw-r--r--net-mgmt/zenpack-deviceadvdetail/distinfo2
-rw-r--r--net-mgmt/zenpack-deviceadvdetail/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-deviceadvdetail/files/pkg-message.in5
-rw-r--r--net-mgmt/zenpack-deviceadvdetail/pkg-descr16
-rw-r--r--net-mgmt/zenpack-deviceadvdetail/pkg-plist2
6 files changed, 60 insertions, 0 deletions
diff --git a/net-mgmt/zenpack-deviceadvdetail/Makefile b/net-mgmt/zenpack-deviceadvdetail/Makefile
new file mode 100644
index 000000000000..dc2896be2787
--- /dev/null
+++ b/net-mgmt/zenpack-deviceadvdetail/Makefile
@@ -0,0 +1,25 @@
+# New ports collection Makefile for: deviceAdvDetail
+# Date created: 11 May 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= deviceAdvDetail
+PORTVERSION= 2.7.3
+CATEGORIES= net-mgmt
+MASTER_SITES= https://github.com/epuzanov/${ZPACKPREFIX}${PORTNAME}/tarball/deviceadvdetail-2.7/
+DISTNAME= epuzanov-${ZPACKPREFIX}${PORTNAME}-deviceadvdetail-2.7-0-g4cc7c48
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Provides additional hardware details for Zenoss
+
+ZPACKGROUP= community
+WRKSRC= ${WRKDIR}/epuzanov-${ZPACKPREFIX}${PORTNAME}-cfbd596
+
+ZPACK= ${ZPACKPREFIX}${PORTNAME}-2.7-${PYTHON_VERSION:S/thon//}.egg
+ZPACKPREFIX= ZenPacks.community.
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-deviceadvdetail/distinfo b/net-mgmt/zenpack-deviceadvdetail/distinfo
new file mode 100644
index 000000000000..fb3430456061
--- /dev/null
+++ b/net-mgmt/zenpack-deviceadvdetail/distinfo
@@ -0,0 +1,2 @@
+SHA256 (epuzanov-ZenPacks.community.deviceAdvDetail-deviceadvdetail-2.7-0-g4cc7c48.tar.gz) = fa5072eac03d2fc0b483ec80f4596be87f5f740c9a456a055d58a3710a45e289
+SIZE (epuzanov-ZenPacks.community.deviceAdvDetail-deviceadvdetail-2.7-0-g4cc7c48.tar.gz) = 17009
diff --git a/net-mgmt/zenpack-deviceadvdetail/files/pkg-deinstall.in b/net-mgmt/zenpack-deviceadvdetail/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-deviceadvdetail/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-deviceadvdetail/files/pkg-message.in b/net-mgmt/zenpack-deviceadvdetail/files/pkg-message.in
new file mode 100644
index 000000000000..869bea811264
--- /dev/null
+++ b/net-mgmt/zenpack-deviceadvdetail/files/pkg-message.in
@@ -0,0 +1,5 @@
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-deviceadvdetail/pkg-descr b/net-mgmt/zenpack-deviceadvdetail/pkg-descr
new file mode 100644
index 000000000000..9e596c05bdde
--- /dev/null
+++ b/net-mgmt/zenpack-deviceadvdetail/pkg-descr
@@ -0,0 +1,16 @@
+This ZenPack is currently used by the HP ProLiant Monitor, Dell Monitor and ODBC
+Datasource (and many others) to display additional hardware details and could be
+used by other ZenPacks as well. Examples of details include:
+
+* dynamic deviceHardwareDetail tab (additional sections can be added
+ or removed by any ZenPack)
+* dynamic deviceOsDetail tab
+* dynamic deviceSoftwareDetail tab
+* Number of CPU Cores
+* Memory Modules section
+* Logical Drives sections
+* status indication for all hardware components
+* It also make changes deviceOSDetail tab to show only monitored
+ Network Interfaces
+
+WWW: http://community.zenoss.org/docs/DOC-3452
diff --git a/net-mgmt/zenpack-deviceadvdetail/pkg-plist b/net-mgmt/zenpack-deviceadvdetail/pkg-plist
new file mode 100644
index 000000000000..52307ea0055e
--- /dev/null
+++ b/net-mgmt/zenpack-deviceadvdetail/pkg-plist
@@ -0,0 +1,2 @@
+zenoss/ZenPack/%%ZPACK%%
+@dirrmtry zenoss/ZenPack