aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zenpack-devicesearch
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-10-29 19:31:19 +0000
committerChris Rees <crees@FreeBSD.org>2011-10-29 19:31:19 +0000
commit5ed5cf59536a17aca6c0869829e7ac3a5a323b98 (patch)
treeb532ecf2c6217034463ea161e01a0c7715b4ac33 /net-mgmt/zenpack-devicesearch
parent3c50cf4ae36dd7d1c35c005aa4056d9afa65b1ab (diff)
Notes
Diffstat (limited to 'net-mgmt/zenpack-devicesearch')
-rw-r--r--net-mgmt/zenpack-devicesearch/Makefile20
-rw-r--r--net-mgmt/zenpack-devicesearch/distinfo2
-rw-r--r--net-mgmt/zenpack-devicesearch/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-devicesearch/files/pkg-message.in8
-rw-r--r--net-mgmt/zenpack-devicesearch/pkg-descr7
-rw-r--r--net-mgmt/zenpack-devicesearch/pkg-plist2
6 files changed, 49 insertions, 0 deletions
diff --git a/net-mgmt/zenpack-devicesearch/Makefile b/net-mgmt/zenpack-devicesearch/Makefile
new file mode 100644
index 000000000000..f3c15821a37f
--- /dev/null
+++ b/net-mgmt/zenpack-devicesearch/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: DeviceSearch
+# Date created: 26 May 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DeviceSearch
+PORTVERSION= 1.0.0
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.glenbarber.us/ports/net-mgmt/zenpack-${PORTNAME}/
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Provides the ability to quickly search for devices in Zenoss
+
+ZPACKGROUP= core
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-devicesearch/distinfo b/net-mgmt/zenpack-devicesearch/distinfo
new file mode 100644
index 000000000000..18ab0a47e0fd
--- /dev/null
+++ b/net-mgmt/zenpack-devicesearch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (DeviceSearch-1.0.0.tar.gz) = 3c2c7f7b2b1f1c8ddb1a8421aba010a4cc3258e4f41634341bc8652431211de2
+SIZE (DeviceSearch-1.0.0.tar.gz) = 3642
diff --git a/net-mgmt/zenpack-devicesearch/files/pkg-deinstall.in b/net-mgmt/zenpack-devicesearch/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-devicesearch/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-devicesearch/files/pkg-message.in b/net-mgmt/zenpack-devicesearch/files/pkg-message.in
new file mode 100644
index 000000000000..8e2a09bc46ba
--- /dev/null
+++ b/net-mgmt/zenpack-devicesearch/files/pkg-message.in
@@ -0,0 +1,8 @@
+
+Before activation of this Zenpack, you will need to create a Sub-Folder named
+"Storage" under MIBs in the web-interface. (Advanced-> MIBs> Sub-Folder)
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-devicesearch/pkg-descr b/net-mgmt/zenpack-devicesearch/pkg-descr
new file mode 100644
index 000000000000..65795ad9e2d4
--- /dev/null
+++ b/net-mgmt/zenpack-devicesearch/pkg-descr
@@ -0,0 +1,7 @@
+This ZenPack provides the ability to quickly search for Devices by their name
+or by their IP address. Search is triggered by typing 3 or more characters
+into the text box, which then returns the first 10 matches. The use of the
+asterisk wild-card is supported, so you may search for fuzzy matches
+dynamically.
+
+WWW: http://community.zenoss.org/docs/DOC-7453
diff --git a/net-mgmt/zenpack-devicesearch/pkg-plist b/net-mgmt/zenpack-devicesearch/pkg-plist
new file mode 100644
index 000000000000..52307ea0055e
--- /dev/null
+++ b/net-mgmt/zenpack-devicesearch/pkg-plist
@@ -0,0 +1,2 @@
+zenoss/ZenPack/%%ZPACK%%
+@dirrmtry zenoss/ZenPack