aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-10-03 08:09:59 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-10-03 08:09:59 +0000
commit27754cf3a7406c7dc2adecd0725561b0e955036c (patch)
tree0f7cd1ef946a9cf6bac5eb03b6d4612f9182cac3 /net-mgmt
parenta44229b5cf69d83727da43d6063e803b0e42d81d (diff)
downloadports-27754cf3a7406c7dc2adecd0725561b0e955036c.tar.gz
ports-27754cf3a7406c7dc2adecd0725561b0e955036c.zip
Fix spurious crashes.
PR: 231801 Submitted by: madpilot
Notes
Notes: svn path=/head/; revision=481146
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/monitoring-plugins/Makefile2
-rw-r--r--net-mgmt/monitoring-plugins/files/patch-lib_utils__base.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-mgmt/monitoring-plugins/Makefile b/net-mgmt/monitoring-plugins/Makefile
index 1eab3bfc5669..8316c1bc0e66 100644
--- a/net-mgmt/monitoring-plugins/Makefile
+++ b/net-mgmt/monitoring-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= monitoring-plugins
PORTVERSION= 2.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt
MASTER_SITES= https://www.monitoring-plugins.org/download/ LOCAL/mat/${PORTNAME}
diff --git a/net-mgmt/monitoring-plugins/files/patch-lib_utils__base.c b/net-mgmt/monitoring-plugins/files/patch-lib_utils__base.c
new file mode 100644
index 000000000000..f2eea57ad561
--- /dev/null
+++ b/net-mgmt/monitoring-plugins/files/patch-lib_utils__base.c
@@ -0,0 +1,20 @@
+--- lib/utils_base.c.orig 2016-11-29 08:45:08 UTC
++++ lib/utils_base.c
+@@ -87,10 +87,13 @@ void _get_monitoring_plugin( monitoring_
+ void
+ die (int result, const char *fmt, ...)
+ {
+- va_list ap;
+- va_start (ap, fmt);
+- vprintf (fmt, ap);
+- va_end (ap);
++ if(fmt!=NULL) {
++ va_list ap;
++ va_start (ap, fmt);
++ vprintf (fmt, ap);
++ va_end (ap);
++ }
++
+ if(this_monitoring_plugin!=NULL) {
+ np_cleanup();
+ }