aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-07-14 21:39:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-07-14 21:39:29 +0000
commit7ff6dcab61bed9fbed19f3381b3a927bce3e56a5 (patch)
tree698a69631240067de3b5c36f9fb9395738998acc /net-mgmt
parent409d850942002ede1e6c80b451427df85452814f (diff)
downloadports-7ff6dcab61bed9fbed19f3381b3a927bce3e56a5.tar.gz
ports-7ff6dcab61bed9fbed19f3381b3a927bce3e56a5.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/nagios-check_nick/Makefile25
-rw-r--r--net-mgmt/nagios-check_nick/distinfo3
-rw-r--r--net-mgmt/nagios-check_nick/pkg-descr3
-rw-r--r--net-mgmt/nagios-check_nick/pkg-plist2
5 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 4cb04b4be8df..3218ec7019f2 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -109,6 +109,7 @@
SUBDIR += nagios-certexp-plugin
SUBDIR += nagios-check_bacula
SUBDIR += nagios-check_clamav
+ SUBDIR += nagios-check_nick
SUBDIR += nagios-check_ports
SUBDIR += nagios-check_puppet
SUBDIR += nagios-check_smartmon
diff --git a/net-mgmt/nagios-check_nick/Makefile b/net-mgmt/nagios-check_nick/Makefile
new file mode 100644
index 000000000000..44fd19d6b7e9
--- /dev/null
+++ b/net-mgmt/nagios-check_nick/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: nagios-check_nick
+# Date created: 2009-07-11
+# Whom: steinex
+#
+# $FreeBSD$
+
+PORTNAME= check_nick
+PORTVERSION= 1.0
+CATEGORIES= net-mgmt
+MASTER_SITES= http://nognu.de/s/FreeBSD/distfiles/
+PKGNAMEPREFIX= nagios-
+
+MAINTAINER= steinex@nognu.de
+COMMENT= Nagios plug-in to check if a nick is on IRC
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/irclib.py:${PORTSDIR}/irc/py-irclib
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_nick ${PREFIX}/libexec/nagios
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-check_nick/distinfo b/net-mgmt/nagios-check_nick/distinfo
new file mode 100644
index 000000000000..85cb2311060f
--- /dev/null
+++ b/net-mgmt/nagios-check_nick/distinfo
@@ -0,0 +1,3 @@
+MD5 (check_nick-1.0.tar.gz) = 0fd6c997056d23e77c497c0b8899fcef
+SHA256 (check_nick-1.0.tar.gz) = 5c7d1b723a6d19a62ecb671278f06f0e8a5c39c4ece0965ac88afb4672f1eb0c
+SIZE (check_nick-1.0.tar.gz) = 634
diff --git a/net-mgmt/nagios-check_nick/pkg-descr b/net-mgmt/nagios-check_nick/pkg-descr
new file mode 100644
index 000000000000..366f085b2b50
--- /dev/null
+++ b/net-mgmt/nagios-check_nick/pkg-descr
@@ -0,0 +1,3 @@
+check_nick is a Nagios plugin-in written in python that will
+connect to an IRC server and check if a particular nick is
+online.
diff --git a/net-mgmt/nagios-check_nick/pkg-plist b/net-mgmt/nagios-check_nick/pkg-plist
new file mode 100644
index 000000000000..bb24c8fb596c
--- /dev/null
+++ b/net-mgmt/nagios-check_nick/pkg-plist
@@ -0,0 +1,2 @@
+libexec/nagios/check_nick
+@dirrmtry libexec/nagios