aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2013-09-30 20:05:10 +0000
committerLars Engels <lme@FreeBSD.org>2013-09-30 20:05:10 +0000
commit02a1ef0b2827ca1cb292dfba5fed58e33117c91e (patch)
tree5e81d952ef73ba56f0aeb414fcc551a64dde9d71 /net-mgmt
parent0e3b7988b9c76b5a7a920d78584baa4c9cad3af4 (diff)
downloadports-02a1ef0b2827ca1cb292dfba5fed58e33117c91e.tar.gz
ports-02a1ef0b2827ca1cb292dfba5fed58e33117c91e.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/icli/Makefile31
-rw-r--r--net-mgmt/icli/distinfo2
-rw-r--r--net-mgmt/icli/pkg-descr12
4 files changed, 46 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 50d3ec0adfee..56625c88bb2f 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -84,6 +84,7 @@
SUBDIR += hawk
SUBDIR += horde3-nic
SUBDIR += icinga
+ SUBDIR += icli
SUBDIR += icmpmonitor
SUBDIR += icmpquery
SUBDIR += ifgraph
diff --git a/net-mgmt/icli/Makefile b/net-mgmt/icli/Makefile
new file mode 100644
index 000000000000..e3b47659c784
--- /dev/null
+++ b/net-mgmt/icli/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= icli
+DISTVERSION= 0.46
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= http://finalrewind.org/projects/icli/
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Command line interface to Icinga
+
+LICENSE= ICLI
+LICENSE_NAME= ICLI license
+LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+RUN_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Term-Size>=0:${PORTSDIR}/devel/p5-Term-Size \
+ icinga:${PORTSDIR}/net-mgmt/icinga
+
+CONFIGURE_ARGS+= --destdir ${STAGEDIR}
+
+USES= perl5
+USE_PERL5= modbuild
+
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
+
+post-patch:
+ @${REINPLACE_CMD} -i '' 's|/var/[^/]*/icinga|/var/spool/icinga|' \
+ ${WRKSRC}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/icli/distinfo b/net-mgmt/icli/distinfo
new file mode 100644
index 000000000000..c76e4a6726ed
--- /dev/null
+++ b/net-mgmt/icli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (icli-0.46.tar.gz) = cf63d74fe99288b8b6c77e9e5fe258fc9d7c6546a7fbc5c0cae04fe1ed4d5106
+SIZE (icli-0.46.tar.gz) = 35591
diff --git a/net-mgmt/icli/pkg-descr b/net-mgmt/icli/pkg-descr
new file mode 100644
index 000000000000..87d3e7bd9bac
--- /dev/null
+++ b/net-mgmt/icli/pkg-descr
@@ -0,0 +1,12 @@
+Command line interface to Icinga.
+
+Features:
+
+- Listing of service/host states, check queue or downtimes
+- Detailed service/host info
+- Scheduling of service rechecks, acknowledging of problems
+- Detailed filtering (host(group)/service name, state, passive, acknowledged,
+ etc.)
+- Mostly nagios-compatible
+
+WWW: http://finalrewind.org/projects/icli/