aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-04 05:52:04 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-04 05:52:04 +0000
commit6337984890c98036209bdd2001ac29c3386bf22a (patch)
tree49987ebc7199c83bbbedf798b4bac41866d0e8b8 /net-mgmt
parent60142314b6fa572e821b7630f04ec5ef3bb3d0f2 (diff)
downloadports-6337984890c98036209bdd2001ac29c3386bf22a.tar.gz
ports-6337984890c98036209bdd2001ac29c3386bf22a.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/mrtg-ping-probe/Makefile2
-rw-r--r--net-mgmt/nagios-silfreed-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-snmp-plugins-extras/Makefile3
-rw-r--r--net-mgmt/nagios-spamd-plugin/Makefile2
-rw-r--r--net-mgmt/p5-Nagios-Object/Makefile3
-rw-r--r--net-mgmt/p5-Net-NSCA-Client/Makefile3
-rw-r--r--net-mgmt/p5-NetApp/Makefile3
-rw-r--r--net-mgmt/p5-SNMP-MIB-Compiler/Makefile3
-rw-r--r--net-mgmt/p5-Xymon-Server/Makefile3
9 files changed, 15 insertions, 9 deletions
diff --git a/net-mgmt/mrtg-ping-probe/Makefile b/net-mgmt/mrtg-ping-probe/Makefile
index 40d76fe31285..2562381300aa 100644
--- a/net-mgmt/mrtg-ping-probe/Makefile
+++ b/net-mgmt/mrtg-ping-probe/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/mrtg:${PORTSDIR}/net-mgmt/mrtg
FETCH_BEFORE_ARGS= -p # MASTER_SITE needs PASSIVE FTP.
-USE_PERL5= YES
+USES= perl5
MAN1= ${PORTNAME}.1
diff --git a/net-mgmt/nagios-silfreed-plugins/Makefile b/net-mgmt/nagios-silfreed-plugins/Makefile
index 605287c6bcf3..e441ad44de7e 100644
--- a/net-mgmt/nagios-silfreed-plugins/Makefile
+++ b/net-mgmt/nagios-silfreed-plugins/Makefile
@@ -33,7 +33,7 @@ RUN_DEPENDS+= \
${LOCALBASE}/bin/expect:${PORTSDIR}/lang/expect
.endif
-USE_PERL5= yes
+USES= perl5
NO_WRKSUBDIR= yes
NAGIOS_PLUGIN_DIR= ${PREFIX}/libexec/nagios
diff --git a/net-mgmt/nagios-snmp-plugins-extras/Makefile b/net-mgmt/nagios-snmp-plugins-extras/Makefile
index 88ec664c044c..d493b6e128b5 100644
--- a/net-mgmt/nagios-snmp-plugins-extras/Makefile
+++ b/net-mgmt/nagios-snmp-plugins-extras/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= alexey@renatasystems.org
COMMENT= A set of Nagios plugins written in Perl to check devices with SNMP
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
RUN_DEPENDS+= p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
${LOCALBASE}/libexec/nagios/utils.pm:${PORTSDIR}/net-mgmt/nagios-plugins
diff --git a/net-mgmt/nagios-spamd-plugin/Makefile b/net-mgmt/nagios-spamd-plugin/Makefile
index 5e75e83cba5b..64d570cb95aa 100644
--- a/net-mgmt/nagios-spamd-plugin/Makefile
+++ b/net-mgmt/nagios-spamd-plugin/Makefile
@@ -17,7 +17,7 @@ COMMENT= Nagios plugin for checking SpamAssassins spamd
RUN_DEPENDS+= ${LOCALBASE}/${NAGIOS_PLUGIN_DIR}/utils.pm:${PORTSDIR}/net-mgmt/nagios-plugins
-USE_PERL5= yes
+USES= perl5
NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= ${NAGIOS_PLUGIN_DIR}/check_spamd.pl
diff --git a/net-mgmt/p5-Nagios-Object/Makefile b/net-mgmt/p5-Nagios-Object/Makefile
index 11815395211c..6c8248f44d9e 100644
--- a/net-mgmt/p5-Nagios-Object/Makefile
+++ b/net-mgmt/p5-Nagios-Object/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Test-Exception>=0.31:${PORTSDIR}/devel/p5-Test-Exception \
p5-Test-NoWarnings>=1.01:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= parse.pl.1 \
config_status_demo.pl.1 \
diff --git a/net-mgmt/p5-Net-NSCA-Client/Makefile b/net-mgmt/p5-Net-NSCA-Client/Makefile
index 8e532348fb6f..68beec7357b3 100644
--- a/net-mgmt/p5-Net-NSCA-Client/Makefile
+++ b/net-mgmt/p5-Net-NSCA-Client/Makefile
@@ -40,7 +40,8 @@ TEST_DEPENDS= p5-Test-Class>=0.37:${PORTSDIR}/devel/p5-Test-Class \
p5-Test-Requires>=0.06:${PORTSDIR}/devel/p5-Test-Requires \
p5-Test-TCP>=1.17:${PORTSDIR}/devel/p5-Test-TCP
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::NSCA::Client.3 \
Net::NSCA::Client::DataPacket.3 \
diff --git a/net-mgmt/p5-NetApp/Makefile b/net-mgmt/p5-NetApp/Makefile
index 7e5d1f1675fa..5f985b63a10b 100644
--- a/net-mgmt/p5-NetApp/Makefile
+++ b/net-mgmt/p5-NetApp/Makefile
@@ -26,7 +26,8 @@ RUN_DEPENDS= p5-IPC-Cmd>=0:${PORTSDIR}/devel/p5-IPC-Cmd \
p5-Clone>=0:${PORTSDIR}/devel/p5-Clone
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= NetApp::Aggregate.3 \
NetApp::Aggregate::Plex.3 \
diff --git a/net-mgmt/p5-SNMP-MIB-Compiler/Makefile b/net-mgmt/p5-SNMP-MIB-Compiler/Makefile
index ea0063aa1abb..b85abaf10ba5 100644
--- a/net-mgmt/p5-SNMP-MIB-Compiler/Makefile
+++ b/net-mgmt/p5-SNMP-MIB-Compiler/Makefile
@@ -16,7 +16,8 @@ COMMENT= A Perl MIB compiler supporting both SMIv1 and SMIv2
BUILD_DEPENDS= p5-Data-Compare>=0:${PORTSDIR}/devel/p5-Data-Compare
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= SNMP::MIB::Compiler.3 \
Bundle::SNMP::MIB::Compiler.3
diff --git a/net-mgmt/p5-Xymon-Server/Makefile b/net-mgmt/p5-Xymon-Server/Makefile
index f4ef3a5d6708..1fb7634b404c 100644
--- a/net-mgmt/p5-Xymon-Server/Makefile
+++ b/net-mgmt/p5-Xymon-Server/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Xymon Server Interface
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Xymon::Server.3