aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-05-17 15:09:21 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-05-17 15:09:21 +0000
commitf9149684aedb20e25e461b9e3c24d3ccd96e1b0c (patch)
tree730e3b9e17731055e3a49f953dd13f80ca751408 /net-mgmt
parent6c8a55027327560bedec9c0fb32fe935d05e6415 (diff)
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ourmon/Makefile82
-rw-r--r--net-mgmt/ourmon/distinfo6
-rw-r--r--net-mgmt/ourmon/files/ourmon.in53
-rw-r--r--net-mgmt/ourmon/files/pkg-message.in40
-rw-r--r--net-mgmt/ourmon/pkg-descr2
-rw-r--r--net-mgmt/ourmon/pkg-message28
-rw-r--r--net-mgmt/ourmon/pkg-plist435
7 files changed, 409 insertions, 237 deletions
diff --git a/net-mgmt/ourmon/Makefile b/net-mgmt/ourmon/Makefile
index cdce5da2dbdf..34b2cf54c2c3 100644
--- a/net-mgmt/ourmon/Makefile
+++ b/net-mgmt/ourmon/Makefile
@@ -4,67 +4,41 @@
#
# $FreeBSD$
-PORTNAME= ourmon
-PORTVERSION= 2.5
-PORTREVISION= 1
-CATEGORIES= net-mgmt
-MASTER_SITES= http://ourmon.cat.pdx.edu/ourmon/
-DISTNAME= ourmon25
-
-MAINTAINER= manos@cs.pdx.edu
-COMMENT= A libpcap-based network monitoring and anomaly detection system
-
-BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-LIB_DEPENDS= gd:$(PORTSDIR)/graphics/gd
-RUN_DEPENDS= rrdtool:$(PORTSDIR)/databases/rrdtool
-
-#IS_INTERACTIVE= yes
-WRKSRC= ${WRKDIR}/mrourmon
-USE_PERL5= yes
+PORTNAME= ourmon
+PORTVERSION= 2.8.1
+CATEGORIES= net-mgmt
+MASTER_SITES= SF
+DISTNAME= ourmon281
+
+MAINTAINER= manos@cs.pdx.edu
+COMMENT= A libpcap-based network monitoring and anomaly detection system
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap \
+ ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
+
+WRKSRC= ${WRKDIR}/mrourmon
+USE_APACHE= yes
+USE_PERL5= yes
+NO_BUILD= yes
NO_INSTALL_MANPAGES= yes
-#NO_PACKAGE= yes
-NO_BUILD= yes
-# where to install ourmon and also
-# where we build the ourmon runtime-script with configure.pl
-# note: we use the work directory simply for unpacking
+SUB_FILES= pkg-message
-# make simply states assumptions, unpacks the system, and puts it in PREFIX
-pre-build:
- @${ECHO_MSG} "install dir is PREFIX=\"${PREFIX}/mrourmon\""
- @${ECHO_MSG} "We do not install apache or some other web server for you.
- @${ECHO_MSG} "You should know where your apache docs directory is before make install."
- @${ECHO_MSG} "You should also know which network interface you want ourmon to use."
- @${ECHO_MSG}
- @${ECHO_MSG} "Ourmon may be installed on one CPU or two. If you"
- @${ECHO_MSG} "are only installing the front-end probe, you do"
- @${ECHO_MSG} "not need Apache, hence we do not install it."
- @${ECHO_MSG} "If you are installing the back-end graphics engine"
- @${ECHO_MSG} "(which needs a web server) do install Apache first, and note"
- @${ECHO_MSG} "where the htdocs web directory lives. You will need"
- @${ECHO_MSG} "that for ourmon configuration. If you simply"
- @${ECHO_MSG} "want to install ourmon with both front-end and back-end"
- @${ECHO_MSG} "on one CPU, then install Apache first on that machine."
- @${ECHO_MSG}
+USE_RC_SUBR= ourmon
-pre-install:
-.if exists(${PREFIX}/etc/ourmon.conf)
- ${MV} ${PREFIX}/etc/ourmon.conf ${PREFIX}/etc/ourmon.conf.old
-.endif
- $(CP) -R ${WRKSRC} ${PREFIX}
+.include <bsd.port.pre.mk>
-# make install compiles and configures the system installing
-# all binaries in the local PREFIX/bin as well as asking
-# the user if he/she wants to install system start scripts
-# and modify /etc/crontab
+pre-everything:
+ @${ECHO_MSG} "==================================================="
+ @${ECHO_MSG} "ATTENTION: Do not install startup script during"
+ @${ECHO_MSG} "interactive steps, use the created by port instead."
+ @${ECHO_MSG} "==================================================="
do-install:
- cd ${PREFIX}/mrourmon && ${PERL5} configure.pl ${PREFIX}
+ @cd ${WRKSRC} && ${PERL5} configure.pl ${PREFIX}
+ @${CP} -R ${WRKSRC} ${PREFIX}
post-install:
- @${ECHO_MSG} "Ourmon is installed in ${PREFIX}"
- @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
- @${ECHO_MSG}
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/ourmon/distinfo b/net-mgmt/ourmon/distinfo
index d72dd9259b2c..46af73965b65 100644
--- a/net-mgmt/ourmon/distinfo
+++ b/net-mgmt/ourmon/distinfo
@@ -1,3 +1,3 @@
-MD5 (ourmon25.tar.gz) = 23353c42d2432793345b19ac0a77dfdb
-SHA256 (ourmon25.tar.gz) = 4a7996bda1fdf1f8f3d76dfec8dfd1a0cf575406b10f0764a435ce5596c53d2d
-SIZE (ourmon25.tar.gz) = 330622
+MD5 (ourmon281.tar.gz) = 721c52038d3c3dd30afb77e5eaac9388
+SHA256 (ourmon281.tar.gz) = e0d8159dd25680807653aed9f446e4b96feb2dc9c535765b51a88e601d5bf52e
+SIZE (ourmon281.tar.gz) = 404102
diff --git a/net-mgmt/ourmon/files/ourmon.in b/net-mgmt/ourmon/files/ourmon.in
new file mode 100644
index 000000000000..3b704ea100f2
--- /dev/null
+++ b/net-mgmt/ourmon/files/ourmon.in
@@ -0,0 +1,53 @@
+#!/bin/sh
+
+# PROVIDE: ourmon
+# REQUIRE: LOGIN
+#
+# Add the follow line to /etc/rc.conf to enable ourmon:
+# ourmon_enable (bool): Set it to "YES" to enable ourmon.
+# Default is "NO".
+# ourmon_flags (str): Flags passed to ourmon-script on startup.
+# Default is "-a 30 -s 256 -f
+# /usr/local/mrourmon/etc/ourmon.conf -i re0 -D /usr/local/mrourmon/tmp"
+#
+# The sysctl variables exist to reduce dropped packets.
+# NOTE: on BSD, you may need a recent version of libpcap for this to work
+# get it from: www.tcpdump.org.
+# On BSD: compare sysctl -a outputs to /var/log/messages, bpf bufsizes should match!
+
+
+. %%RC_SUBR%%
+
+name="ourmon"
+rcvar=${name}_enable
+command="%%PREFIX%%/mrourmon/bin/ourmon"
+
+load_rc_config $name
+
+: ${ourmon_enable="NO"}
+: ${ourmon_flags="-a 30 -s 256 -f /usr/local/mrourmon/etc/ourmon.conf -i re0 -D /usr/local/mrourmon/tmp"}
+
+start_cmd=${name}_start
+
+ourmon_start () {
+ sysctl -w net.bpf_bufsize=8388608
+ sysctl -w net.bpf_maxbufsize=8388608
+ echo "Starting ourmon."
+ ${command} ${ourmon_flags}
+}
+
+ourmon_stop () {
+ echo "Stopping ourmon."
+ kill -9 `cat /var/run/ourmon.pid`
+}
+
+
+ourmon_restart () {
+ echo "Restarting ourmon."
+ ourmon_stop
+ ourmon_start
+}
+
+command_args="$ourmon_flags"
+
+run_rc_command "$1"
diff --git a/net-mgmt/ourmon/files/pkg-message.in b/net-mgmt/ourmon/files/pkg-message.in
new file mode 100644
index 000000000000..d409f52e3e6e
--- /dev/null
+++ b/net-mgmt/ourmon/files/pkg-message.in
@@ -0,0 +1,40 @@
+For the FreeBSD port, we assume:
+
+%%PREFIX%%/mrourmon
+
+is the base directory, although that can be overridden with
+the port Makefile.
+
+Read the INSTALL file in the ourmon base directory.
+**************************************************
+
+If you want to uninstall ourmon, read "uninstall.txt" in
+the base directory.
+
+Be sure and inspect and modify the basic config file,
+at %%PREFIX%%/mrourmon/etc/ourmon.conf. In particular
+set the notion of topn_syn home IP in the config file
+
+topn_syn_homeip 10.2.3.4/32
+
+to your home subnet and netmask.
+
+After setting the config file up properly,
+in order to start the front-end probe process,
+named "ourmon", you must cd to the base directory
+and run the ourmon probe from the start shellscript.
+
+# cd %%PREFIX%%/mrourmon/bin
+# ./ourmon.sh start
+
+If you use non-english language in console, set environment "LC_TIME" to "en_US"
+before runnings scripts, for example:
+############## ourmon crontab entries ###############
+# run ourmon back-end omupdate.pl etc. per minute
+*/1 * * * * root (export LC_TIME=en_US; %%PREFIX%%/mrourmon/bin/omupdate.sh)
+# batchip.sh - hourly log summary
+0 * * * * root (export LC_TIME=en_US; %%PREFIX%%/mrourmon/bin/batchip.sh)
+# batchipall.sh - roll over daily summary logs at almost midnight
+59 23 * * * root (export LC_TIME=en_US; %%PREFIX%%/mrourmon/bin/batchipall.sh)
+# daily.pl - re init next day logs at midnight
+0 0 * * * root (export LC_TIME=en_US; %%PREFIX%/mrourmon/bin/daily.pl %%PREFIX%%/mrourmon/logs)
diff --git a/net-mgmt/ourmon/pkg-descr b/net-mgmt/ourmon/pkg-descr
index fe5ab61c1b5f..c2c853f7cda9 100644
--- a/net-mgmt/ourmon/pkg-descr
+++ b/net-mgmt/ourmon/pkg-descr
@@ -10,7 +10,7 @@ graphs include a year of baselined information. New RRDTOOL graphs
may be designed with user-configured BPF expressions a la tcpdump.
Reports and logging for top talkers are also included.
-WWW: http://ourmon.cat.pdx.edu/ourmon/
+WWW: http://ourmon.sourceforge.net
Created by: Jim Binkley <jrb@cs.pdx.edu>
FreeBSD Port by: Charlie Schluting <manos@cs.pdx.edu>
diff --git a/net-mgmt/ourmon/pkg-message b/net-mgmt/ourmon/pkg-message
deleted file mode 100644
index e0d2bdc9dad6..000000000000
--- a/net-mgmt/ourmon/pkg-message
+++ /dev/null
@@ -1,28 +0,0 @@
-For the FreeBSD port, we assume
-
-/usr/local/mrourmon
-
-is the base directory, although that can be overridden with
-the port Makefile.
-
-Read the INSTALL file in the ourmon base directory.
-**************************************************
-
-If you want to uninstall ourmon, read "uninstall.txt" in
-the base directory.
-
-Be sure and inspect and modify the basic config file,
-at /usr/local/mrourmon/etc/ourmon.conf. In particular
-set the notion of topn_syn home IP in the config file
-
-topn_syn_homeip 10.1.0.0 255.255.0.0
-
-to your home subnet and netmask.
-
-After setting the config file up properly,
-in order to start the front-end probe process,
-named "ourmon", you must cd to the base directory
-and run the ourmon probe from the start shellscript.
-
-# cd /usr/local/mrourmon/bin
-# ./ourmon.sh start
diff --git a/net-mgmt/ourmon/pkg-plist b/net-mgmt/ourmon/pkg-plist
index ca2e4293c53b..7a68673addf3 100644
--- a/net-mgmt/ourmon/pkg-plist
+++ b/net-mgmt/ourmon/pkg-plist
@@ -1,167 +1,300 @@
-mrourmon/src/ourmon/copyright.h
-mrourmon/src/ourmon/pid.c
-mrourmon/ACKS
-mrourmon/CHANGE.LOG
-mrourmon/CHANGES
-mrourmon/INSTALL
-mrourmon/README
-mrourmon/TODO
-mrourmon/VERSION
-mrourmon/deb.sh
-mrourmon/etc/README
-mrourmon/etc/cbpfexamples.conf
-mrourmon/etc/crontab.sample
-mrourmon/etc/ourmon.conf
-mrourmon/scripts/README
-mrourmon/scripts/checkmon.sh
-mrourmon/src/README
-mrourmon/src/distros/freebsd/Makefile
-mrourmon/src/distros/freebsd/distinfo
-mrourmon/src/distros/freebsd/pkg-descr
-mrourmon/src/distros/freebsd/pkg-message
-mrourmon/src/distros/freebsd/x
-mrourmon/src/ourmon/Makefile.bsd
-mrourmon/src/ourmon/Makefile.linux
-mrourmon/src/ourmon/Makefile.solaris
-mrourmon/src/ourmon/TODO
-mrourmon/src/ourmon/barthash.c
-mrourmon/src/ourmon/bytecodes.h
-mrourmon/src/ourmon/changed.c
-mrourmon/src/ourmon/config.h
-mrourmon/src/ourmon/docs/morep2p.txt
-mrourmon/src/ourmon/docs/p2p.txt
-mrourmon/src/ourmon/ehash.c
-mrourmon/src/ourmon/filter.h
-mrourmon/src/ourmon/hashicmp.h
-mrourmon/src/ourmon/hashport.h
-mrourmon/src/ourmon/hashscan.c
-mrourmon/src/ourmon/hashscan.h
-mrourmon/src/ourmon/hashsort.c
-mrourmon/src/ourmon/hashsort.h
-mrourmon/src/ourmon/hashsyn.h
-mrourmon/src/ourmon/interfaces.c
-mrourmon/src/ourmon/ipanalyze.c
-mrourmon/src/ourmon/ircscan.c
-mrourmon/src/ourmon/ircscan.h
-mrourmon/src/ourmon/machdep.c
-mrourmon/src/ourmon/nonipanalyze.c
-mrourmon/src/ourmon/ourmon.c
-mrourmon/src/ourmon/ourmon.h
-mrourmon/src/ourmon/sample.configs/foo.conf
-mrourmon/src/ourmon/sample.configs/goo.conf
-mrourmon/src/ourmon/sample.configs/icmp.conf
-mrourmon/src/ourmon/sample.configs/ourmon.conf
-mrourmon/src/ourmon/sample.configs/ourmon.conf.2
-mrourmon/src/ourmon/sample.configs/portrange.conf
-mrourmon/src/ourmon/sample.configs/test.conf
-mrourmon/src/ourmon/sample.configs/x.conf
-mrourmon/src/ourmon/sig.c
-mrourmon/src/ourmon/stats.h
-mrourmon/src/ourmon/trigger.h
-mrourmon/src/ourmon/util.c
-mrourmon/src/testcode/Makefile
-mrourmon/src/testcode/README
-mrourmon/src/testcode/testri.c
-mrourmon/src/web.code/Makefile
-mrourmon/src/web.code/NOTDONEYET
-mrourmon/src/web.code/README
-mrourmon/src/web.code/README.logs
+mrourmon/src/web.code/bard/bar99.png
+mrourmon/src/web.code/bard/bar57.png
+mrourmon/src/web.code/bard/bar52.png
+mrourmon/src/web.code/bard/bar30.png
+mrourmon/src/web.code/bard/bar100.png
+mrourmon/src/web.code/bard/bar26.png
+mrourmon/src/web.code/bard/bar55.png
+mrourmon/src/web.code/bard/bar27.png
+mrourmon/src/web.code/bard/bar56.png
+mrourmon/src/web.code/bard/bar79.png
+mrourmon/src/web.code/bard/bar87.png
+mrourmon/src/web.code/bard/bar76.png
+mrourmon/src/web.code/bard/bar41.png
+mrourmon/src/web.code/bard/bar11.png
+mrourmon/src/web.code/bard/bar81.png
+mrourmon/src/web.code/bard/bar44.png
+mrourmon/src/web.code/bard/bar50.png
+mrourmon/src/web.code/bard/bar16.png
+mrourmon/src/web.code/bard/bar29.png
+mrourmon/src/web.code/bard/bar94.png
+mrourmon/src/web.code/bard/bar77.png
+mrourmon/src/web.code/bard/bar8.png
+mrourmon/src/web.code/bard/bar51.png
+mrourmon/src/web.code/bard/bar28.png
+mrourmon/src/web.code/bard/bar83.png
+mrourmon/src/web.code/bard/bar36.png
+mrourmon/src/web.code/bard/bar86.png
+mrourmon/src/web.code/bard/bar21.png
+mrourmon/src/web.code/bard/bar46.png
+mrourmon/src/web.code/bard/bar48.png
+mrourmon/src/web.code/bard/bar20.png
+mrourmon/src/web.code/bard/bar15.png
+mrourmon/src/web.code/bard/bar89.png
+mrourmon/src/web.code/bard/bar6.png
+mrourmon/src/web.code/bard/bar72.png
+mrourmon/src/web.code/bard/bar74.png
+mrourmon/src/web.code/bard/bar34.png
+mrourmon/src/web.code/bard/bar69.png
+mrourmon/src/web.code/bard/bar17.png
+mrourmon/src/web.code/bard/bar12.png
+mrourmon/src/web.code/bard/bar84.png
+mrourmon/src/web.code/bard/bar23.png
+mrourmon/src/web.code/bard/bar92.png
+mrourmon/src/web.code/bard/bar88.png
+mrourmon/src/web.code/bard/bar13.png
+mrourmon/src/web.code/bard/bar59.png
+mrourmon/src/web.code/bard/bar78.png
+mrourmon/src/web.code/bard/bar3.png
+mrourmon/src/web.code/bard/bar45.png
+mrourmon/src/web.code/bard/bar25.png
+mrourmon/src/web.code/bard/bar22.png
+mrourmon/src/web.code/bard/bar96.png
+mrourmon/src/web.code/bard/bar24.png
+mrourmon/src/web.code/bard/bar62.png
+mrourmon/src/web.code/bard/bar95.png
+mrourmon/src/web.code/bard/bar71.png
+mrourmon/src/web.code/bard/bar9.png
+mrourmon/src/web.code/bard/bar40.png
+mrourmon/src/web.code/bard/bar90.png
+mrourmon/src/web.code/bard/bar33.png
+mrourmon/src/web.code/bard/bar42.png
+mrourmon/src/web.code/bard/bar61.png
+mrourmon/src/web.code/bard/bar66.png
+mrourmon/src/web.code/bard/bar97.png
+mrourmon/src/web.code/bard/bar58.png
+mrourmon/src/web.code/bard/bar80.png
+mrourmon/src/web.code/bard/bar93.png
+mrourmon/src/web.code/bard/bar2.png
+mrourmon/src/web.code/bard/bar64.png
+mrourmon/src/web.code/bard/bar65.png
+mrourmon/src/web.code/bard/bar53.png
+mrourmon/src/web.code/bard/bar68.png
+mrourmon/src/web.code/bard/bar39.png
+mrourmon/src/web.code/bard/bar14.png
+mrourmon/src/web.code/bard/bar18.png
+mrourmon/src/web.code/bard/bar75.png
+mrourmon/src/web.code/bard/bar67.png
+mrourmon/src/web.code/bard/bar1.png
+mrourmon/src/web.code/bard/bar60.png
+mrourmon/src/web.code/bard/bar10.png
+mrourmon/src/web.code/bard/bar49.png
+mrourmon/src/web.code/bard/bar85.png
+mrourmon/src/web.code/bard/bar47.png
+mrourmon/src/web.code/bard/bar37.png
+mrourmon/src/web.code/bard/bar82.png
+mrourmon/src/web.code/bard/bar4.png
+mrourmon/src/web.code/bard/bar63.png
+mrourmon/src/web.code/bard/bar32.png
+mrourmon/src/web.code/bard/bar31.png
+mrourmon/src/web.code/bard/bar5.png
+mrourmon/src/web.code/bard/bar70.png
+mrourmon/src/web.code/bard/bar43.png
+mrourmon/src/web.code/bard/bar91.png
+mrourmon/src/web.code/bard/bar7.png
+mrourmon/src/web.code/bard/bar35.png
+mrourmon/src/web.code/bard/bar73.png
+mrourmon/src/web.code/bard/bar38.png
+mrourmon/src/web.code/bard/bar19.png
+mrourmon/src/web.code/bard/bar54.png
+mrourmon/src/web.code/bard/bar98.png
+mrourmon/src/web.code/omupdate.pl
mrourmon/src/web.code/drawtopn.c
-mrourmon/src/web.code/testdraw.sh
+mrourmon/src/web.code/ombatchsyn.pl
+mrourmon/src/web.code/omupdate.sh
+mrourmon/src/web.code/wormtolog.pl
+mrourmon/src/web.code/makebar.pl
+mrourmon/src/web.code/README
+mrourmon/src/web.code/monbackup.pl
+mrourmon/src/web.code/ombatchip.pl
mrourmon/src/web.code/topn_udp.png
+mrourmon/src/web.code/drawbar.c
+mrourmon/src/web.code/tcpworm.pl
+mrourmon/src/web.code/testdraw.sh
+mrourmon/src/web.code/ombatchipsrc.pl
mrourmon/src/web.code/udptest.sh
-mrourmon/src/web.html/Makefile
-mrourmon/src/web.html/README
-mrourmon/src/web.html/bpf-emailsyns.html
+mrourmon/src/web.code/irc.pl
+mrourmon/src/web.code/batchip.sh
+mrourmon/src/web.code/Makefile
+mrourmon/src/web.code/batchipall.sh
+mrourmon/src/web.code/mklogdir.sh
+mrourmon/src/web.code/daily.pl
+mrourmon/src/web.html/info.topipa.html
+mrourmon/src/web.html/ourarch.png
+mrourmon/src/web.html/pss2.radar.stop.html
+mrourmon/src/web.html/neg.radar.stop.html
+mrourmon/src/web.html/indexstatic.html
+mrourmon/src/web.html/pss.radar.html
mrourmon/src/web.html/bpf-errors.html
-mrourmon/src/web.html/bpf-p2p.html
-mrourmon/src/web.html/bpf-ports.html
-mrourmon/src/web.html/bpf-protopkts.html
-mrourmon/src/web.html/bpf-subnets1.html
-mrourmon/src/web.html/bpf-tcpcontrol.html
-mrourmon/src/web.html/bpf-unreach.html
mrourmon/src/web.html/bpf-vpns.html
-mrourmon/src/web.html/cast.html
mrourmon/src/web.html/flow.html
-mrourmon/src/web.html/icmpcodes.txt
+mrourmon/src/web.html/dnsstats.html
+mrourmon/src/web.html/pkts.html
+mrourmon/src/web.html/scans.radar.stop.html
+mrourmon/src/web.html/topnstat.html
+mrourmon/src/web.html/tworm.html
+mrourmon/src/web.html/tcp3.html
+mrourmon/src/web.html/l2proto.html
+mrourmon/src/web.html/irc.html
+mrourmon/src/web.html/pss.radar.stop.html
+mrourmon/src/web.html/bpf-emailsyns.html
+mrourmon/src/web.html/netww.html
mrourmon/src/web.html/icmperror.html
-mrourmon/src/web.html/index.html
-mrourmon/src/web.html/indexstatic.html
-mrourmon/src/web.html/info.html
-mrourmon/src/web.html/info.topipa.html
-mrourmon/src/web.html/ipportscan.html
+mrourmon/src/web.html/pss2.radar.html
+mrourmon/src/web.html/README
+mrourmon/src/web.html/scans.radar.html
mrourmon/src/web.html/ipproto.html
-mrourmon/src/web.html/iprange1.html
+mrourmon/src/web.html/bpf-ports.html
+mrourmon/src/web.html/icmpcodes.txt
+mrourmon/src/web.html/neg.radar.html
mrourmon/src/web.html/ipscan.html
-mrourmon/src/web.html/irc.html
-mrourmon/src/web.html/l2proto.html
-mrourmon/src/web.html/netww.html
-mrourmon/src/web.html/ourarch.png
-mrourmon/src/web.html/pkts.html
-mrourmon/src/web.html/realhtml.txt
+mrourmon/src/web.html/udpscan.html
+mrourmon/src/web.html/bpf-unreach.html
+mrourmon/src/web.html/bpf-p2p.html
+mrourmon/src/web.html/index.html
mrourmon/src/web.html/size.html
-mrourmon/src/web.html/tcp3.html
-mrourmon/src/web.html/tcpports.html
-mrourmon/src/web.html/tcpscan.html
+mrourmon/src/web.html/bpf-subnets1.html
+mrourmon/src/web.html/cast.html
+mrourmon/src/web.html/bpf-tcpcontrol.html
+mrourmon/src/web.html/ipportscan.html
mrourmon/src/web.html/tcpsyn.html
-mrourmon/src/web.html/tingting.html
-mrourmon/src/web.html/topn_icmp.html
-mrourmon/src/web.html/topn_ip.html
-mrourmon/src/web.html/topn_tcp.html
-mrourmon/src/web.html/topn_udp.html
-mrourmon/src/web.html/topnstat.html
-mrourmon/src/web.html/tworm.html
-mrourmon/src/web.html/udperror.html
-mrourmon/src/web.html/udpports.html
-mrourmon/src/web.html/udpscan.html
+mrourmon/src/web.html/info.html
+mrourmon/src/web.html/l2pni.radar.html
+mrourmon/src/web.html/radar.html
+mrourmon/src/web.html/realhtml.txt
+mrourmon/src/web.html/radar.stop.html
+mrourmon/src/web.html/bpf-protopkts.html
+mrourmon/src/web.html/l2pni.radar.stop.html
mrourmon/src/web.html/udpweight.html
-mrourmon/uninstall.txt
-mrourmon/src/ourmon/hashicmp.c
-mrourmon/src/ourmon/hashport.c
+mrourmon/src/web.html/udperror.html
+mrourmon/src/web.html/iprange1.html
+mrourmon/src/web.html/radarlist.txt
+mrourmon/src/ourmon/hashblist.h
+mrourmon/src/ourmon/copyright.h
+mrourmon/src/ourmon/signal.c
+mrourmon/src/ourmon/ircscan.h
+mrourmon/src/ourmon/hashscan.c
+mrourmon/src/ourmon/spinlock.h
+mrourmon/src/ourmon/barthash.c
+mrourmon/src/ourmon/thread.h
+mrourmon/src/ourmon/ourpcap.c
+mrourmon/src/ourmon/hashicmp.h
mrourmon/src/ourmon/hashsyn.c
-mrourmon/src/ourmon/trigger.c
-mrourmon/configure.pl
-mrourmon/makeclean.sh
-mrourmon/scripts/monupdate.sh
-mrourmon/scripts/runourmon.pl
-mrourmon/src/ourmon/cprogram.c
+mrourmon/src/ourmon/Makefile.mmap.linux
+mrourmon/src/ourmon/sync.c
+mrourmon/src/ourmon/ehash.c
+mrourmon/src/ourmon/ipanalyze.c
+mrourmon/src/ourmon/patmatch.c
mrourmon/src/ourmon/cprogram.h
+mrourmon/src/ourmon/hashblist.c
+mrourmon/src/ourmon/hashdns.c
+mrourmon/src/ourmon/stringstore.c
+mrourmon/src/ourmon/hashsyn.h
+mrourmon/src/ourmon/bytecodes.h
+mrourmon/src/ourmon/spinlock.c
+mrourmon/src/ourmon/trigger.c
+mrourmon/src/ourmon/Makefile.linux
+mrourmon/src/ourmon/filter.h
+mrourmon/src/ourmon/thread.c
+mrourmon/src/ourmon/hashsort.c
+mrourmon/src/ourmon/Makefile.solaris
+mrourmon/src/ourmon/util.c
mrourmon/src/ourmon/filter.c
-mrourmon/src/ourmon/hashsort
+mrourmon/src/ourmon/hashport.c
+mrourmon/src/ourmon/hashicmp.c
+mrourmon/src/ourmon/stats.h
+mrourmon/src/ourmon/stringstore.h
+mrourmon/src/ourmon/cprogram.c
+mrourmon/src/ourmon/machdep.c
+mrourmon/src/ourmon/pktlinux.c
+mrourmon/src/ourmon/Makefile.mac
+mrourmon/src/ourmon/ircscan.c
+mrourmon/src/ourmon/nonipanalyze.c
+mrourmon/src/ourmon/hwflags.h
+mrourmon/src/ourmon/hashport.h
+mrourmon/src/ourmon/interfaces.c
+mrourmon/src/ourmon/trigger.h
+mrourmon/src/ourmon/hashscan.h
+mrourmon/src/ourmon/ourmon.c
+mrourmon/src/ourmon/sync.h
+mrourmon/src/ourmon/Makefile.mmap
+mrourmon/src/ourmon/ourmon.h
+mrourmon/src/ourmon/ourpcap.h
+mrourmon/src/ourmon/hashdns.h
+mrourmon/src/ourmon/patmatch.h
mrourmon/src/ourmon/monconfig.c
-mrourmon/src/ourmon/sample.configs/doit.sh
-mrourmon/src/ourmon/sample.configs/ourmon.sh
-mrourmon/src/ourmon/sample.configs/readit.sh
-mrourmon/src/ourmon/sample.configs/runourmon.sh
-mrourmon/src/testcode/testri
-mrourmon/src/web.code/batchip.sh
-mrourmon/src/web.code/batchipall.sh
-mrourmon/src/web.code/daily.pl
-mrourmon/src/web.code/irc.pl
-mrourmon/src/web.code/mklogdir.sh
-mrourmon/src/web.code/monbackup.pl
-mrourmon/src/web.code/notdoneyet/makepics.pl
-mrourmon/src/web.code/ombatchip.pl
-mrourmon/src/web.code/ombatchipsrc.pl
-mrourmon/src/web.code/ombatchsyn.pl
-mrourmon/src/web.code/omupdate.pl
-mrourmon/src/web.code/omupdate.sh
-mrourmon/src/web.code/tcpworm.pl
-mrourmon/src/web.code/topipa.pl
-mrourmon/src/web.code/wormtolog.pl
-
-@dirrm mrourmon/tmp
-@dirrm mrourmon/src/web.html
-@dirrm mrourmon/src/web.code/notdoneyet
-@dirrm mrourmon/src/web.code
-@dirrm mrourmon/src/testcode
-@dirrm mrourmon/src/ourmon/sample.configs
-@dirrm mrourmon/src/ourmon/docs
-@dirrm mrourmon/src/ourmon
-@dirrm mrourmon/src/distros/freebsd
-@dirrm mrourmon/src/distros
-@dirrm mrourmon/src
-@dirrm mrourmon/scripts
-@dirrm mrourmon/etc
-@dirrm mrourmon/bin
-@dirrm mrourmon
+mrourmon/src/ourmon/hashsort.h
+mrourmon/src/ourmon/ourmon.conf
+mrourmon/src/ourmon/config.h
+mrourmon/src/ourmon/Makefile.bsd
+mrourmon/src/ourmon/ourmon.sh
+mrourmon/src/scripts/stirc.pl
+mrourmon/src/scripts/getssbots.sh
+mrourmon/src/scripts/README
+mrourmon/src/scripts/stoo.pl
+mrourmon/src/scripts/sizecheck.pl
+mrourmon/src/ircfr/ircfr.h
+mrourmon/src/ircfr/Makefile.bsd
+mrourmon/src/ircfr/copyright.h
+mrourmon/src/ircfr/ircfr.c
+mrourmon/src/ircfr/ircscan.h
+mrourmon/src/ircfr/ipanalyze.c
+mrourmon/src/ircfr/README
+mrourmon/src/ircfr/Makefile.linux
+mrourmon/src/ircfr/filter.h
+mrourmon/src/ircfr/util.c
+mrourmon/src/ircfr/filter.c
+mrourmon/src/ircfr/machdep.c
+mrourmon/src/ircfr/ircfr.sh
+mrourmon/src/ircfr/ircscan.c
+mrourmon/src/ircfr/interfaces.c
+mrourmon/src/ircfr/config.h
+mrourmon/src/README
+mrourmon/bin/mklogdir.sh
+mrourmon/bin/omupdate.sh
+mrourmon/bin/batchipall.sh
+mrourmon/bin/batchip.sh
+mrourmon/bin/monbackup.pl
+mrourmon/bin/daily.pl
+mrourmon/bin/wormtolog.pl
+mrourmon/bin/ombatchsyn.pl
+mrourmon/bin/ombatchipsrc.pl
+mrourmon/bin/ombatchip.pl
+mrourmon/bin/irc.pl
+mrourmon/bin/tcpworm.pl
+mrourmon/bin/omupdate.pl
+mrourmon/bin/ourmon
+mrourmon/etc/cbpfexamples.conf
+mrourmon/etc/README
+mrourmon/etc/ourmon.conf
+mrourmon/etc/secmin.conf
+mrourmon/etc/crontab.sample
+mrourmon/scripts/checkmon.sh
+mrourmon/scripts/monupdate.sh
+mrourmon/scripts/README
+mrourmon/scripts/runourmon.pl
+mrourmon/README.bsd
+mrourmon/INSTALL
+mrourmon/ACKS
+mrourmon/uninstall.txt
+mrourmon/README
+mrourmon/web.pages
+mrourmon/CHANGES
+mrourmon/VERSION
+mrourmon/README.linux
+mrourmon/makeclean.sh
+mrourmon/configure.pl
+mrourmon/ubuntudep.sh
+@dirrmtry mrourmon/src/web.code/bard
+@dirrmtry mrourmon/src/web.code
+@dirrmtry mrourmon/src/web.html
+@dirrmtry mrourmon/src/ourmon
+@dirrmtry mrourmon/src/scripts
+@dirrmtry mrourmon/src/ircfr
+@dirrmtry mrourmon/src
+@dirrmtry mrourmon/bin
+@dirrmtry mrourmon/etc
+@dirrmtry mrourmon/scripts
+@dirrmtry mrourmon/tmp
+@dirrmtry mrourmon/rrddata
+@dirrmtry mrourmon