aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-10 16:24:04 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-10 16:24:04 +0000
commit17f3d4c9acc7daa78823ad13cbe5879466e148dd (patch)
tree79c4972c0450b8bc2b8f4dc69beb9acb906b2eae /net-mgmt
parent8006488985501c22dce252d7dbc1b4e7fd0a84a1 (diff)
downloadports-17f3d4c9acc7daa78823ad13cbe5879466e148dd.tar.gz
ports-17f3d4c9acc7daa78823ad13cbe5879466e148dd.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/docsis/Makefile5
-rw-r--r--net-mgmt/docsis/files/patch-md5.h22
2 files changed, 24 insertions, 3 deletions
diff --git a/net-mgmt/docsis/Makefile b/net-mgmt/docsis/Makefile
index 1dae1fda874c..747ef8104153 100644
--- a/net-mgmt/docsis/Makefile
+++ b/net-mgmt/docsis/Makefile
@@ -7,10 +7,9 @@
PORTNAME= docsis
PORTVERSION= 0.9.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= jflemer@alum.rpi.edu
COMMENT= DOCSIS(tm) binary configuration file encoder/decoder
diff --git a/net-mgmt/docsis/files/patch-md5.h b/net-mgmt/docsis/files/patch-md5.h
new file mode 100644
index 000000000000..b82cd66a30f8
--- /dev/null
+++ b/net-mgmt/docsis/files/patch-md5.h
@@ -0,0 +1,22 @@
+# $FreeBSD$
+--- src/md5.h.orig 2004-03-17 07:09:31.000000000 -0800
++++ src/md5.h 2009-05-07 19:41:20.000000000 -0700
+@@ -22,14 +22,16 @@
+ documentation and/or software.
+ */
+
++#include <stdint.h>
++
+ /* POINTER defines a generic pointer type */
+ typedef unsigned char *POINTER;
+
+ /* UINT2 defines a two byte word */
+-typedef unsigned short int UINT2;
++typedef uint16_t UINT2;
+
+ /* UINT4 defines a four byte word */
+-typedef unsigned long int UINT4;
++typedef uint32_t UINT4;
+
+ /* MD5 context. */
+ typedef struct {