aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net-mgmt
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/angst/Makefile16
-rw-r--r--net-mgmt/cdpd/Makefile11
-rw-r--r--net-mgmt/ettercap/Makefile19
-rw-r--r--net-mgmt/gps/Makefile20
-rw-r--r--net-mgmt/isic/Makefile11
-rw-r--r--net-mgmt/knowlan/Makefile15
-rw-r--r--net-mgmt/packit/Makefile25
-rw-r--r--net-mgmt/pixilate/Makefile21
-rw-r--r--net-mgmt/scdp/Makefile14
-rw-r--r--net-mgmt/sing/Makefile11
-rw-r--r--net-mgmt/tcpreplay/Makefile16
11 files changed, 121 insertions, 58 deletions
diff --git a/net-mgmt/angst/Makefile b/net-mgmt/angst/Makefile
index 248b6c911500..110fc8a3a8a8 100644
--- a/net-mgmt/angst/Makefile
+++ b/net-mgmt/angst/Makefile
@@ -8,7 +8,7 @@
PORTNAME= angst
PORTVERSION= 0.4b
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_PACKETSTORM:S:%SUBDIR%:sniffers/angst:}
@@ -17,17 +17,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An active sniffer
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
-
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
MAN8= angst.8
PLIST_FILES= sbin/angst
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
post-patch:
- @${REINPLACE_CMD} -e "s,^CC,#CC,g ; \
- s,^CFLAGS,#CFLAGS,g ; \
- s,libnet-config,${LIBNET_CONFIG},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -Ee \
+ 's,^(CC|CFLAGS).*,#&,; \
+ s,libnet-config,${LIBNET_CONFIG},; \
+ s,--defines,& --cflags,' \
+ ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
diff --git a/net-mgmt/cdpd/Makefile b/net-mgmt/cdpd/Makefile
index 318f6f46b757..428221735b3c 100644
--- a/net-mgmt/cdpd/Makefile
+++ b/net-mgmt/cdpd/Makefile
@@ -6,17 +6,24 @@
PORTNAME= cdpd
PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
MAINTAINER= ports@FreeBSD.org
COMMENT= CDPdaemon - sends Cisco Discovery Protocol announces over ethernet
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
GNU_CONFIGURE= yes
+CFLAGS+= `${LIBNET_CONFIG} --cflags`
MAN8= cdpd.8
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG:T}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.mk>
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index 3a64b1b3fd4a..b84c42e51d99 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ettercap
PORTVERSION= 0.7.3
DISTVERSIONPREFIX= NG-
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= net-mgmt security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
@@ -18,7 +18,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mnag@FreeBSD.org
COMMENT= A network sniffer/interceptor/injector/logger for switched LANs
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
OPTIONS= GTK "Build with GTK2+ GUI" on \
ICONV "Build with support for UTF-8" on \
@@ -36,13 +36,16 @@ DOCS= AUTHORS CHANGELOG README README.BINARIES README.BUGS \
README.CVS README.PLATFORMS THANKS TODO TODO.TESTING \
doc/capture doc/decoders doc/dissectors doc/threads
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
.include <bsd.port.pre.mk>
CFLAGS+= ${PTHREAD_CFLAGS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+= --enable-plugins --with-libnet=${LOCALBASE}
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ LIBS="${LDFLAGS}"
+CONFIGURE_ARGS+= --enable-plugins
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if ${OSVERSION} < 502111
@@ -88,8 +91,12 @@ CONFIGURE_ARGS+= --without-openssl
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -Ee \
+ 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|; \
+ s|test -f /usr/include/libnet\.h|${TRUE}|; \
+ s|(LNETINC=).*|\1"`${LIBNET_CONFIG} --cflags`"|; \
+ s|(LNETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -E -e 's|(^pkgdatadir.+=).+|\1 ${DATADIR}|' \
${WRKSRC}/share/Makefile.in
diff --git a/net-mgmt/gps/Makefile b/net-mgmt/gps/Makefile
index 20b231758f0d..3f268c97d6db 100644
--- a/net-mgmt/gps/Makefile
+++ b/net-mgmt/gps/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gps
PORTVERSION= 0.9.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= http://www.bsd-geek.de/FreeBSD/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION}-FRC
@@ -16,14 +16,24 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-FRC
MAINTAINER= lars.engels@0x20.net
COMMENT= Ghost Port Scan
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+.include <bsd.port.pre.mk>
+
post-patch:
- @${REINPLACE_CMD} -e "s,-Wall -O3,${CFLAGS},g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|-Wall -O3|${CFLAGS}|; \
+ s|-lnet|`${LIBNET_CONFIG} --libs`|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e \
+ 's|libnet-config|${LIBNET_CONFIG}|; \
+ s|--defines|& --cflags|' \
+ ${WRKSRC}/Makefile.in
.if !defined(NOPORTDOCS)
post-install:
@@ -31,4 +41,4 @@ post-install:
${CP} ${WRKSRC}/docs/* ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/isic/Makefile b/net-mgmt/isic/Makefile
index 381810a88b66..2db223097ea9 100644
--- a/net-mgmt/isic/Makefile
+++ b/net-mgmt/isic/Makefile
@@ -7,6 +7,7 @@
PORTNAME= isic
PORTVERSION= 0.07
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,10 +16,18 @@ EXTRACT_SUFX= .tgz
MAINTAINER= wxs@atarininja.org
COMMENT= IP Stack Integrity Checker
-BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
MAN1= isic.1
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/net-mgmt/knowlan/Makefile b/net-mgmt/knowlan/Makefile
index 96f932070dde..acf8be08d61a 100644
--- a/net-mgmt/knowlan/Makefile
+++ b/net-mgmt/knowlan/Makefile
@@ -7,17 +7,28 @@
PORTNAME= knowlan
PORTVERSION= 0.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://www.enderunix.org/knowlan/
MAINTAINER= ofsen@enderunix.org
COMMENT= ARP-based LAN IP and MAC Address Extractor
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
HAS_CONFIGURE= yes
CONFIGURE_ENV= PREFIX="${PREFIX}" LOCALBASE="${LOCALBASE}"
+CFLAGS+= `${LIBNET_CONFIG} --cflags`
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '95d; 102d; 116,117d; \
+ s|libnet-config|${LIBNET_CONFIG}|; \
+ s|$${LOCALBASE}/lib/libnet.a|`${LIBNET_CONFIG} --libs`|; \
+ s|gcc|${CC}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/knowlan ${PREFIX}/sbin
diff --git a/net-mgmt/packit/Makefile b/net-mgmt/packit/Makefile
index df114749328a..23886e6f339d 100644
--- a/net-mgmt/packit/Makefile
+++ b/net-mgmt/packit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= packit
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://packit.sourceforge.net/downloads/
EXTRACT_SUFX= .tgz
@@ -15,16 +15,16 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Network auditing tool
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet-config
MAN8= packit.8
PLIST_FILES= sbin/packit
-GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
.if defined(WITHOUT_CAPTURE)
CONFIGURE_ARGS+= --without-capture
@@ -33,13 +33,8 @@ CONFIGURE_ARGS+= --without-capture
CONFIGURE_ARGS+= --without-injection
.endif
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} ""#######################################################
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You need ${PORTSDIR}/net/libnet to build this port
- @${ECHO_MSG} ""
- @${ECHO_MSG} ""#######################################################
- @${ECHO_MSG} ""
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>
diff --git a/net-mgmt/pixilate/Makefile b/net-mgmt/pixilate/Makefile
index 38a3cdd50378..fd21bcf9c904 100644
--- a/net-mgmt/pixilate/Makefile
+++ b/net-mgmt/pixilate/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pixilate
PORTVERSION= 0.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= winfingerprint
@@ -14,25 +14,28 @@ MASTER_SITE_SUBDIR= winfingerprint
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates packets to match a list of Cisco PIX access lists
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
WRKSRC= ${WRKDIR}/pixilate
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet-config
-CFLAGS+= `${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
-CFLAGS+= -I${LOCALBASE}/include
-LIBS= `${LIBNET_CONFIG} --libs`
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:15 autoconf:253
+USE_AUTOTOOLS= automake:15 autoconf:259
AUTOMAKE_ARGS= --add-missing
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${LIBS}" CPPFLAGS="-I${LOCALBASE}/include"
+#CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${LIBS}" CPPFLAGS="-I${LOCALBASE}/include"
MAN1= pixilate.1
PORTDOCS= README
PLIST_FILES= bin/pixilate
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|libnet-config|${LIBNET_CONFIG}|; \
+ s|--defines`|& `${LIBNET_CONFIG} --cflags`|' \
+ ${WRKSRC}/configure.ac
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/net-mgmt/scdp/Makefile b/net-mgmt/scdp/Makefile
index 1e225ffc565f..1d209646614e 100644
--- a/net-mgmt/scdp/Makefile
+++ b/net-mgmt/scdp/Makefile
@@ -6,7 +6,7 @@
PORTNAME= scdp
PORTVERSION= 1.0.b
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= scdp
@@ -15,13 +15,19 @@ DISTNAME= scdp-${PORTVERSION:S/.b/b/}
MAINTAINER= arved@FreeBSD.org
COMMENT= "Tool that sends CDP (CISCO Discovery Protocol) Packets"
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
-PLIST_FILES= bin/scdp
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= libnet_config="${LIBNET_CONFIG}"
+CFLAGS+= `${LIBNET_CONFIG} --cflags`
+PLIST_FILES= bin/scdp
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
post-patch:
${REINPLACE_CMD} -e 's,malloc.h,stdlib.h,' ${WRKSRC}/scdp.c
+ ${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.include <bsd.port.mk>
diff --git a/net-mgmt/sing/Makefile b/net-mgmt/sing/Makefile
index 40f633a9e96d..52d6307567fb 100644
--- a/net-mgmt/sing/Makefile
+++ b/net-mgmt/sing/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sing
PORTVERSION= 1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -17,14 +17,17 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for sending customized ICMP packets
-BUILD_DEPENDS= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+= --with-libnet-prefix=${LOCALBASE} --with-libpcap-prefix=/usr
GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-libpcap-prefix=/usr
+CONFIGURE_ENV= CPPFLAGS="`${LIBNET_CONFIG} --defines` \
+ `${LIBNET_CONFIG} --cflags`" LIBS="`${LIBNET_CONFIG} --libs`"
MAN8= sing.8
PLIST_FILES= sbin/sing
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
+
post-extract:
@${RM} -rf ${WRKSRC}/libpcap-* ;\
${RM} -rf ${WRKSRC}/Libnet-*
diff --git a/net-mgmt/tcpreplay/Makefile b/net-mgmt/tcpreplay/Makefile
index 36d1b830796f..fce858982c9c 100644
--- a/net-mgmt/tcpreplay/Makefile
+++ b/net-mgmt/tcpreplay/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tcpreplay
PORTVERSION= 2.3.5
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,18 +15,27 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= laszlof@FreeBSD.org
COMMENT= A tool to replay saved packet capture files
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet \
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet \
${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
GNU_CONFIGURE= yes
-# Pickup correct pcap.h; CFLAGS gets overwritten
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
CONFIGURE_ARGS= --with-libpcap=${LOCALBASE} \
--without-pcapnav-config
+CFLAGS+= `${LIBNET_CONFIG} --cflags` -I${LOCALBASE}/include
MAN1= capinfo.1 tcpprep.1 pcapmerge.1 flowreplay.1
MAN8= tcpreplay.8
PLIST_FILES= bin/capinfo bin/pcapmerge bin/tcpprep sbin/tcpreplay bin/flowreplay
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
+post-patch:
+ @${REINPLACE_CMD} -Ee \
+ 's|-pipe -Wall|$$CFLAGS &|; \
+ s|^(foundnet=)no|\1yes|; \
+ s|\$$LNETLIB|`${LIBNET_CONFIG} --libs`|; \
+ s|\$$LNETINCDIR/||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
.include <bsd.port.mk>