aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-01-15 16:04:16 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-01-15 16:04:16 +0000
commit37c4b71bf8176f042d98b9be2c9e2e5a4cddc7d5 (patch)
treef38459d1086f254a8d3c0a3f0b034b79c04dc80c /net-mgmt
parentb31fd9c2f33c118dc5478769f7934e7822d65a22 (diff)
downloadports-37c4b71bf8176f042d98b9be2c9e2e5a4cddc7d5.tar.gz
ports-37c4b71bf8176f042d98b9be2c9e2e5a4cddc7d5.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-plugins/Makefile2
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl2
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ircd.pl (renamed from net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl)0
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ntp.pl (renamed from net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ntp.pl)0
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins_check__pgsql.c (renamed from net-mgmt/nagios-plugins/files/patch-plugins__check_pgsql.c)0
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins_check__ssh.c (renamed from net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c)0
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins_sslutils.c16
7 files changed, 18 insertions, 2 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 2c1fe10837ad..f1989e1774bc 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nagios-plugins
PORTVERSION= 2.1.1
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= https://www.nagios-plugins.org/download/ \
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl
index 293fdea1b59e..38475e97ba3e 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__file__age.pl
@@ -1,4 +1,4 @@
---- plugins-scripts/check_file_age.pl.orig 2015-09-08 21:18:08 UTC
+--- plugins-scripts/check_file_age.pl.orig 2015-07-30 21:40:06 UTC
+++ plugins-scripts/check_file_age.pl
@@ -26,7 +26,8 @@ use English;
use Getopt::Long;
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ircd.pl
index 5b09476f279d..5b09476f279d 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ircd.pl
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ircd.pl
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ntp.pl b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ntp.pl
index 40e8668f427b..40e8668f427b 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__check_ntp.pl
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts_check__ntp.pl
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins__check_pgsql.c b/net-mgmt/nagios-plugins/files/patch-plugins_check__pgsql.c
index 3da67fb48a92..3da67fb48a92 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins__check_pgsql.c
+++ b/net-mgmt/nagios-plugins/files/patch-plugins_check__pgsql.c
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c b/net-mgmt/nagios-plugins/files/patch-plugins_check__ssh.c
index 22862e326e3a..22862e326e3a 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins__check_ssh.c
+++ b/net-mgmt/nagios-plugins/files/patch-plugins_check__ssh.c
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins_sslutils.c b/net-mgmt/nagios-plugins/files/patch-plugins_sslutils.c
new file mode 100644
index 000000000000..1c531d4ca98c
--- /dev/null
+++ b/net-mgmt/nagios-plugins/files/patch-plugins_sslutils.c
@@ -0,0 +1,16 @@
+--- plugins/sslutils.c.orig 2015-07-30 21:40:06 UTC
++++ plugins/sslutils.c
+@@ -70,8 +70,13 @@ int np_net_ssl_init_with_hostname_versio
+ #endif
+ break;
+ case 3: /* SSLv3 protocol */
++#if defined(OPENSSL_NO_SSL3)
++ printf(("%s\n", _("CRITICAL - SSL protocol version 3 is not supported by your SSL library.")));
++ return STATE_CRITICAL;
++#else
+ method = SSLv3_client_method();
+ ssl_options = SSL_OP_NO_SSLv2 | SSL_OP_NO_TLSv1;
++#endif
+ break;
+ default: /* Unsupported */
+ printf("%s\n", _("CRITICAL - Unsupported SSL protocol version."));