aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-10-29 19:58:04 +0000
committerChris Rees <crees@FreeBSD.org>2011-10-29 19:58:04 +0000
commit5cd5a53a681c716b7c49c04393392995dfba2bf5 (patch)
treed3b7de0e7d165036c1854846621d9dd16f24fa64 /net-mgmt
parent5ed5cf59536a17aca6c0869829e7ac3a5a323b98 (diff)
downloadports-5cd5a53a681c716b7c49c04393392995dfba2bf5.tar.gz
ports-5cd5a53a681c716b7c49c04393392995dfba2bf5.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/zenpack-apachemonitor/Makefile22
-rw-r--r--net-mgmt/zenpack-apachemonitor/distinfo2
-rw-r--r--net-mgmt/zenpack-apachemonitor/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-apachemonitor/files/pkg-message.in5
-rw-r--r--net-mgmt/zenpack-apachemonitor/pkg-descr5
-rw-r--r--net-mgmt/zenpack-apachemonitor/pkg-plist2
7 files changed, 47 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 18f9a7677f4f..e3d1ba451e7a 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -297,6 +297,7 @@
SUBDIR += zabbix-proxy
SUBDIR += zabbix-server
SUBDIR += zenoss
+ SUBDIR += zenpack-apachemonitor
SUBDIR += zenpack-dellmon
SUBDIR += zenpack-deviceadvdetail
SUBDIR += zenpack-devicesearch
diff --git a/net-mgmt/zenpack-apachemonitor/Makefile b/net-mgmt/zenpack-apachemonitor/Makefile
new file mode 100644
index 000000000000..9b4d3a5858d6
--- /dev/null
+++ b/net-mgmt/zenpack-apachemonitor/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: ApacheMonitor
+# Date created: 12 May 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ApacheMonitor
+PORTVERSION= 2.1.2
+CATEGORIES= net-mgmt www
+MASTER_SITES= http://dev.zenoss.org/trac/changeset/26203/tags/zenoss-3.1.0/zenpacks/
+DISTFILES= ${ZPACKPREFIX}${PORTNAME}?old_path=%2F\&format=zip
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Provides performance monitoring of the Apache HTTP Server
+USE_ZIP= yes
+ZPACKGROUP= core
+WRKSRC= ${WRKDIR}/tags/zenoss-3.1.0/zenpacks/${ZPACKPREFIX}${PORTNAME}/
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-apachemonitor/distinfo b/net-mgmt/zenpack-apachemonitor/distinfo
new file mode 100644
index 000000000000..4bab287f3951
--- /dev/null
+++ b/net-mgmt/zenpack-apachemonitor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ZenPacks.zenoss.ApacheMonitor?old_path=%2F&format=zip) = 905b9baa0fbbaf1b6316338ed6bbd33c1d2c086f7b742b023a5c2517b3925d8a
+SIZE (ZenPacks.zenoss.ApacheMonitor?old_path=%2F&format=zip) = 17112
diff --git a/net-mgmt/zenpack-apachemonitor/files/pkg-deinstall.in b/net-mgmt/zenpack-apachemonitor/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-apachemonitor/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-apachemonitor/files/pkg-message.in b/net-mgmt/zenpack-apachemonitor/files/pkg-message.in
new file mode 100644
index 000000000000..869bea811264
--- /dev/null
+++ b/net-mgmt/zenpack-apachemonitor/files/pkg-message.in
@@ -0,0 +1,5 @@
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-apachemonitor/pkg-descr b/net-mgmt/zenpack-apachemonitor/pkg-descr
new file mode 100644
index 000000000000..1469201cafaa
--- /dev/null
+++ b/net-mgmt/zenpack-apachemonitor/pkg-descr
@@ -0,0 +1,5 @@
+This ZenPack provides performance monitoring of the Apache HTTP Server.
+
+This ZenPack is documented in the Zenoss Extended Monitoring Guide.
+
+WWW: http://community.zenoss.org/docs/DOC-3442
diff --git a/net-mgmt/zenpack-apachemonitor/pkg-plist b/net-mgmt/zenpack-apachemonitor/pkg-plist
new file mode 100644
index 000000000000..52307ea0055e
--- /dev/null
+++ b/net-mgmt/zenpack-apachemonitor/pkg-plist
@@ -0,0 +1,2 @@
+zenoss/ZenPack/%%ZPACK%%
+@dirrmtry zenoss/ZenPack