aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2015-02-20 14:52:01 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2015-02-20 14:52:01 +0000
commit6d443bd621def3eb046e8d8584dd65caedf4093c (patch)
treee9fcfb8ba647abc53e12450e848376e1beb158da /net-mgmt
parent842cc113e67e86a5f9a55fa253e0a948da7b87c8 (diff)
downloadports-6d443bd621def3eb046e8d8584dd65caedf4093c.tar.gz
ports-6d443bd621def3eb046e8d8584dd65caedf4093c.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent_mibgroup_hardware_memory_memory__freebsd.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 7c1f1e8043c1..e232e4208b05 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent_mibgroup_hardware_memory_memory__freebsd.c b/net-mgmt/net-snmp/files/patch-agent_mibgroup_hardware_memory_memory__freebsd.c
new file mode 100644
index 000000000000..e5204974a550
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent_mibgroup_hardware_memory_memory__freebsd.c
@@ -0,0 +1,11 @@
+--- agent/mibgroup/hardware/memory/memory_freebsd.c.orig 2015-02-20 14:44:47 UTC
++++ agent/mibgroup/hardware/memory/memory_freebsd.c
+@@ -163,7 +163,7 @@ int netsnmp_mem_arch_load( netsnmp_cache
+ if (!mem->descr)
+ mem->descr = strdup("Cached memory");
+ mem->units = pagesize;
+- mem->size = cache_count;
++ mem->size = cache_count + inact_count;
+ mem->free = 0;
+ }
+