aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-21 19:01:25 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-21 19:01:25 +0000
commit83cb048d24fa3308ec8dfdd1f98d9fdfb68c9fe6 (patch)
tree213af89ccf087d9a8e9f20cd2acbaff8c153866e /net-mgmt
parentaf0ecf95cb16a7d419e3b59e2f18530012645ce1 (diff)
downloadports-83cb048d24fa3308ec8dfdd1f98d9fdfb68c9fe6.tar.gz
ports-83cb048d24fa3308ec8dfdd1f98d9fdfb68c9fe6.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/nagios-radauth-plugin/Makefile29
-rw-r--r--net-mgmt/nagios-radauth-plugin/distinfo2
-rw-r--r--net-mgmt/nagios-radauth-plugin/files/patch-Makefile.in26
-rw-r--r--net-mgmt/nagios-radauth-plugin/pkg-descr8
5 files changed, 66 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 52e60d46fee0..11ce5e583199 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -79,6 +79,7 @@
SUBDIR += mrtg
SUBDIR += nagios
SUBDIR += nagios-plugins
+ SUBDIR += nagios-radauth-plugin
SUBDIR += nagios-silfreed-plugins
SUBDIR += nagios-snmp-plugins
SUBDIR += nagios-spamd-plugin
diff --git a/net-mgmt/nagios-radauth-plugin/Makefile b/net-mgmt/nagios-radauth-plugin/Makefile
new file mode 100644
index 000000000000..1bd10cbbee72
--- /dev/null
+++ b/net-mgmt/nagios-radauth-plugin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: nagios-spamd-plugin
+# Date created: 2006-01-18
+# Whom: Andrew Kilpatrick <tiger@whitetigersd.com>
+#
+# $FreeBSD$
+
+PORTNAME= nagios-radauth-plugin
+PORTVERSION= 1.00
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.hick.org/code/skape/radauth/
+DISTNAME= radauth-${PORTVERSION}
+
+MAINTAINER= tiger@whitetigersd.com
+COMMENT= Nagios plugin for checking radius server
+
+NAGIOS_PLUGIN_DIR?= libexec/nagios
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX} \
+ --bindir=${PREFIX}/${NAGIOS_PLUGIN_DIR}
+
+PLIST_FILES= "@exec ${MKDIR} ${NAGIOS_PLUGIN_DIR}" \
+ ${NAGIOS_PLUGIN_DIR}/check_radauth
+PLIST_DIRS= ${NAGIOS_PLUGIN_DIR}
+
+pre-install:
+ @${MKDIR} ${PREFIX}/${NAGIOS_PLUGIN_DIR}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-radauth-plugin/distinfo b/net-mgmt/nagios-radauth-plugin/distinfo
new file mode 100644
index 000000000000..5286d63f1a08
--- /dev/null
+++ b/net-mgmt/nagios-radauth-plugin/distinfo
@@ -0,0 +1,2 @@
+MD5 (radauth-1.00.tar.gz) = 6b07fe24f6473f23089eec5087339fad
+SIZE (radauth-1.00.tar.gz) = 43087
diff --git a/net-mgmt/nagios-radauth-plugin/files/patch-Makefile.in b/net-mgmt/nagios-radauth-plugin/files/patch-Makefile.in
new file mode 100644
index 000000000000..1d373f487c27
--- /dev/null
+++ b/net-mgmt/nagios-radauth-plugin/files/patch-Makefile.in
@@ -0,0 +1,26 @@
+--- Makefile.in.orig Sun Jan 14 08:33:28 2001
++++ Makefile.in Sat Jan 21 21:55:42 2006
+@@ -1,8 +1,8 @@
+-CC=@CC@
+-DEBUG=@DEBUG@
++CC?=@CC@
++DEBUG=
+ DEFINES=@DEFINES@
+-CFLAGS=-Wall ${DEFINES} ${DEBUG} -c
+-LFLAGS=-Wall ${DEFINES} ${DEBUG} -o
++CFLAGS+=-Wall ${DEFINES} ${DEBUG} -c
++LFLAGS+=-Wall ${DEFINES} ${DEBUG} -o
+ OBJS=radauth.o md5.o
+ BIN=radauth
+ LIBS=@LIBS@
+@@ -17,8 +17,8 @@
+ ${CC} ${CFLAGS} md5.c -o md5.o
+
+ install: ${OBJS}
+- cp radauth /usr/local/bin/radauth
+- chmod 755 /usr/local/bin/radauth
++ cp radauth @bindir@/check_radauth
++ chmod 555 @bindir@/check_radauth
+
+ distclean:
+ rm -f core ${BIN} *.o config.status config.cache Makefile config.log
diff --git a/net-mgmt/nagios-radauth-plugin/pkg-descr b/net-mgmt/nagios-radauth-plugin/pkg-descr
new file mode 100644
index 000000000000..672792e3b1b6
--- /dev/null
+++ b/net-mgmt/nagios-radauth-plugin/pkg-descr
@@ -0,0 +1,8 @@
+radauth was developed to allow for command line authentication
+against a radius server. This allows for more rapid
+testing/troubleshooting of radius authentication problems depending
+upon the method by which the person is authenticating (dial-up
+customers come to mind).
+
+Author: Matt Miller <mmiller@hick.org>
+WWW: http://freshmeat.net/projects/radauth/