aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2004-08-28 17:56:17 +0000
committerMichael Haro <mharo@FreeBSD.org>2004-08-28 17:56:17 +0000
commitb9786cccae1769eff4f4160c5574e9641ae6a1a4 (patch)
tree80df5c4128b1466b1d96ce368fddd28a234cb18c /net-mgmt
parent2927a6353ac33d7a9c8e9cffed3cb0b1fb56bfb0 (diff)
downloadports-b9786cccae1769eff4f4160c5574e9641ae6a1a4.tar.gz
ports-b9786cccae1769eff4f4160c5574e9641ae6a1a4.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nrpe2/Makefile30
-rw-r--r--net-mgmt/nrpe2/distinfo4
-rw-r--r--net-mgmt/nrpe2/pkg-descr5
-rw-r--r--net-mgmt/nrpe2/pkg-plist4
4 files changed, 27 insertions, 16 deletions
diff --git a/net-mgmt/nrpe2/Makefile b/net-mgmt/nrpe2/Makefile
index 8538df43176a..024ff08ba0f6 100644
--- a/net-mgmt/nrpe2/Makefile
+++ b/net-mgmt/nrpe2/Makefile
@@ -5,27 +5,33 @@
# $FreeBSD$
#
-PORTNAME= nrpe
-PORTVERSION= 1.9
-PORTREVISION= 0
-CATEGORIES= net-mgmt
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTNAME= nrpe2
+PORTVERSION= 2.0
+PORTREVISION= 0
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nagios
+DISTNAME= nrpe-${PORTVERSION}
-MAINTAINER= paul@nerdlabs.com
-COMMENT= Nagios Remote Plugin Executor
+MAINTAINER= paul@nerdlabs.com
+COMMENT= Nagios Remote Plugin Executor
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
GNU_CONFIGURE= yes
-USE_PERL5= yes
-CONFIGURE_ARGS= --libexecdir=${PREFIX}/libexec/nagios --sysconfdir=${PREFIX}/etc \
- --sbindir=${PREFIX}/sbin --bindir=${PREFIX}/sbin
+CONFIGURE_ARGS+= --libexecdir=${PREFIX}/libexec/nagios --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc
+
+.if defined(WITH_SSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --enable-ssl
+.else
+CONFIGURE_ARGS+= --disable-ssl
+.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/nrpe ${PREFIX}/sbin/nrpe
- ${INSTALL_PROGRAM} ${WRKSRC}/src/check_nrpe ${PREFIX}/libexec/nagios/check_nrpe
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/nrpe ${PREFIX}/sbin/nrpe2
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/check_nrpe ${PREFIX}/libexec/nagios/check_nrpe2
${INSTALL_DATA} ${WRKSRC}/nrpe.cfg ${PREFIX}/etc/nrpe.cfg-sample
${INSTALL_SCRIPT} ${WRKSRC}/init-script.freebsd ${PREFIX}/etc/rc.d/nrpe.sh
diff --git a/net-mgmt/nrpe2/distinfo b/net-mgmt/nrpe2/distinfo
index 277ee47ae30f..fc5659be43f1 100644
--- a/net-mgmt/nrpe2/distinfo
+++ b/net-mgmt/nrpe2/distinfo
@@ -1,2 +1,2 @@
-MD5 (nrpe-1.9.tar.gz) = b4a5e00963f1aaa754ae877b9f921565
-SIZE (nrpe-1.9.tar.gz) = 41513
+MD5 (nrpe-2.0.tar.gz) = 70ef9502a3b7e49fa520dbceabfa04d0
+SIZE (nrpe-2.0.tar.gz) = 52157
diff --git a/net-mgmt/nrpe2/pkg-descr b/net-mgmt/nrpe2/pkg-descr
index ad2d2a4cee3f..1d6937a92950 100644
--- a/net-mgmt/nrpe2/pkg-descr
+++ b/net-mgmt/nrpe2/pkg-descr
@@ -6,4 +6,9 @@ remote hosts. The check_nrpe plugin is called from Nagios and actually makes
the plugin requests to the remote host. Requires that nrpe be running on the
remote host (either as a standalone daemon or as a service under inetd).
+nrpe2 is incompatible with nrpe version 1, if you are running this version
+see net-mgmt/nrpe. Both ports can be installed in parallel but share the same
+configuration file by default. This is easily changed in the nrpe startup
+file.
+
WWW: http://www.nagios.org/
diff --git a/net-mgmt/nrpe2/pkg-plist b/net-mgmt/nrpe2/pkg-plist
index fb4d15e163fc..b62af3f4663f 100644
--- a/net-mgmt/nrpe2/pkg-plist
+++ b/net-mgmt/nrpe2/pkg-plist
@@ -1,4 +1,4 @@
-sbin/nrpe
+sbin/nrpe2
etc/nrpe.cfg-sample
etc/rc.d/nrpe.sh
-libexec/nagios/check_nrpe
+libexec/nagios/check_nrpe2