aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-25 21:01:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-25 21:01:57 +0000
commit05e759e9db8dddb18ea94856169ab4b683d1e002 (patch)
tree27080e900bc21919931ec82566cf9604841c0d09 /net-mgmt
parentd0a0b05788691f0282278b31dbe0ec7ca4481445 (diff)
downloadports-05e759e9db8dddb18ea94856169ab4b683d1e002.tar.gz
ports-05e759e9db8dddb18ea94856169ab4b683d1e002.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/yabm/Makefile33
-rw-r--r--net-mgmt/yabm/distinfo2
-rw-r--r--net-mgmt/yabm/files/pkg-message.in11
-rw-r--r--net-mgmt/yabm/pkg-descr12
-rw-r--r--net-mgmt/yabm/pkg-plist2
6 files changed, 61 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index f7d9ffea4498..f8fd4f1a7a3b 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -160,6 +160,7 @@
SUBDIR += trafd
SUBDIR += whatmask
SUBDIR += wide-dhcp
+ SUBDIR += yabm
SUBDIR += zabbix
.include <bsd.port.subdir.mk>
diff --git a/net-mgmt/yabm/Makefile b/net-mgmt/yabm/Makefile
new file mode 100644
index 000000000000..808af7f7309a
--- /dev/null
+++ b/net-mgmt/yabm/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: yabm
+# Date created: 15 January 2005
+# Whom: Fredrik Lindberg <fli@shapeshifter.se>
+#
+# $FreeBSD$
+#
+
+PORTNAME= yabm
+PORTVERSION= 0.2
+CATEGORIES= net-mgmt
+MASTER_SITES= http://shapeshifter.se/code/yabm/release/ \
+ http://www2.shapeshifter.se/yabm/release/
+
+MAINTAINER= fli@shapeshifter.se
+COMMENT= Yet Another Bandwidth Meter, somewhat resembles the Linux bwbar
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_RC_SUBR= yes
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-extract:
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${WRKSRC}/scripts/yabm.sh.sample > ${WRKSRC}/scripts/yabm.sh
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/yabm.sh ${PREFIX}/etc/rc.d/yabm.sh
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/yabm/distinfo b/net-mgmt/yabm/distinfo
new file mode 100644
index 000000000000..e5188016b89a
--- /dev/null
+++ b/net-mgmt/yabm/distinfo
@@ -0,0 +1,2 @@
+MD5 (yabm-0.2.tar.gz) = b453b8986e94fc1fff4d1d2af44022b6
+SIZE (yabm-0.2.tar.gz) = 13426
diff --git a/net-mgmt/yabm/files/pkg-message.in b/net-mgmt/yabm/files/pkg-message.in
new file mode 100644
index 000000000000..6f44b8b32458
--- /dev/null
+++ b/net-mgmt/yabm/files/pkg-message.in
@@ -0,0 +1,11 @@
+
+**********************************************************
+
+ A startup script has been copied to
+ %%PREFIX%%/etc/rc.d/yabm.sh, please add yabm_enable="YES"
+ in your /etc/rc.conf to run yabm at startup.
+ For further script configuration notes, please see the
+ online documentation or comments in yabm.sh.
+
+**********************************************************
+
diff --git a/net-mgmt/yabm/pkg-descr b/net-mgmt/yabm/pkg-descr
new file mode 100644
index 000000000000..df4dca8bbbb4
--- /dev/null
+++ b/net-mgmt/yabm/pkg-descr
@@ -0,0 +1,12 @@
+Yet Another Bandwidth Meter displays current bandwidth utilization using the
+PNG image format. It somewhat resembles the Linux bwbar (although there is no
+connection to it).
+
+Features include measurement both on interface and assigned IP-address basis,
+possible to run non-root and non-setuid, quite customizable (colours, geometry,
+device max speed, etc). It also includes text output to the image.
+
+WWW: http://shapeshifter.se/code/yabm/
+
+-- Fredrik Lindberg
+ fli@shapeshifter.se
diff --git a/net-mgmt/yabm/pkg-plist b/net-mgmt/yabm/pkg-plist
new file mode 100644
index 000000000000..462ac9df4d45
--- /dev/null
+++ b/net-mgmt/yabm/pkg-plist
@@ -0,0 +1,2 @@
+bin/yabm
+etc/rc.d/yabm.sh