aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-10-14 08:40:47 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-10-14 08:40:47 +0000
commit64bde32282f6b9a44c92811eed8839b6d8910b22 (patch)
treeddbf460b1fa2d9e0a75a609af2bf03522ed5fc11 /net-mgmt
parent114654b4d1bb9e498cf714974bb883679f2344f0 (diff)
downloadports-64bde32282f6b9a44c92811eed8839b6d8910b22.tar.gz
ports-64bde32282f6b9a44c92811eed8839b6d8910b22.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios-plugins/Makefile3
-rw-r--r--net-mgmt/nagios-plugins/distinfo6
-rw-r--r--net-mgmt/nagios-plugins/files/patch-configure.in56
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in6
-rw-r--r--net-mgmt/nagios-plugins/files/patch-plugins__check_radius.c66
5 files changed, 38 insertions, 99 deletions
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index 4be6e3ca375d..426865e9f1b7 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nagios-plugins
-PORTVERSION= 1.4.9
-PORTREVISION= 3
+PORTVERSION= 1.4.10
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
diff --git a/net-mgmt/nagios-plugins/distinfo b/net-mgmt/nagios-plugins/distinfo
index 3645a3dbdd10..61c1b7f6fb66 100644
--- a/net-mgmt/nagios-plugins/distinfo
+++ b/net-mgmt/nagios-plugins/distinfo
@@ -1,3 +1,3 @@
-MD5 (nagios-plugins-1.4.9.tar.gz) = 6e617e95cadeedd92870cdbd2f13726c
-SHA256 (nagios-plugins-1.4.9.tar.gz) = 93cf5dadfb092d7c4d600a713bbef75d37141edb4d18ac3bc3c0d1c09f4b7fe2
-SIZE (nagios-plugins-1.4.9.tar.gz) = 1370263
+MD5 (nagios-plugins-1.4.10.tar.gz) = c67841223864ae1626ab2adb2f0b4c9d
+SHA256 (nagios-plugins-1.4.10.tar.gz) = 193ef480cd2b98d63de9183a83e277d6ef3b55032f44bd76616ef5e7a3d4a76e
+SIZE (nagios-plugins-1.4.10.tar.gz) = 1693979
diff --git a/net-mgmt/nagios-plugins/files/patch-configure.in b/net-mgmt/nagios-plugins/files/patch-configure.in
index 0a41459d54b4..466f280375cd 100644
--- a/net-mgmt/nagios-plugins/files/patch-configure.in
+++ b/net-mgmt/nagios-plugins/files/patch-configure.in
@@ -1,5 +1,5 @@
---- configure.in.orig Wed Apr 11 21:38:05 2007
-+++ configure.in Sun May 27 12:27:04 2007
+--- configure.in.orig Sat Sep 29 10:14:36 2007
++++ configure.in Sun Oct 14 12:32:53 2007
@@ -12,8 +12,6 @@
RELEASE=1
AC_SUBST(RELEASE)
@@ -33,7 +33,7 @@
fi
AC_CHECK_LIB(pq,PQsetdbLogin,,,-lcrypt)
if test "$ac_cv_lib_pq_PQsetdbLogin" = "yes"; then
-@@ -207,30 +206,42 @@
+@@ -207,37 +206,42 @@
AC_MSG_WARN([Skipping PostgreSQL plugin (check_pgsql)])
AC_MSG_WARN([install lib crypt and PostgreSQL libs to compile this plugin (see REQUIREMENTS).])
fi
@@ -50,18 +50,24 @@
_SAVEDLIBS="$LIBS"
-AC_CHECK_LIB(radiusclient,rc_read_config)
-if test "$ac_cv_lib_radiusclient_rc_read_config" = "yes"; then
-+AC_CHECK_LIB(radiusclient-ng,rc_read_config,,,-L${LOCALBASE}/lib)
-+if test "$ac_cv_lib_radiusclient_ng_rc_read_config" = "yes"; then
- EXTRAS="$EXTRAS check_radius"
+- EXTRAS="$EXTRAS check_radius"
- RADIUSLIBS="-lradiusclient"
-+ RADIUSLIBS="-L${LOCALBASE}/lib -lradiusclient-ng"\
-+ RADIUSINCLUDE="-I${LOCALBASE}/include"
- AC_SUBST(RADIUSLIBS)
-+ AC_SUBST(RADIUSINCLUDE)
- else
- AC_MSG_WARN([Skipping radius plugin])
- AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).])
- fi
+- AC_SUBST(RADIUSLIBS)
+-else
+- AC_CHECK_LIB(radiusclient-ng,rc_read_config)
++ AC_CHECK_LIB(radiusclient-ng,rc_read_config,,,-L${LOCALBASE}/lib)
+ if test "$ac_cv_lib_radiusclient_ng_rc_read_config" = "yes"; then
+ EXTRAS="$EXTRAS check_radius"
+- RADIUSLIBS="-lradiusclient-ng"
++ RADIUSLIBS="-L${LOCALBASE}/lib -lradiusclient-ng"\
++ RADIUSINCLUDE="-I${LOCALBASE}/include"
+ AC_SUBST(RADIUSLIBS)
++ AC_SUBST(RADIUSINCLUDE)
+ else
+ AC_MSG_WARN([Skipping radius plugin])
+ AC_MSG_WARN([install radius libs to compile this plugin (see REQUIREMENTS).])
+ fi
+-fi
LIBS="$_SAVEDLIBS"
+fi
@@ -83,15 +89,15 @@
AC_CHECK_FUNCS(ldap_set_option)
EXTRAS="$EXTRAS check_ldap"
AC_CHECK_FUNCS(ldap_init ldap_set_option ldap_get_option ldap_start_tls_s)
-@@ -239,6 +250,7 @@
+@@ -246,6 +250,7 @@
AC_MSG_WARN([install LDAP libs to compile this plugin (see REQUIREMENTS).])
fi
LIBS="$_SAVEDLIBS"
+fi
- dnl Check for mysql libraries
- np_mysqlclient
-@@ -492,22 +504,10 @@
+ dnl Check for headers used by check_ide_smart
+ AC_CHECK_HEADER(linux/hdreg.h, FOUNDINCLUDE=yes, FOUNDINCLUDE=no)
+@@ -522,22 +527,10 @@
ac_cv_ps_cols=8
AC_MSG_RESULT([$ac_cv_ps_command])
@@ -117,7 +123,7 @@
then
ac_cv_ps_varlist="[procstat,&procuid,&procpid,&procppid,&procvsz,&procrss,&procpcpu,procprog,&pos]"
ac_cv_ps_command="$PATH_TO_PS -axwo 'stat uid pid ppid vsz rss pcpu comm args'"
-@@ -515,9 +515,8 @@
+@@ -545,9 +538,8 @@
ac_cv_ps_cols=9
AC_MSG_RESULT([$ac_cv_ps_command])
@@ -129,7 +135,7 @@
elif ps -axwo 'stat uid pid ppid vsz rss pcpu ucomm command' 2>/dev/null | \
egrep -i ["^ *STAT +UID +PID +PPID +VSZ +RSS +%CPU +UCOMM +COMMAND"] > /dev/null
then
-@@ -527,209 +526,6 @@
+@@ -557,209 +549,6 @@
ac_cv_ps_cols=9
AC_MSG_RESULT([$ac_cv_ps_command])
@@ -339,7 +345,7 @@
else
AC_MSG_WARN([unable to find usable ps syntax - check_procs and check_nagios will not be compiled])
fi
-@@ -1099,6 +895,8 @@
+@@ -1137,6 +926,8 @@
AC_DEFINE_UNQUOTED(WHO_COMMAND,"$ac_cv_path_to_who",
[path and arguments for invoking 'who'])
@@ -348,7 +354,7 @@
AC_PATH_PROG(PATH_TO_SNMPGET,snmpget)
AC_ARG_WITH(snmpget_command,
ACX_HELP_STRING([--with-snmpget-command=PATH],
-@@ -1129,7 +927,10 @@
+@@ -1167,7 +958,10 @@
else
AC_MSG_WARN([Tried $PERL - install Net::SNMP perl module if you want to use the perl snmp plugins])
fi
@@ -359,7 +365,7 @@
AC_PATH_PROG(PATH_TO_QUAKESTAT,quakestat)
AC_PATH_PROG(PATH_TO_QSTAT,qstat)
AC_ARG_WITH(qstat_command,
-@@ -1154,7 +955,10 @@
+@@ -1192,7 +986,10 @@
AC_DEFINE_UNQUOTED(PATH_TO_QSTAT,"$ac_cv_path_to_qstat",
[path to qstat/quakestat])
fi
@@ -370,7 +376,7 @@
AC_PATH_PROG(PATH_TO_FPING,fping)
AC_ARG_WITH(fping_command,
ACX_HELP_STRING([--with-fping-command=PATH],
-@@ -1166,6 +970,7 @@
+@@ -1204,6 +1001,7 @@
else
AC_MSG_WARN([Get fping from http://www.fping.com in order to make check_fping plugin])
fi
@@ -378,7 +384,7 @@
AC_PATH_PROG(PATH_TO_SSH,ssh)
AC_ARG_WITH(ssh_command,
-@@ -1233,32 +1038,12 @@
+@@ -1271,32 +1069,12 @@
dnl end if for PATH_TO_SWAP
fi
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in
index 940cf11e8a0d..5e1abd7acbb4 100644
--- a/net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in
+++ b/net-mgmt/nagios-plugins/files/patch-plugins-scripts__utils.sh.in
@@ -1,9 +1,9 @@
---- plugins-scripts/utils.sh.in.orig Wed Mar 22 23:29:36 2006
-+++ plugins-scripts/utils.sh.in Fri May 12 23:37:49 2006
+--- plugins-scripts/utils.sh.in.orig Sat Jul 7 21:10:29 2007
++++ plugins-scripts/utils.sh.in Sun Oct 14 12:33:54 2007
@@ -14,10 +14,10 @@
print_revision() {
- echo "$1 (@PACKAGE@ @VERSION@) $2"
+ echo "$1 v$2 (@PACKAGE@ @VERSION@)"
- $ECHO "@WARRANTY@" | sed -e 's/\n/ /g'
+ $ECHO "@WARRANTY@" | /usr/bin/sed -e 's/\n/ /g'
}
diff --git a/net-mgmt/nagios-plugins/files/patch-plugins__check_radius.c b/net-mgmt/nagios-plugins/files/patch-plugins__check_radius.c
deleted file mode 100644
index 9220d25fdb5f..000000000000
--- a/net-mgmt/nagios-plugins/files/patch-plugins__check_radius.c
+++ /dev/null
@@ -1,66 +0,0 @@
---- plugins/check_radius.c.orig Mon Jan 29 08:16:40 2007
-+++ plugins/check_radius.c Tue Feb 27 21:36:09 2007
-@@ -43,7 +43,7 @@
- #include "utils.h"
- #include "netutils.h"
-
--#include <radiusclient.h>
-+#include <radiusclient-ng.h>
-
- int process_arguments (int, char **);
- void print_help (void);
-@@ -124,6 +124,7 @@
- int result = STATE_UNKNOWN;
- UINT4 client_id;
- char *str;
-+ rc_handle *rh;
-
- setlocale (LC_ALL, "");
- bindtextdomain (PACKAGE, LOCALEDIR);
-@@ -133,33 +134,36 @@
- usage4 (_("Could not parse arguments"));
-
- str = strdup ("dictionary");
-- if ((config_file && rc_read_config (config_file)) ||
-- rc_read_dictionary (rc_conf_str (str)))
-+ if (config_file)
-+ rh = rc_read_config (config_file);
-+ else
-+ rh = NULL;
-+ if (!rh || rc_read_dictionary (rh, rc_conf_str (rh, str)))
- die (STATE_UNKNOWN, _("Config file error"));
-
- service = PW_AUTHENTICATE_ONLY;
-
- memset (&data, 0, sizeof(data));
-- if (!(rc_avpair_add (&data.send_pairs, PW_SERVICE_TYPE, &service, 0) &&
-- rc_avpair_add (&data.send_pairs, PW_USER_NAME, username, 0) &&
-- rc_avpair_add (&data.send_pairs, PW_USER_PASSWORD, password, 0) &&
-- (nasid==NULL || rc_avpair_add (&data.send_pairs, PW_NAS_IDENTIFIER, nasid, 0))))
-+ if (!(rc_avpair_add (rh, &data.send_pairs, PW_SERVICE_TYPE, &service, -1, 0) &&
-+ rc_avpair_add (rh, &data.send_pairs, PW_USER_NAME, username, -1, 0) &&
-+ rc_avpair_add (rh, &data.send_pairs, PW_USER_PASSWORD, password, -1, 0) &&
-+ (nasid==NULL || rc_avpair_add (rh, &data.send_pairs, PW_NAS_IDENTIFIER, nasid, -1, 0))))
- die (STATE_UNKNOWN, _("Out of Memory?"));
-
- /*
- * Fill in NAS-IP-Address
- */
-
-- if ((client_id = rc_own_ipaddress ()) == 0)
-+ if ((client_id = rc_own_ipaddress (rh)) == 0)
- return (ERROR_RC);
-
-- if (rc_avpair_add (&(data.send_pairs), PW_NAS_IP_ADDRESS, &client_id, 0) ==
-+ if (rc_avpair_add (rh, &(data.send_pairs), PW_NAS_IP_ADDRESS, &client_id, -1, 0) ==
- NULL) return (ERROR_RC);
-
-- rc_buildreq (&data, PW_ACCESS_REQUEST, server, port, (int)timeout_interval,
-+ rc_buildreq (rh, &data, PW_ACCESS_REQUEST, server, port, (int)timeout_interval,
- retries);
-
-- result = rc_send_server (&data, msg);
-+ result = rc_send_server (rh, &data, msg);
- rc_avpair_free (data.send_pairs);
- if (data.receive_pairs)
- rc_avpair_free (data.receive_pairs);