aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /net-mgmt
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ap-utils/Makefile6
-rw-r--r--net-mgmt/cacti-spine/Makefile4
-rw-r--r--net-mgmt/collectd/Makefile5
-rw-r--r--net-mgmt/collectd5/Makefile5
-rw-r--r--net-mgmt/disco/Makefile4
-rw-r--r--net-mgmt/etherape/Makefile4
-rw-r--r--net-mgmt/ettercap/Makefile3
-rw-r--r--net-mgmt/icinga/Makefile7
-rw-r--r--net-mgmt/kismet/Makefile1
-rw-r--r--net-mgmt/mbrowse/Makefile4
-rw-r--r--net-mgmt/nagios-devel/Makefile7
-rw-r--r--net-mgmt/nagios-plugins/Makefile8
-rw-r--r--net-mgmt/nagios-snmp-plugins/Makefile2
-rw-r--r--net-mgmt/nagios/Makefile5
-rw-r--r--net-mgmt/nagios2/Makefile7
-rw-r--r--net-mgmt/nbtscan/Makefile4
-rw-r--r--net-mgmt/nefu/Makefile4
-rw-r--r--net-mgmt/nettop/Makefile2
-rw-r--r--net-mgmt/packit/Makefile2
-rw-r--r--net-mgmt/pmacct/Makefile4
-rw-r--r--net-mgmt/py-yapsnmp/Makefile6
-rw-r--r--net-mgmt/satellite/Makefile20
-rw-r--r--net-mgmt/sblim-wbemcli/Makefile3
-rw-r--r--net-mgmt/sing/Makefile5
-rw-r--r--net-mgmt/snmp4nagios/Makefile6
-rw-r--r--net-mgmt/spectools/Makefile4
-rw-r--r--net-mgmt/zabbix-server/Makefile3
-rw-r--r--net-mgmt/zabbix2-server/Makefile3
28 files changed, 63 insertions, 75 deletions
diff --git a/net-mgmt/ap-utils/Makefile b/net-mgmt/ap-utils/Makefile
index bf7dc18c0d20..d3678f897e6d 100644
--- a/net-mgmt/ap-utils/Makefile
+++ b/net-mgmt/ap-utils/Makefile
@@ -17,9 +17,9 @@ COMMENT= A set of utilities to configure and monitor wireless access points
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_ICONV= yes
-CONFIGURE_ENV= LDFLAGS="-lintl -L${LOCALBASE}/lib" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -lintl -L${LOCALBASE}/lib
MAN8= ap-trapd.8 ap-mrtg.8 ap-config.8
.if !defined(WITHOUT_NLS)
diff --git a/net-mgmt/cacti-spine/Makefile b/net-mgmt/cacti-spine/Makefile
index 6585d11ade2c..0e7efe604ec1 100644
--- a/net-mgmt/cacti-spine/Makefile
+++ b/net-mgmt/cacti-spine/Makefile
@@ -24,8 +24,8 @@ LIB_DEPENDS= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
GNU_CONFIGURE= YES
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} --with-snmp=${LOCALBASE}
-CONFIGURE_ENV= LDFLAGS="`net-snmp-config --libs`" \
- CPPFLAGS="`net-snmp-config --cflags`"
+CPPFLAGS+= `net-snmp-config --cflags`
+LDFLAGS+= `net-snmp-config --libs`
USE_MYSQL= YES
USE_OPENSSL= YES
USE_AUTOTOOLS= libtool
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 0907e45da33c..62c7b5b2a72b 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -53,9 +53,8 @@ USE_LDCONFIG= yes
CONFLICTS= collectd-5.[0-9]*
-CPPFLAGS= -I${LOCALBASE}/include
-
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 0583772d4c8e..749a67e07353 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -54,9 +54,8 @@ USE_LDCONFIG= yes
CONFLICTS= collectd-4.[0-9]*
-CPPFLAGS= -I${LOCALBASE}/include
-
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/net-mgmt/disco/Makefile b/net-mgmt/disco/Makefile
index fa8285052f8c..c08d38eb3e33 100644
--- a/net-mgmt/disco/Makefile
+++ b/net-mgmt/disco/Makefile
@@ -15,8 +15,8 @@ MAINTAINER= jadawin@FreeBSD.org
COMMENT= IP discovery and fingerprinting utility
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/net-mgmt/etherape/Makefile b/net-mgmt/etherape/Makefile
index aa3cfc9d29be..0b314d3cfecd 100644
--- a/net-mgmt/etherape/Makefile
+++ b/net-mgmt/etherape/Makefile
@@ -18,8 +18,8 @@ USE_GNOME= libglade2 libgnomeui gnomehack gnomeprefix
USE_GMAKE= yes
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= etherape.1
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index 282470dba965..ffc8c26f7539 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -43,8 +43,7 @@ LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
CFLAGS+= ${PTHREAD_CFLAGS}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
- LIBS="${LDFLAGS}"
+CONFIGURE_ENV+= LIBS="${LDFLAGS}"
CONFIGURE_ARGS+= --enable-plugins
.if !defined(WITHOUT_GTK)
diff --git a/net-mgmt/icinga/Makefile b/net-mgmt/icinga/Makefile
index 2f8cada12fd4..b72dcc6791cd 100644
--- a/net-mgmt/icinga/Makefile
+++ b/net-mgmt/icinga/Makefile
@@ -43,7 +43,7 @@ ICINGACGIURL?= ${ICINGAHTMURL}/cgi-bin
.include <bsd.port.pre.mk>
-CPPFLAGS= -I${LOCALBASE}/include -fPIC
+CPPFLAGS+= -I${LOCALBASE}/include -fPIC
CFLAGS+= ${CPPFLAGS}
CONFIGURE_ARGS= --with-command-user=${ICINGAUSER} \
@@ -62,10 +62,7 @@ CONFIGURE_ARGS= --with-command-user=${ICINGAUSER} \
--with-checkresult-dir=${ICINGADIR}/checkresults \
--disable-statuswrl
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
PERL=${PERL}
MAKE_JOBS_UNSAFE= yes
diff --git a/net-mgmt/kismet/Makefile b/net-mgmt/kismet/Makefile
index 0de44995ef80..989474534af6 100644
--- a/net-mgmt/kismet/Makefile
+++ b/net-mgmt/kismet/Makefile
@@ -22,7 +22,6 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
MAN1= kismet.1 kismet_drone.1
MAN5= kismet.conf.5 kismet_drone.conf.5
diff --git a/net-mgmt/mbrowse/Makefile b/net-mgmt/mbrowse/Makefile
index 4d8f2bb18b61..673bc578d267 100644
--- a/net-mgmt/mbrowse/Makefile
+++ b/net-mgmt/mbrowse/Makefile
@@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/mbrowse
USE_GNOME= gtk20
CONFIGURE_ARGS= --with-snmp-prefix=${PREFIX} --with-snmp-type=net
-CONFIGURE_ENV= LDFLAGS="`net-snmp-config --libs`" \
- CPPFLAGS="`net-snmp-config --cflags`"
+CPPFLAGS+= `net-snmp-config --cflags`
+LDFLAGS+= `net-snmp-config --libs`
.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-devel/Makefile b/net-mgmt/nagios-devel/Makefile
index e6d7ec68409f..76aec908db60 100644
--- a/net-mgmt/nagios-devel/Makefile
+++ b/net-mgmt/nagios-devel/Makefile
@@ -50,7 +50,7 @@ NAGIOSCGIURL?= ${NAGIOSHTMURL}/cgi-bin
.include <bsd.port.pre.mk>
-CPPFLAGS= -I${LOCALBASE}/include -fPIC
+CPPFLAGS+= -I${LOCALBASE}/include -fPIC
CFLAGS+= ${CPPFLAGS}
CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
@@ -69,10 +69,7 @@ CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
--with-checkresult-dir=${NAGIOSDIR}/checkresults \
--disable-statuswrl
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
PERL=${PERL}
MAKE_JOBS_UNSAFE= yes
diff --git a/net-mgmt/nagios-plugins/Makefile b/net-mgmt/nagios-plugins/Makefile
index f477e7656689..3e61ea946827 100644
--- a/net-mgmt/nagios-plugins/Makefile
+++ b/net-mgmt/nagios-plugins/Makefile
@@ -56,10 +56,10 @@ CONFIGURE_ARGS= --with-nagios-user=${NAGIOSUSER} \
--localstatedir=${NAGIOSDIR} \
--prefix=${PREFIX}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
- PERL=${PERL}
+CONFIGURE_ENV= PERL=${PERL}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CFLAGS+= -I${LOCALBASE}/include
.if defined(WITH_QSTAT)
BUILD_DEPENDS+= qstat:${PORTSDIR}/games/qstat
diff --git a/net-mgmt/nagios-snmp-plugins/Makefile b/net-mgmt/nagios-snmp-plugins/Makefile
index 3bc7dae3d077..4710a292dbf5 100644
--- a/net-mgmt/nagios-snmp-plugins/Makefile
+++ b/net-mgmt/nagios-snmp-plugins/Makefile
@@ -33,7 +33,7 @@ CONFIGURE_ARGS= --sbindir=${PREFIX}/share/nagios/cgi-bin \
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
# Workaround configure.in lameness.
-CONFIGURE_ENV+= CPPFLAGS="`net-snmp-config --cflags`"
+CPPFLAGS+= `net-snmp-config --cflags`
.include <bsd.port.pre.mk>
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index cc6ca868a413..a942f361c9e1 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -48,7 +48,7 @@ GROUPS= ${NAGIOSGROUP}
.include <bsd.port.pre.mk>
-CPPFLAGS= -I${LOCALBASE}/include -fPIC
+CPPFLAGS+= -I${LOCALBASE}/include -fPIC
CFLAGS+= ${CPPFLAGS}
CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
@@ -67,8 +67,7 @@ CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
--with-checkresult-dir=${NAGIOSDIR}/checkresults \
--disable-statuswrl
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" \
- LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
PERL=${PERL}
MAKE_JOBS_UNSAFE= yes
diff --git a/net-mgmt/nagios2/Makefile b/net-mgmt/nagios2/Makefile
index 37fbcd010d00..9ebda1ab6431 100644
--- a/net-mgmt/nagios2/Makefile
+++ b/net-mgmt/nagios2/Makefile
@@ -51,7 +51,7 @@ NAGIOSHOMEURL?= main.html
.include <bsd.port.pre.mk>
-CPPFLAGS= -I${LOCALBASE}/include -fPIC
+CPPFLAGS+= -I${LOCALBASE}/include -fPIC
CFLAGS+= ${CPPFLAGS}
CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
@@ -67,10 +67,7 @@ CONFIGURE_ARGS= --with-command-user=${NAGIOSUSER} \
--localstatedir=${NAGIOSDIR} \
--prefix=${PREFIX}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
PERL=${PERL}
MAKE_JOBS_UNSAFE= yes
diff --git a/net-mgmt/nbtscan/Makefile b/net-mgmt/nbtscan/Makefile
index 53fae8c6d6f2..c157d4d3453b 100644
--- a/net-mgmt/nbtscan/Makefile
+++ b/net-mgmt/nbtscan/Makefile
@@ -19,8 +19,8 @@ COMMENT= NetBIOS name network scanner
MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}a
ALL_TARGET= nbtscan
diff --git a/net-mgmt/nefu/Makefile b/net-mgmt/nefu/Makefile
index fc40555f8e15..46a6d2c0efd4 100644
--- a/net-mgmt/nefu/Makefile
+++ b/net-mgmt/nefu/Makefile
@@ -18,11 +18,11 @@ COMMENT= A network monitoring daemon
USE_RC_SUBR= nefu
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
YACC=${YACC} \
OPENSSL_CFLAGS="-I${OPENSSLINC}" \
OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
+CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE} \
--without-sasl \
--without-zlib \
diff --git a/net-mgmt/nettop/Makefile b/net-mgmt/nettop/Makefile
index 15dbb7d91717..c83f53a8c81b 100644
--- a/net-mgmt/nettop/Makefile
+++ b/net-mgmt/nettop/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-slang-libraries=${LOCALBASE}/lib \
--with-slang-includes=${LOCALBASE}/include
-CONFIGURE_ENV= LDFLAGS="-lcurses"
+LDFLAGS+= -lcurses
PLIST_FILES= bin/nettop
PORTDOCS= README THANKS ChangeLog
diff --git a/net-mgmt/packit/Makefile b/net-mgmt/packit/Makefile
index 341a94477b2a..293d10c32e88 100644
--- a/net-mgmt/packit/Makefile
+++ b/net-mgmt/packit/Makefile
@@ -18,7 +18,7 @@ COMMENT= Network auditing tool
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"
+CPPFLAGS+= `${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`
MAN8= packit.8
PLIST_FILES= sbin/packit
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index 6d35a7af15d3..9ba425b6f56b 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -20,8 +20,8 @@ LICENSE= GPLv2
USE_RC_SUBR= pmacctd
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
-CPPFLAGS= "-I${LOCALBASE}/include"
-LDFLAGS= "-L${LOCALBASE}/lib"
+CPPFLAGS+= "-I${LOCALBASE}/include"
+LDFLAGS+= "-L${LOCALBASE}/lib"
OPTIONS= MYSQL "Enable MySQL support." Off \
PGSQL "Enable PostgreSQL support." Off \
diff --git a/net-mgmt/py-yapsnmp/Makefile b/net-mgmt/py-yapsnmp/Makefile
index 7891b95ffb51..f7e7beed6ac0 100644
--- a/net-mgmt/py-yapsnmp/Makefile
+++ b/net-mgmt/py-yapsnmp/Makefile
@@ -23,14 +23,14 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_PYTHON= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${PYTHON_INCLUDEDIR}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include -I${PYTHON_INCLUDEDIR}
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+=--enable-site-packages-prefix=${PREFIX}
.include <bsd.port.pre.mk>
.if (${OSVERSION} >= 800000) && (${ARCH} == "i386")
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -fstack-protector -I${LOCALBASE}/include"
+CPPFLAGS+= -fstack-protector -I${LOCALBASE}/include
.endif
post-patch:
diff --git a/net-mgmt/satellite/Makefile b/net-mgmt/satellite/Makefile
index ff3ef7b8034e..cb73874fae8a 100644
--- a/net-mgmt/satellite/Makefile
+++ b/net-mgmt/satellite/Makefile
@@ -5,24 +5,24 @@
# $FreeBSD$
#
-PORTNAME= satellite
-PORTVERSION= 1.0.2
+PORTNAME= satellite
+PORTVERSION= 1.0.2
PORTREVISION= 1
-CATEGORIES= net-mgmt
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= system/network
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR=system/network
MAINTAINER= ports@FreeBSD.org
COMMENT= A system for tracking machines with dynamic IP addresses
-LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm.4:${PORTSDIR}/databases/gdbm
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS='-I${LOCALBASE}/include' \
- LDFLAGS='-L${LOCALBASE}/lib'
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --localstatedir=/var/log
-MAN8= satcfg.8 satellite.8 satellited.8 satwatch.8
+MAN8= satcfg.8 satellite.8 satellited.8 satwatch.8
pre-install:
@${SH} pkg-install ${PKGNAME} PRE-INSTALL
diff --git a/net-mgmt/sblim-wbemcli/Makefile b/net-mgmt/sblim-wbemcli/Makefile
index 941ba5784bfa..88196a24300f 100644
--- a/net-mgmt/sblim-wbemcli/Makefile
+++ b/net-mgmt/sblim-wbemcli/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
USE_BZIP2= YES
GNU_CONFIGURE= YES
-CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib"
+CPPFLAGS+= -I${PREFIX}/include
+LDFLAGS+= -L${PREFIX}/lib
MAKE_ARGS= RM="${RM} -f"
MAN1= wbemcli.1
diff --git a/net-mgmt/sing/Makefile b/net-mgmt/sing/Makefile
index c4fcf58f8ebd..2c190dcb03f7 100644
--- a/net-mgmt/sing/Makefile
+++ b/net-mgmt/sing/Makefile
@@ -20,8 +20,9 @@ BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-libpcap-prefix=/usr
-CONFIGURE_ENV= CPPFLAGS="`${LIBNET_CONFIG} --defines` \
- `${LIBNET_CONFIG} --cflags`" LIBS="`${LIBNET_CONFIG} --libs`"
+CONFIGURE_ENV= LIBS="`${LIBNET_CONFIG} --libs`"
+CPPFLAGS+= `${LIBNET_CONFIG} --defines` \
+ `${LIBNET_CONFIG} --cflags`
MAN8= sing.8
PLIST_FILES= sbin/sing
diff --git a/net-mgmt/snmp4nagios/Makefile b/net-mgmt/snmp4nagios/Makefile
index f2abe0fd99c7..a4893f9bdd4b 100644
--- a/net-mgmt/snmp4nagios/Makefile
+++ b/net-mgmt/snmp4nagios/Makefile
@@ -33,10 +33,8 @@ CONFIGURE_ARGS= --sbindir=${PREFIX}/${NAGIOSWWWDIR}/cgi-bin \
--with-pngdir=${NAGIOSDIR}/snmp4nagios/png \
--prefix=${PREFIX}
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS}" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CFLAGS+= -I${LOCALBASE}/include
.include <bsd.port.pre.mk>
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 21be8570cfad..53737d08edc4 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -18,8 +18,8 @@ COMMENT= Tools for the Wi-Spy spectrum analyzers from MetaGeek LLC
LICENSE= GPLv2
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USE_GMAKE= yes
PORTDOCS= README
diff --git a/net-mgmt/zabbix-server/Makefile b/net-mgmt/zabbix-server/Makefile
index 54fd18d849e7..1cabcee84b7f 100644
--- a/net-mgmt/zabbix-server/Makefile
+++ b/net-mgmt/zabbix-server/Makefile
@@ -47,7 +47,8 @@ SUB_LIST= ZABBIX_BUILD=${ZABBIX_BUILD} ZABBIX_REQUIRE=${ZABBIX_REQUIRE}
MAKE_ARGS+= ARCH=freebsd
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD}
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if ${ZABBIX_BUILD} != "agent"
LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp \
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index 54fd18d849e7..1cabcee84b7f 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -47,7 +47,8 @@ SUB_LIST= ZABBIX_BUILD=${ZABBIX_BUILD} ZABBIX_REQUIRE=${ZABBIX_REQUIRE}
MAKE_ARGS+= ARCH=freebsd
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD}
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.if ${ZABBIX_BUILD} != "agent"
LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp \