aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorCraig Leres <leres@FreeBSD.org>2019-06-01 16:06:30 +0000
committerCraig Leres <leres@FreeBSD.org>2019-06-01 16:06:30 +0000
commit7456dd6cc088c08360e948b38be650f8ea93f0eb (patch)
tree054354500fef88a1ef33f155dac9ceffaceaee18 /net-mgmt
parent25147d341a4a9ac7985d1e25c379f92f614a0a5a (diff)
downloadports-7456dd6cc088c08360e948b38be650f8ea93f0eb.tar.gz
ports-7456dd6cc088c08360e948b38be650f8ea93f0eb.zip
This adds net-mgmt/check_nwc_health, a Nagios plugin that uses
SNMP to monitor network devices. Reviewed by: ler (mentor) Approved by: ler (mentor) Differential Revision: https://reviews.freebsd.org/D20489
Notes
Notes: svn path=/head/; revision=503244
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/check_nwc_health/Makefile33
-rw-r--r--net-mgmt/check_nwc_health/distinfo3
-rw-r--r--net-mgmt/check_nwc_health/pkg-descr7
4 files changed, 44 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index a7697a3dda92..73124b09c8f5 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -43,6 +43,7 @@
SUBDIR += check_mk_agent
SUBDIR += check_multi
SUBDIR += check_mysql_health
+ SUBDIR += check_nwc_health
SUBDIR += check_ssl_cert
SUBDIR += chillispot
SUBDIR += choparp
diff --git a/net-mgmt/check_nwc_health/Makefile b/net-mgmt/check_nwc_health/Makefile
new file mode 100644
index 000000000000..d8a13f232c9e
--- /dev/null
+++ b/net-mgmt/check_nwc_health/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= check_nwc_health
+PORTVERSION= 7.7
+CATEGORIES= net-mgmt
+MASTER_SITES= https://labs.consol.de/assets/downloads/nagios/
+
+MAINTAINER= leres@freebsd.org
+COMMENT= Nagios plugin to monitor network equipment via SNMP
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= perl5
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-nagios-user=${NAGIOSUSER} \
+ --with-nagios-group=${NAGIOSGROUP} \
+ --with-perl=${PERL5}
+
+NAGIOSUSER?= nagios
+NAGIOSGROUP?= nagios
+USERS= ${NAGIOSUSER}
+GROUPS= ${NAGIOSGROUP}
+
+PLIST_FILES= libexec/check_nwc_health
+
+post-patch:
+ ${REINPLACE_CMD} -e "s| /bin/sed| ${SED}|" -e "s| /bin/grep| ${GREP}|" \
+ ${WRKSRC}/plugins-scripts/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/check_nwc_health/distinfo b/net-mgmt/check_nwc_health/distinfo
new file mode 100644
index 000000000000..dbc936b637e5
--- /dev/null
+++ b/net-mgmt/check_nwc_health/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1559078058
+SHA256 (check_nwc_health-7.7.tar.gz) = dc188c47a8a016803f0eb75ff006ebce48de1cfdb14a881835340444ecebcf52
+SIZE (check_nwc_health-7.7.tar.gz) = 645837
diff --git a/net-mgmt/check_nwc_health/pkg-descr b/net-mgmt/check_nwc_health/pkg-descr
new file mode 100644
index 000000000000..ab356624dc1e
--- /dev/null
+++ b/net-mgmt/check_nwc_health/pkg-descr
@@ -0,0 +1,7 @@
+check_nwc_health is a plugin for Nagios, Shinken and Icinga, which
+is used to monitor network components. It is capable of interrogating
+interface statistics, hardware (CPU, memory, fans, power modules,
+etc.), firewall policies, HSRP, load balancer pools, processor and
+memory usage.
+
+WWW: https://labs.consol.de/nagios/check_nwc_health