aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-07 00:39:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-07 00:39:54 +0000
commit2137dac72556bf7a40bffde8ce7f7d798a7bf11e (patch)
treea29e61d63d6b7e88a0af0b788c6b080f729927c0 /net-mgmt
parentcd6a02cead3780f0e37985ba1852a52767fce0bf (diff)
downloadports-2137dac72556bf7a40bffde8ce7f7d798a7bf11e.tar.gz
ports-2137dac72556bf7a40bffde8ce7f7d798a7bf11e.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nagios/Makefile15
-rw-r--r--net-mgmt/nagios12/Makefile15
-rw-r--r--net-mgmt/nagios2/Makefile15
3 files changed, 45 insertions, 0 deletions
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index ff0dd52082e4..a22f55280c09 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -37,6 +37,21 @@ CONFIGURE_ARGS= --with-command-user=nagios \
--localstatedir=${PREFIX}/var/nagios \
--prefix=${PREFIX}
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-inc=${LOCALBASE}/include/mysql \
+ --with-mysql-xdata
+.endif
+
+.if defined(WITH_POSTGRES)
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
+ --with-pgsql-inc=${LOCALBASE}/pgsql \
+ --with-pgsql-xdata
+.endif
+
INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
pre-fetch:
diff --git a/net-mgmt/nagios12/Makefile b/net-mgmt/nagios12/Makefile
index ff0dd52082e4..a22f55280c09 100644
--- a/net-mgmt/nagios12/Makefile
+++ b/net-mgmt/nagios12/Makefile
@@ -37,6 +37,21 @@ CONFIGURE_ARGS= --with-command-user=nagios \
--localstatedir=${PREFIX}/var/nagios \
--prefix=${PREFIX}
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-inc=${LOCALBASE}/include/mysql \
+ --with-mysql-xdata
+.endif
+
+.if defined(WITH_POSTGRES)
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
+ --with-pgsql-inc=${LOCALBASE}/pgsql \
+ --with-pgsql-xdata
+.endif
+
INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
pre-fetch:
diff --git a/net-mgmt/nagios2/Makefile b/net-mgmt/nagios2/Makefile
index ff0dd52082e4..a22f55280c09 100644
--- a/net-mgmt/nagios2/Makefile
+++ b/net-mgmt/nagios2/Makefile
@@ -37,6 +37,21 @@ CONFIGURE_ARGS= --with-command-user=nagios \
--localstatedir=${PREFIX}/var/nagios \
--prefix=${PREFIX}
+.if defined(WITH_MYSQL)
+LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
+ --with-mysql-inc=${LOCALBASE}/include/mysql \
+ --with-mysql-xdata
+.endif
+
+.if defined(WITH_POSTGRES)
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
+ --with-pgsql-inc=${LOCALBASE}/pgsql \
+ --with-pgsql-xdata
+.endif
+
INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
pre-fetch: