aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-28 13:37:19 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-28 13:37:19 +0000
commit3c87974395c0f207b0768da251c721e0125b48b7 (patch)
treef2a3aca7c7ac739f28a5fcd34c40194fddef9370 /net-mgmt
parentf84edaa66fddec5d2265f2a1526d4a92dffee550 (diff)
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/routers2-extras/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/net-mgmt/routers2-extras/Makefile b/net-mgmt/routers2-extras/Makefile
index f09c7c1635c9..92acb00af65c 100644
--- a/net-mgmt/routers2-extras/Makefile
+++ b/net-mgmt/routers2-extras/Makefile
@@ -3,7 +3,7 @@
PORTNAME= routers2-extras
PORTVERSION= 2.19
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= http://www.steveshipway.org/software/rrd/ \
ftp://ftp.oav.oav.net/routers2/
@@ -17,15 +17,22 @@ RUN_DEPENDS= ${LOCALBASE}/www/routers2/routers2.cgi:${PORTSDIR}/net-mgmt/routers
WRKSRC= ${WRKDIR}/routers2-v${PORTVERSION}/extras
-USES= perl5
-NO_BUILD= YES
+USES= perl5 shebangfix
+SHEBANG_FILES= check_foundry check_vmware.pl \
+ checkagent gather.pl graphprune.pl \
+ mrtg-apache mrtg-nrpe.pl mrtg-pnsclient.pl \
+ mrtg-portsinuse.pl rrd-archive-clean.pl \
+ rrd-archive.pl rrdextend.pl \
+ winalert.pl
+NO_BUILD= yes
+NO_ARCH= yes
PORTDOCS= README *.txt
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
+ ${REINPLACE_CMD} -e '1s|#!perl|#!${perl_CMD}|' \
+ ${WRKSRC}/targetnames/targetnames.pl
${REINPLACE_CMD} -e 's|%%PERL%%|${PERL}|' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/buildwan.pl \
@@ -46,9 +53,9 @@ do-install:
${STAGEDIR}${PREFIX}/www/routers2/extras
cd ${WRKSRC}; ${INSTALL_DATA} mrtg-templates/* \
${STAGEDIR}${PREFIX}/www/routers2/extras/templates
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}; ${INSTALL_DATA} README *.txt ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>