aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-06-07 14:58:07 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2008-06-07 14:58:07 +0000
commitfb01654c94b331befe44b63d6e71cdafa3070809 (patch)
tree7074bc8b948a93f257de3298f4868da9fc438bc5 /net-mgmt
parentbd5626a621f87452c24107dc84fc0c04d4f2cd17 (diff)
downloadports-fb01654c94b331befe44b63d6e71cdafa3070809.tar.gz
ports-fb01654c94b331befe44b63d6e71cdafa3070809.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/ezradius/Makefile33
-rw-r--r--net-mgmt/ezradius/distinfo3
-rw-r--r--net-mgmt/ezradius/pkg-descr3
-rw-r--r--net-mgmt/ezradius/pkg-plist265
5 files changed, 305 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 2d2a3a7931db..d15a3e8b9800 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -59,6 +59,7 @@
SUBDIR += ehnt
SUBDIR += etherape
SUBDIR += ettercap
+ SUBDIR += ezradius
SUBDIR += fetchconfig
SUBDIR += flow-extract
SUBDIR += flow-tools
diff --git a/net-mgmt/ezradius/Makefile b/net-mgmt/ezradius/Makefile
new file mode 100644
index 000000000000..9fb6e9b062d5
--- /dev/null
+++ b/net-mgmt/ezradius/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: ezradius
+# Date created: 2008-05-29
+# Whom: Lucio Costa <lucio@zetasolucoes.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ezradius
+PORTVERSION= 0.2.1.2
+CATEGORIES= net-mgmt
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}stable${EXTRACT_SUFFIX}
+
+MAINTAINER= lucio@zetasolucoes.com.br
+COMMENT= EzRADIUS is FreeRADIUS and Chillispot web-based management software
+
+RUN_DEPENDS= radiusd:${PORTSDIR}/net/freeradius-mysql
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-intl
+NO_BUILD= yes
+USE_MYSQL= yes
+USE_PHP= mysql session xml
+WANT_PHP_WEB= yes
+
+do-install:
+ @${MKDIR} ${WWWDIR}
+ @cd ${WRKSRC} && \
+ ${FIND} . -type d -exec ${MKDIR} ${WWWDIR}/{} \; \
+ -exec ${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/{} \;
+ @cd ${WRKSRC} && \
+ ${FIND} . \! -type d -exec ${INSTALL_DATA} {} ${WWWDIR}/{} \; \
+ -exec ${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/{} \;
+.include <bsd.port.mk>
diff --git a/net-mgmt/ezradius/distinfo b/net-mgmt/ezradius/distinfo
new file mode 100644
index 000000000000..cac8cacdbcfa
--- /dev/null
+++ b/net-mgmt/ezradius/distinfo
@@ -0,0 +1,3 @@
+MD5 (ezradius-0.2.1.2stable.tar.gz) = 3c58173c42d1e09346dda9e0a7be101f
+SHA256 (ezradius-0.2.1.2stable.tar.gz) = b5bc3335f18187f369bcac6e18e14bc694157c85ee44bf766ab8b63aaa53658f
+SIZE (ezradius-0.2.1.2stable.tar.gz) = 1209984
diff --git a/net-mgmt/ezradius/pkg-descr b/net-mgmt/ezradius/pkg-descr
new file mode 100644
index 000000000000..9c2d168a9d45
--- /dev/null
+++ b/net-mgmt/ezradius/pkg-descr
@@ -0,0 +1,3 @@
+ezRADIUS is FreeRADIUS and Chillispot web-based management software package.
+
+WWW: http://ezradius.sourceforge.net/
diff --git a/net-mgmt/ezradius/pkg-plist b/net-mgmt/ezradius/pkg-plist
new file mode 100644
index 000000000000..45bbfcc9b468
--- /dev/null
+++ b/net-mgmt/ezradius/pkg-plist
@@ -0,0 +1,265 @@
+%%WWWDIR%%/resources/mysql-dump/radius.sql
+%%WWWDIR%%/resources/hotspotlogin-without-popup/Connections/conStatus.php
+%%WWWDIR%%/resources/hotspotlogin-without-popup/get-status.js
+%%WWWDIR%%/resources/hotspotlogin-without-popup/back-status.php
+%%WWWDIR%%/resources/hotspotlogin-without-popup/logo.png
+%%WWWDIR%%/resources/hotspotlogin-without-popup/psd1541.jpg
+%%WWWDIR%%/resources/hotspotlogin-without-popup/logo.jpg
+%%WWWDIR%%/resources/hotspotlogin-without-popup/index.php
+%%WWWDIR%%/resources/hotspotlogin-without-popup/error_handler.php
+%%WWWDIR%%/resources/hotspotlogin-without-popup/hotspotlogin.php
+%%WWWDIR%%/resources/hotspotlogin-without-popup/INSTALL.txt
+%%WWWDIR%%/resources/hotspotlogin-without-popup/front-status.php
+%%WWWDIR%%/resources/chillispot-example-config/chilli.conf
+%%WWWDIR%%/resources/freeradius-example-config/certs/demoCA/index.txt.old
+%%WWWDIR%%/resources/freeradius-example-config/certs/demoCA/cacert.pem
+%%WWWDIR%%/resources/freeradius-example-config/certs/demoCA/serial.old
+%%WWWDIR%%/resources/freeradius-example-config/certs/demoCA/index.txt
+%%WWWDIR%%/resources/freeradius-example-config/certs/demoCA/serial
+%%WWWDIR%%/resources/freeradius-example-config/certs/root.pem
+%%WWWDIR%%/resources/freeradius-example-config/certs/cert-srv.p12
+%%WWWDIR%%/resources/freeradius-example-config/certs/newcert.pem
+%%WWWDIR%%/resources/freeradius-example-config/certs/dh
+%%WWWDIR%%/resources/freeradius-example-config/certs/root.der
+%%WWWDIR%%/resources/freeradius-example-config/certs/root.p12
+%%WWWDIR%%/resources/freeradius-example-config/certs/cert-srv.pem
+%%WWWDIR%%/resources/freeradius-example-config/certs/random
+%%WWWDIR%%/resources/freeradius-example-config/certs/cert-srv.der
+%%WWWDIR%%/resources/freeradius-example-config/certs/cert-clt.p12
+%%WWWDIR%%/resources/freeradius-example-config/certs/newreq.pem
+%%WWWDIR%%/resources/freeradius-example-config/certs/cert-clt.der
+%%WWWDIR%%/resources/freeradius-example-config/certs/cert-clt.pem
+%%WWWDIR%%/resources/freeradius-example-config/certs/README
+%%WWWDIR%%/resources/freeradius-example-config/experimental.conf
+%%WWWDIR%%/resources/freeradius-example-config/dictionary.chillispot
+%%WWWDIR%%/resources/freeradius-example-config/sql.conf-original
+%%WWWDIR%%/resources/freeradius-example-config/dictionary.wispr
+%%WWWDIR%%/resources/freeradius-example-config/sqlippool.conf
+%%WWWDIR%%/resources/freeradius-example-config/clients.conf-original
+%%WWWDIR%%/resources/freeradius-example-config/naslist
+%%WWWDIR%%/resources/freeradius-example-config/proxy.conf
+%%WWWDIR%%/resources/freeradius-example-config/sql.conf
+%%WWWDIR%%/resources/freeradius-example-config/preproxy_users
+%%WWWDIR%%/resources/freeradius-example-config/hints
+%%WWWDIR%%/resources/freeradius-example-config/naspasswd
+%%WWWDIR%%/resources/freeradius-example-config/dictionary
+%%WWWDIR%%/resources/freeradius-example-config/acct_users
+%%WWWDIR%%/resources/freeradius-example-config/mssql.conf
+%%WWWDIR%%/resources/freeradius-example-config/ldap.attrmap
+%%WWWDIR%%/resources/freeradius-example-config/clients.conf
+%%WWWDIR%%/resources/freeradius-example-config/otppasswd.sample
+%%WWWDIR%%/resources/freeradius-example-config/oraclesql.conf
+%%WWWDIR%%/resources/freeradius-example-config/README.txt
+%%WWWDIR%%/resources/freeradius-example-config/attrs
+%%WWWDIR%%/resources/freeradius-example-config/users
+%%WWWDIR%%/resources/freeradius-example-config/realms
+%%WWWDIR%%/resources/freeradius-example-config/eap.conf
+%%WWWDIR%%/resources/freeradius-example-config/huntgroups
+%%WWWDIR%%/resources/freeradius-example-config/radiusd.conf
+%%WWWDIR%%/resources/freeradius-example-config/radiusd.conf.v114
+%%WWWDIR%%/resources/freeradius-example-config/sql.conf-asli
+%%WWWDIR%%/resources/freeradius-example-config/otp.conf
+%%WWWDIR%%/resources/freeradius-example-config/clients.conf-asli
+%%WWWDIR%%/resources/freeradius-example-config/clients
+%%WWWDIR%%/resources/freeradius-example-config/snmp.conf
+%%WWWDIR%%/resources/freeradius-example-config/postgresql.conf
+%%WWWDIR%%/resources/hotspotlogin-with-popup/Connections/conStatus.php
+%%WWWDIR%%/resources/hotspotlogin-with-popup/screenshot/loginfailed.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/screenshot/popuploginsuccess.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/screenshot/logout.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/screenshot/popuplogin.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/screenshot/popuplogout.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/screenshot/popupgood.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/screenshot/alreadyloggedin.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/get-status.js
+%%WWWDIR%%/resources/hotspotlogin-with-popup/back-status.php
+%%WWWDIR%%/resources/hotspotlogin-with-popup/logo.png
+%%WWWDIR%%/resources/hotspotlogin-with-popup/psd1541.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/logo.jpg
+%%WWWDIR%%/resources/hotspotlogin-with-popup/index.php
+%%WWWDIR%%/resources/hotspotlogin-with-popup/error_handler.php
+%%WWWDIR%%/resources/hotspotlogin-with-popup/hotspotlogin.php
+%%WWWDIR%%/resources/hotspotlogin-with-popup/INSTALL.txt
+%%WWWDIR%%/resources/hotspotlogin-with-popup/front-status.php
+%%WWWDIR%%/SpryAssets/_notes/dwsync.xml
+%%WWWDIR%%/SpryAssets/SpryValidationTextField.js
+%%WWWDIR%%/SpryAssets/SpryValidationSelect.js
+%%WWWDIR%%/SpryAssets/SpryMenuBarRightHover.gif
+%%WWWDIR%%/SpryAssets/SpryValidationSelect.css
+%%WWWDIR%%/SpryAssets/SpryMenuBarDownHover.gif
+%%WWWDIR%%/SpryAssets/SpryMenuBar.js
+%%WWWDIR%%/SpryAssets/SpryCollapsiblePanel.js
+%%WWWDIR%%/SpryAssets/SpryMenuBarHorizontal.css
+%%WWWDIR%%/SpryAssets/SpryMenuBarVertical.css
+%%WWWDIR%%/SpryAssets/SpryMenuBarDown.gif
+%%WWWDIR%%/SpryAssets/SpryValidationTextField.css
+%%WWWDIR%%/SpryAssets/SpryMenuBarRight.gif
+%%WWWDIR%%/SpryAssets/SpryCollapsiblePanel.css
+%%WWWDIR%%/images/_notes/dwsync.xml
+%%WWWDIR%%/images/close.png
+%%WWWDIR%%/images/next.png
+%%WWWDIR%%/images/animated_favicon1.gif
+%%WWWDIR%%/images/php-med-trans-light.gif
+%%WWWDIR%%/images/wilber-icon.png
+%%WWWDIR%%/images/undip_warna_transparent.png
+%%WWWDIR%%/images/tr_bck.gif
+%%WWWDIR%%/images/new_back.bmp
+%%WWWDIR%%/images/foot_bck.gif
+%%WWWDIR%%/images/openlogo-nd-50.png
+%%WWWDIR%%/images/th_bck.gif
+%%WWWDIR%%/images/prev.png
+%%WWWDIR%%/images/dreamweaver.jpeg
+%%WWWDIR%%/images/debian.png
+%%WWWDIR%%/images/feather.gif
+%%WWWDIR%%/images/last.png
+%%WWWDIR%%/images/ezradius2.png
+%%WWWDIR%%/images/powered-by-mysql-167x86.png
+%%WWWDIR%%/images/favicon.ico
+%%WWWDIR%%/images/project-support.jpg
+%%WWWDIR%%/images/cxlogo_linux.png
+%%WWWDIR%%/images/first.png
+%%WWWDIR%%/images/ffdb-logo.png
+%%WWWDIR%%/_mmServerScripts/_notes/dwsync.xml
+%%WWWDIR%%/_mmServerScripts/mysql.php
+%%WWWDIR%%/_mmServerScripts/MMHTTPDB.php
+%%WWWDIR%%/Templates/_notes/dwsync.xml
+%%WWWDIR%%/Templates/tmp1.dwt.php
+%%WWWDIR%%/Templates/table.css
+%%WWWDIR%%/Connections/_notes/dwsync.xml
+%%WWWDIR%%/Connections/database.ini
+%%WWWDIR%%/Connections/.htaccess
+%%WWWDIR%%/Connections/cnRadius.php
+%%WWWDIR%%/_notes/.mno
+%%WWWDIR%%/_notes/topusers.php.mno
+%%WWWDIR%%/_notes/acct-all.php.mno
+%%WWWDIR%%/_notes/edit-radreply.php.mno
+%%WWWDIR%%/_notes/add-newuser.php.mno
+%%WWWDIR%%/_notes/add-radcheck.php.mno
+%%WWWDIR%%/_notes/edit-nas.php.mno
+%%WWWDIR%%/_notes/edit-radgroupreply.php.mno
+%%WWWDIR%%/_notes/group-detail.php.mno
+%%WWWDIR%%/_notes/dwsync.xml
+%%WWWDIR%%/_notes/list-alluser.php.mno
+%%WWWDIR%%/_notes/add-radgroupreply.php.mno
+%%WWWDIR%%/_notes/edit-radcheck.php.mno
+%%WWWDIR%%/_notes/edit-user-to-group.php.mno
+%%WWWDIR%%/_notes/edit-user-password.php.mno
+%%WWWDIR%%/_notes/online-users.php.mno
+%%WWWDIR%%/_notes/add-radgroupcheck.php.mno
+%%WWWDIR%%/_notes/acct-username-result.php.mno
+%%WWWDIR%%/_notes/attach-user-to-group.php.mno
+%%WWWDIR%%/_notes/KT3SiteSettings.mno
+%%WWWDIR%%/_notes/user-detail.php.mno
+%%WWWDIR%%/_notes/edit-radgroupcheck.php.mno
+%%WWWDIR%%/_notes/list-user-to-group.php.mno
+%%WWWDIR%%/_notes/list-allnas.php.mno
+%%WWWDIR%%/_notes/list-allgroup.php.mno
+%%WWWDIR%%/_notes/add-radreply.php.mno
+%%WWWDIR%%/screenshot/user-accounting.jpg
+%%WWWDIR%%/screenshot/alluser.jpg
+%%WWWDIR%%/screenshot/add-new-user.jpg
+%%WWWDIR%%/screenshot/online-user.jpg
+%%WWWDIR%%/screenshot/user-detail.jpg
+%%WWWDIR%%/screenshot/config-editor.jpg
+%%WWWDIR%%/screenshot/dropdown-menu.jpg
+%%WWWDIR%%/screenshot/group-detail.jpg
+%%WWWDIR%%/library/_notes/dwsync.xml
+%%WWWDIR%%/library/libTestNDisconnect.php
+%%WWWDIR%%/config/.htaccess
+%%WWWDIR%%/config/config.ini
+%%WWWDIR%%/del-user.php
+%%WWWDIR%%/get-online.js
+%%WWWDIR%%/test-user-connectivity.php
+%%WWWDIR%%/online-users.php
+%%WWWDIR%%/edit-radcheck.php
+%%WWWDIR%%/edit-groupname.php
+%%WWWDIR%%/CHANGELOG.txt
+%%WWWDIR%%/add-radcheck.php
+%%WWWDIR%%/del-radcheck.php
+%%WWWDIR%%/del-radgroupreply.php
+%%WWWDIR%%/COPYING
+%%WWWDIR%%/del-radgroupcheck.php
+%%WWWDIR%%/edit-username-user.php
+%%WWWDIR%%/edit-radius-attribute.php
+%%WWWDIR%%/about.php
+%%WWWDIR%%/del-radreply.php
+%%WWWDIR%%/del-nas.php
+%%WWWDIR%%/add-radreply.php
+%%WWWDIR%%/add-newuser.php
+%%WWWDIR%%/init-attribute-table.php
+%%WWWDIR%%/static-available-authreply.php
+%%WWWDIR%%/back-online.php
+%%WWWDIR%%/topusers.php
+%%WWWDIR%%/del-all-useraccounting.php
+%%WWWDIR%%/acct-last-closed-conns.php
+%%WWWDIR%%/edit-user-to-group.php
+%%WWWDIR%%/static-operator.php
+%%WWWDIR%%/static-authreply.php
+%%WWWDIR%%/add-radius-attribute.php
+%%WWWDIR%%/edit-user-password.php
+%%WWWDIR%%/acct-username-result-all.php
+%%WWWDIR%%/list-user-to-group.php
+%%WWWDIR%%/static-authcheck.php
+%%WWWDIR%%/list-allgroup.php
+%%WWWDIR%%/acct-username-result.php
+%%WWWDIR%%/add-radgroupreply.php
+%%WWWDIR%%/del-group.php
+%%WWWDIR%%/add-newgroup.php
+%%WWWDIR%%/attach-user-to-group.php
+%%WWWDIR%%/config.php
+%%WWWDIR%%/attribute.met
+%%WWWDIR%%/acct-username-input-all.php
+%%WWWDIR%%/list-allnas.php
+%%WWWDIR%%/del-radius-attribute.php
+%%WWWDIR%%/ffdb.inc.php
+%%WWWDIR%%/user-detail.php
+%%WWWDIR%%/index.php
+%%WWWDIR%%/acct-all.php
+%%WWWDIR%%/error_handler.php
+%%WWWDIR%%/attribute.dat
+%%WWWDIR%%/firsttime.txt
+%%WWWDIR%%/edit-radgroupcheck.php
+%%WWWDIR%%/edit-radgroupreply.php
+%%WWWDIR%%/list-radius-attribute.php
+%%WWWDIR%%/edit-nas.php
+%%WWWDIR%%/disconnect-user.php
+%%WWWDIR%%/auth.php
+%%WWWDIR%%/group-detail.php
+%%WWWDIR%%/acct-date-result.php
+%%WWWDIR%%/static-available-authcheck.php
+%%WWWDIR%%/add-radgroupcheck.php
+%%WWWDIR%%/acct-date-input.php
+%%WWWDIR%%/del-single-accounting.php
+%%WWWDIR%%/INSTALL.txt
+%%WWWDIR%%/add-newnas.php
+%%WWWDIR%%/edit-radreply.php
+%%WWWDIR%%/list-alluser.php
+%%WWWDIR%%/acct-username-input.php
+%%WWWDIR%%/config-editor.php
+@dirrmtry %%WWWDIR%%/screenshot
+@dirrmtry %%WWWDIR%%/resources/mysql-dump
+@dirrmtry %%WWWDIR%%/resources/hotspotlogin-without-popup/Connections
+@dirrmtry %%WWWDIR%%/resources/hotspotlogin-without-popup
+@dirrmtry %%WWWDIR%%/resources/hotspotlogin-with-popup/screenshot
+@dirrmtry %%WWWDIR%%/resources/hotspotlogin-with-popup/Connections
+@dirrmtry %%WWWDIR%%/resources/hotspotlogin-with-popup
+@dirrmtry %%WWWDIR%%/resources/freeradius-example-config/certs/demoCA
+@dirrmtry %%WWWDIR%%/resources/freeradius-example-config/certs
+@dirrmtry %%WWWDIR%%/resources/freeradius-example-config
+@dirrmtry %%WWWDIR%%/resources/chillispot-example-config
+@dirrmtry %%WWWDIR%%/resources
+@dirrmtry %%WWWDIR%%/library/_notes
+@dirrmtry %%WWWDIR%%/library
+@dirrmtry %%WWWDIR%%/images/_notes
+@dirrmtry %%WWWDIR%%/images
+@dirrmtry %%WWWDIR%%/config
+@dirrmtry %%WWWDIR%%/_notes
+@dirrmtry %%WWWDIR%%/_mmServerScripts/_notes
+@dirrmtry %%WWWDIR%%/_mmServerScripts
+@dirrmtry %%WWWDIR%%/Templates/_notes
+@dirrmtry %%WWWDIR%%/Templates
+@dirrmtry %%WWWDIR%%/SpryAssets/_notes
+@dirrmtry %%WWWDIR%%/SpryAssets
+@dirrmtry %%WWWDIR%%/Connections/_notes
+@dirrmtry %%WWWDIR%%/Connections
+@dirrmtry %%WWWDIR%%