aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2017-03-13 18:25:44 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2017-03-13 18:25:44 +0000
commit04e39cfa0c6dce52ea330ae6dab4783288b9abdc (patch)
treebf45f0b4300d452e43b7fb56cf2a5c8d8c43c705 /net-mgmt
parent78458da1c7ef680aeae11d76ff4748ccce5ef90a (diff)
downloadports-04e39cfa0c6dce52ea330ae6dab4783288b9abdc.tar.gz
ports-04e39cfa0c6dce52ea330ae6dab4783288b9abdc.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/riemann/Makefile2
-rw-r--r--net-mgmt/riemann/files/riemann.in22
2 files changed, 14 insertions, 10 deletions
diff --git a/net-mgmt/riemann/Makefile b/net-mgmt/riemann/Makefile
index ee53702095f5..acc26ec3552f 100644
--- a/net-mgmt/riemann/Makefile
+++ b/net-mgmt/riemann/Makefile
@@ -3,6 +3,7 @@
PORTNAME= riemann
PORTVERSION= 0.2.12
+PORTREVISION= 1
CATEGORIES= net-mgmt java
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/${PORTVERSION}/
@@ -17,7 +18,6 @@ NO_ARCH= yes
USE_JAVA= yes
JAVA_VERSION= 1.7+
-SUB_FILES= ${PORTNAME}
SUB_LIST= JAVA_HOME=${JAVA_HOME} \
RIEMANN_USER=${RIEMANN_USER} \
RIEMANN_GROUP=${RIEMANN_GROUP} \
diff --git a/net-mgmt/riemann/files/riemann.in b/net-mgmt/riemann/files/riemann.in
index 73b53f07bc93..437c5d1f2203 100644
--- a/net-mgmt/riemann/files/riemann.in
+++ b/net-mgmt/riemann/files/riemann.in
@@ -12,14 +12,16 @@
# riemann_enable (bool): Set to NO by default.
# Set it to YES to enable riemann.
#
-# riemann_config (string): Optional full path for riemann config file
-# riemann_user (user): Set to riemann by default.
-# riemann_group (group): Set to riemann by default.
-# riemann_jarfile (string): Optional path to a custom jarfile.
-# riemann_java_home (args): Specify which JVM to use, if not default.
-# riemann_min_mem (num): Minumum JVM heap size, 256m by default.
-# riemann_max_mem (num): Maximum JVM heap size, 1g by default.
-# riemann_java_opts (args): Additional JVM properties or arguments.
+# riemann_config (string): Optional full path for riemann config file
+# riemann_user (user): Set to riemann by default.
+# riemann_group (group): Set to riemann by default.
+# riemann_jarfile (string): Optional path to a custom jarfile.
+# riemann_java_home (args): Specify which JVM to use, if not default.
+# riemann_java_classpath (args): Specify a custom Java ClassPath.
+# riemann_min_mem (num): Minumum JVM heap size, 256m by default.
+# riemann_max_mem (num): Maximum JVM heap size, 1g by default.
+# riemann_java_opts (args): Additional JVM properties or arguments.
+
. /etc/rc.subr
name="riemann"
@@ -35,7 +37,9 @@ load_rc_config $name
: ${riemann_java_home:="%%JAVA_HOME%%"}
: ${riemann_min_mem:="256m"}
: ${riemann_max_mem:="1g"}
+: ${riemann_java_classpath:=${riemann_jarfile}}
: ${riemann_java_opts:=" -server \
+ -cp ${riemann_java_classpath} \
-Dapp=${name} \
-Xms${riemann_min_mem} \
-Xmx${riemann_max_mem} \
@@ -59,7 +63,7 @@ command="/usr/sbin/daemon"
command_args="-f -t ${name} -c -r -P ${pidfile} \
${riemann_java_home}/bin/java \
${riemann_java_opts} \
- -jar ${riemann_jarfile} ${riemann_config}"
+ riemann.bin start ${riemann_config}"
required_files="${java_cmd} ${riemann_config}"
riemann_prestart()