aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2020-03-15 18:44:01 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2020-03-15 18:44:01 +0000
commit3a9096e598ae4d25a56859bdd19583fb754513c7 (patch)
treea8e02b3d41c3abb1f470958427a6a40553c0b4c6 /net-mgmt
parent9f2315a1067d30a02c1f63dd93dbf703765068ba (diff)
downloadports-3a9096e598ae4d25a56859bdd19583fb754513c7.tar.gz
ports-3a9096e598ae4d25a56859bdd19583fb754513c7.zip
Rename swatch to swatchdog, update to 3.2.4, unbreak build
Reported by: Andrea Venturoli <ml@netfence.it>
Notes
Notes: svn path=/head/; revision=528497
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/icinga2/files/icinga2.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/net-mgmt/icinga2/files/icinga2.in b/net-mgmt/icinga2/files/icinga2.in
index 492a1ee4b31a..ac1451daea81 100644
--- a/net-mgmt/icinga2/files/icinga2.in
+++ b/net-mgmt/icinga2/files/icinga2.in
@@ -84,6 +84,24 @@ reload_precmd() {
fi
}
+icinga2_checkfib () {
+ echo "Checkfib called"
+ exit 1
+ if command -v check_namevarlist > /dev/null 2>&1; then
+ check_namevarlist fib && return 0
+ fi
+
+ $SYSCTL net.fibs >/dev/null 2>&1 || return 0
+
+ icinga2_fib=${icinga2_fib:-"NONE"}
+ if [ "x$icinga2_fib" != "xNONE" ]
+ then
+ command="/usr/sbin/setfib -F ${icinga2_fib} ${command}"
+ else
+ return 0
+ fi
+}
+
start_precmd() {
# Create necessary directories / change ownership
# While this is also done through pkg-plist, /var might be on a ramdisk,