aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-20 15:49:29 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-20 15:49:29 +0000
commita2dda80ff1525817e208efb404c135659f68889c (patch)
tree0cff46a5be5c5cba3312f65de1d8fc3a693a542a /net-mgmt
parent86b70fb123f41534a1d77b4113d1789c53ea9901 (diff)
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/weathermap/Makefile27
-rw-r--r--net-mgmt/weathermap/pkg-plist3
2 files changed, 12 insertions, 18 deletions
diff --git a/net-mgmt/weathermap/Makefile b/net-mgmt/weathermap/Makefile
index dda04a4cfaae..7272fbd85b4d 100644
--- a/net-mgmt/weathermap/Makefile
+++ b/net-mgmt/weathermap/Makefile
@@ -3,19 +3,20 @@
PORTNAME= weathermap
PORTVERSION= 1.1.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-mgmt
MASTER_SITES= http://netmon.grnet.gr/weathermap/dist/
MAINTAINER= lippe@FreeBSD.org
COMMENT= This tool displays the utilization of the network links
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
RUN_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
mrtg:${PORTSDIR}/net-mgmt/mrtg
-USES= perl5
+USES= perl5 shebangfix
NO_BUILD= yes
+SHEBANG_FILES= weathermap
OPTIONS_DEFINE= WGET
WGET_DESC= WGET support
@@ -27,7 +28,6 @@ CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
SUB_FILES= pkg-message
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MWGET}
@@ -40,19 +40,14 @@ post-patch:
${WRKSRC}/weathermap
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/weathermap ${PREFIX}/bin
- @${MKDIR} ${EXAMPLESDIR}
- @${MKDIR} ${PREFIX}/etc/weathermap
- @${INSTALL_DATA} ${WRKSRC}/example/* ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/example/weathermap.conf ${PREFIX}/etc/weathermap/weathermap.sample.conf
- @[ -f ${PREFIX}/etc/weathermap/weathermap.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/example/weathermap.conf ${PREFIX}/etc/weathermap/weathermap.conf
+ @${INSTALL_SCRIPT} ${WRKSRC}/weathermap ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/example/* ${STAGEDIR}${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/example/weathermap.conf ${STAGEDIR}${ETCDIR}/weathermap.conf.sample
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.post.mk>
diff --git a/net-mgmt/weathermap/pkg-plist b/net-mgmt/weathermap/pkg-plist
index e6d6fab3bd54..306504b816a9 100644
--- a/net-mgmt/weathermap/pkg-plist
+++ b/net-mgmt/weathermap/pkg-plist
@@ -5,7 +5,6 @@ bin/weathermap
%%EXAMPLESDIR%%/overlib_mini.js
%%EXAMPLESDIR%%/weathermap-background.png
%%EXAMPLESDIR%%/weathermap-overlib.html
-@unexec if cmp -s %%PREFIX%%/etc/weathermap/weathermap.conf %%PREFIX%%/etc/weathermap/weathermap.sample.conf; then rm %%PREFIX%%/etc/weathermap/weathermap.conf; fi
-etc/weathermap/weathermap.sample.conf
+@sample etc/weathermap/weathermap.conf.sample
@dirrmtry etc/weathermap
@dirrm %%EXAMPLESDIR%%