aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2018-03-09 17:55:55 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2018-03-09 17:55:55 +0000
commit0111f86b3d62b423cf69808d0d9ba63a29a9ed09 (patch)
treed8d76a9c74ae2bab6be7d17ae254b9287f6173f0 /net-mgmt
parentf7ce434da99592853c293d57f2c621e2f5637c67 (diff)
downloadports-0111f86b3d62b423cf69808d0d9ba63a29a9ed09.tar.gz
ports-0111f86b3d62b423cf69808d0d9ba63a29a9ed09.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/blackbox_exporter/Makefile10
-rw-r--r--net-mgmt/blackbox_exporter/distinfo6
-rw-r--r--net-mgmt/blackbox_exporter/files/blackbox_exporter.in29
-rw-r--r--net-mgmt/blackbox_exporter/files/pkg-message.in15
4 files changed, 42 insertions, 18 deletions
diff --git a/net-mgmt/blackbox_exporter/Makefile b/net-mgmt/blackbox_exporter/Makefile
index 366a8a0b2ef1..f93dd32b0275 100644
--- a/net-mgmt/blackbox_exporter/Makefile
+++ b/net-mgmt/blackbox_exporter/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= blackbox_exporter
-PORTVERSION= 0.11.0
-PORTREVISION= 1
+PORTVERSION= 0.12.0
DISTVERSIONPREFIX=v
CATEGORIES= net-mgmt
@@ -15,8 +14,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go
USE_GITHUB= yes
-
GH_ACCOUNT= prometheus
+USE_RC_SUBR= blackbox_exporter
+SUB_FILES= pkg-message
+SUB_LIST= GH_TAGNAME=${GH_TAGNAME}
+
+USERS= prometheus
+GROUPS= prometheus
GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}
diff --git a/net-mgmt/blackbox_exporter/distinfo b/net-mgmt/blackbox_exporter/distinfo
index 12c9dce9a830..517a64c52376 100644
--- a/net-mgmt/blackbox_exporter/distinfo
+++ b/net-mgmt/blackbox_exporter/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1512052617
-SHA256 (prometheus-blackbox_exporter-v0.11.0_GH0.tar.gz) = 6ba223b7254fd261e19b9cf96c760505a53b977a6328d5479e6744734e28deb6
-SIZE (prometheus-blackbox_exporter-v0.11.0_GH0.tar.gz) = 2143849
+TIMESTAMP = 1520362217
+SHA256 (prometheus-blackbox_exporter-v0.12.0_GH0.tar.gz) = 8d5c2236b555af0c1ef00e6973f1aac76a38bbb5220aa6a39c1837a9b29e2a50
+SIZE (prometheus-blackbox_exporter-v0.12.0_GH0.tar.gz) = 2202465
diff --git a/net-mgmt/blackbox_exporter/files/blackbox_exporter.in b/net-mgmt/blackbox_exporter/files/blackbox_exporter.in
index c6a49462fe9a..6399317bbe25 100644
--- a/net-mgmt/blackbox_exporter/files/blackbox_exporter.in
+++ b/net-mgmt/blackbox_exporter/files/blackbox_exporter.in
@@ -1,5 +1,7 @@
#!/bin/sh
+# $FreeBSD$
+#
# PROVIDE: blackbox_exporter
# REQUIRE: LOGIN
# KEYWORD: shutdown
@@ -10,13 +12,13 @@
# blackbox_exporter_enable (bool): Set to NO by default.
# Set it to YES to enable blackbox_exporter.
# blackbox_exporter_user (string): Set user that blackbox_exporter will run under
-# Default is "nobody".
+# Default is "prometheus".
# blackbox_exporter_group (string): Set group that blackbox_exporter will run under
-# Default is "nobody".
+# Default is "prometheus".
# blackbox_exporter_args (string): Set extra arguments to pass to blackbox_exporter
# Default is "".
# blackbox_exporter_listen_address (string):Set ip:port that blackbox_exporter will listen on
-# Default is ":9115".
+# Default is "localhost:9115".
# blackbox_exporter_config (string): Set configuration file of blackbox_exporter
# Default is "%%PREFIX%%/etc/blackbox_exporter.yml".
# blackbox_exporter_log_file (string): Set log file of blackbox_exporter
@@ -25,20 +27,20 @@
. /etc/rc.subr
name=blackbox_exporter
+desc="Blackbox exporter for use with Prometheus"
rcvar=blackbox_exporter_enable
load_rc_config $name
-: ${blackbox_exporter_enable:="NO"}
-: ${blackbox_exporter_user:="nobody"}
-: ${blackbox_exporter_group:="nobody"}
-: ${blackbox_exporter_args:=""}
-: ${blackbox_exporter_listen_address:=":9115"}
-: ${blackbox_exporter_config:="%%PREFIX%%/etc/blackbox_exporter.yml"}
-: ${blackbox_exporter_log_file:="/var/log/blackbox_exporter.log"}
+: ${blackbox_exporter_enable:=NO}
+: ${blackbox_exporter_user:=prometheus}
+: ${blackbox_exporter_group:=prometheus}
+: ${blackbox_exporter_listen_address=localhost:9115}
+: ${blackbox_exporter_config="%%PREFIX%%/etc/blackbox_exporter.yml"}
+: ${blackbox_exporter_log_file=/var/log/blackbox_exporter.log}
pidfile=/var/run/blackbox_exporter.pid
-command="/usr/sbin/daemon"
+command=/usr/sbin/daemon
procname="%%PREFIX%%/bin/blackbox_exporter"
command_args="-p ${pidfile} /usr/bin/env ${procname} \
--web.listen-address=${blackbox_exporter_listen_address} \
@@ -54,6 +56,8 @@ blackbox_exporter_startprecmd()
-o ${blackbox_exporter_user} \
-g ${blackbox_exporter_group} \
/dev/null ${pidfile};
+ else
+ chown ${blackbox_exporter_user}:${blackbox_exporter_group} ${pidfile};
fi
if [ ! -e ${blackbox_exporter_log_file} ]; then
install \
@@ -61,8 +65,9 @@ blackbox_exporter_startprecmd()
-g ${blackbox_exporter_group} \
-m 640 \
/dev/null ${blackbox_exporter_log_file};
+ else
+ chown ${blackbox_exporter_user}:${blackbox_exporter_group} ${blackbox_exporter_log_file};
fi
}
-load_rc_config $name
run_rc_command "$1"
diff --git a/net-mgmt/blackbox_exporter/files/pkg-message.in b/net-mgmt/blackbox_exporter/files/pkg-message.in
new file mode 100644
index 000000000000..ab6733827c6c
--- /dev/null
+++ b/net-mgmt/blackbox_exporter/files/pkg-message.in
@@ -0,0 +1,15 @@
+To start blackbox_exporter, create a configuration file at
+%%PREFIX%%/etc/blackbox_exporter.yml and run
+"sysrc blackbox_exporter_enable=yes".
+
+For details about the configuration file format, visit
+https://github.com/prometheus/blackbox_exporter/blob/%%GH_TAGNAME%%/CONFIGURATION.md
+
+Since blackbox_exporter allows setting arbitrary probe
+targets via HTTP parameters, it is set to listen on localhost
+only by default. To change the listen address, set the
+blackbox_exporter_listen_address rcvar.
+
+To use the 'ping' module, blackbox_exporter needs to run with
+root privileges. To run blackbox_exporter with root privileges,
+run "sysrc blackbox_exporter_user=root".