aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-27 11:38:47 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-27 11:38:47 +0000
commit7c9ecf4e7acc7345331d98b87c3b0ec39733dc9d (patch)
tree65ce3435fd007bc1f0539c07d2ec3ff241b4f87d /net-mgmt
parent4082ca1e8a97c50c1680b4a072af2dc025b55fd4 (diff)
downloadports-7c9ecf4e7acc7345331d98b87c3b0ec39733dc9d.tar.gz
ports-7c9ecf4e7acc7345331d98b87c3b0ec39733dc9d.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/sdig/Makefile12
-rw-r--r--net-mgmt/sdig/distinfo4
-rw-r--r--net-mgmt/sdig/files/patch-Makefile.in37
-rw-r--r--net-mgmt/sdig/files/patch-sdig.c42
-rw-r--r--net-mgmt/sdig/pkg-descr12
5 files changed, 13 insertions, 94 deletions
diff --git a/net-mgmt/sdig/Makefile b/net-mgmt/sdig/Makefile
index 6791546cdfdd..b41946ec848a 100644
--- a/net-mgmt/sdig/Makefile
+++ b/net-mgmt/sdig/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= sdig
-PORTVERSION= 0.40
-PORTREVISION= 1
+PORTVERSION= 0.42
CATEGORIES= net-mgmt
-MASTER_SITES= http://www.exploits.org/sdig/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= rjackson@cserv62.csub.edu
-COMMENT= Find which switch/router port a given host is on
+MAINTAINER= raj@cserv62.csub.edu
+COMMENT= Translate IP/DNS/WINS/MAC address into port description
LIB_DEPENDS= netsnmp.6:${PORTSDIR}/net-mgmt/net-snmp
@@ -21,6 +21,6 @@ GNU_CONFIGURE= yes
MAN5= sdig.conf.5
MAN8= sdig.8
-PLIST_FILES= bin/sdig etc/sdig.conf-sample
+PLIST_FILES= bin/sdig etc/sdig.conf-sample etc/mactable-sample
.include <bsd.port.mk>
diff --git a/net-mgmt/sdig/distinfo b/net-mgmt/sdig/distinfo
index 41c949d4db14..1429fad62780 100644
--- a/net-mgmt/sdig/distinfo
+++ b/net-mgmt/sdig/distinfo
@@ -1,2 +1,2 @@
-MD5 (sdig-0.40.tar.gz) = 60132d49076f0e51d7cccc99cb72b7f4
-SIZE (sdig-0.40.tar.gz) = 72623
+MD5 (sdig-0.42.tar.gz) = e3a718b4eabaefd6bf9dbe9fe76fd0a8
+SIZE (sdig-0.42.tar.gz) = 111033
diff --git a/net-mgmt/sdig/files/patch-Makefile.in b/net-mgmt/sdig/files/patch-Makefile.in
deleted file mode 100644
index c00f77ae3fed..000000000000
--- a/net-mgmt/sdig/files/patch-Makefile.in
+++ /dev/null
@@ -1,37 +0,0 @@
---- Makefile.in.orig Fri Apr 4 08:35:54 2003
-+++ Makefile.in Thu Mar 25 13:36:34 2004
-@@ -9,8 +9,8 @@
- MANDIR = $(DESTDIR)@mandir@
-
- # other definitions
--CC = @CC@
--CFLAGS = -Iinclude -O2 -Wall # -g -static
-+CC ?= @CC@
-+CFLAGS += -Iinclude -I/usr/local/include
-
- INSTALLCMD = @INSTALL@
- INSTALLMODE_BIN = 0755
-@@ -32,6 +32,9 @@
- $(CC) $(CFLAGS) -o sdig sdig.o common.o snmpget.o \
- $(NETSNMP_LIBS)
-
-+snmpget.o: snmpget.c
-+ $(CC) $(CFLAGS) -c snmpget.c
-+
- clean:
- rm -f $(PROGS) *.o
-
-@@ -49,12 +52,7 @@
-
- install-conf:
- ./install-sh -d $(CONFDIR)
-- @if ( test -f $(CONFDIR)/sdig.conf ) \
-- then \
-- echo Not replacing existing file: $(CONFDIR)/sdig.conf; \
-- else \
-- $(INSTALLCMD) -m $(INSTALLMODE_CONF) sdig.conf $(CONFDIR); \
-- fi
-+ $(INSTALLCMD) -m $(INSTALLMODE_CONF) sdig.conf $(CONFDIR)/sdig.conf-sample
-
- install-man:
- ./install-sh -d $(MANDIR)/man5
diff --git a/net-mgmt/sdig/files/patch-sdig.c b/net-mgmt/sdig/files/patch-sdig.c
deleted file mode 100644
index 3559519dd440..000000000000
--- a/net-mgmt/sdig/files/patch-sdig.c
+++ /dev/null
@@ -1,42 +0,0 @@
---- sdig.c.orig Mon Mar 24 13:08:00 2003
-+++ sdig.c Wed May 19 13:17:43 2004
-@@ -426,7 +426,7 @@
-
- static void do_ifdescr(stype *sw, long port)
- {
-- char query[256], *ifdescr;
-+ char query[256], *ifdescr, *ifname;
- long ifnum;
-
- /* first get the switch's ifnum for the port */
-@@ -437,13 +437,28 @@
- if (ifnum == -1)
- return;
-
-- snprintf(query, sizeof(query), "interfaces.ifTable.ifEntry.ifDescr.%ld",
-+ snprintf(query, sizeof(query), "IF-MIB::ifName.%ld",
-+ ifnum);
-+
-+ ifname = snmpget_str(sw->ip, sw->pw, query);
-+
-+ if (!ifname) {
-+ snprintf(query, sizeof(query), "IF-MIB::ifAlias.%ld", ifnum);
-+ snmpget_str(sw->ip, sw->pw, query);
-+ }
-+
-+ snprintf(query, sizeof(query), "IF-MIB::ifDescr.%ld",
- ifnum);
-
- ifdescr = snmpget_str(sw->ip, sw->pw, query);
-
-+ if (ifname) {
-+ printf(" (%s)", ifname);
-+ free(ifname);
-+ }
-+
- if (ifdescr) {
-- printf(" (%s)", ifdescr);
-+ printf(" [%s]", ifdescr);
- free(ifdescr);
- }
- }
diff --git a/net-mgmt/sdig/pkg-descr b/net-mgmt/sdig/pkg-descr
index 2c0c9f9948da..808893005253 100644
--- a/net-mgmt/sdig/pkg-descr
+++ b/net-mgmt/sdig/pkg-descr
@@ -1,10 +1,8 @@
-This program is designed to track down computers to the finest level of
-information available at the moment. Sometimes this can mean an exact
-description of a port in a building anywhere in an enterprise. Other
-times this may just be a vague notion of a faraway network. The results
-are only as good as the data you feed to it.
-
-WWW: http://www.exploits.org/sdig
+Given SNMP-capable routers and switches, sdig can
+turn an IP address, DNS/WINS host name or a MAC
+address into a port description. Sdig will run on
+most any platform that net-snmp supports. It
+currently compiles on FreeBSD and Linux.
- Russell A. Jackson
rjackson@cserv62.csub.edu