aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-09 15:24:38 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-09 15:24:38 +0000
commitb8c51e91739cb74756810339db7beef80b96ed0c (patch)
tree2dea59ad52c76996da69930c9ae49a362a9fe0cb /net-mgmt
parentc8edc8a565b254caa963007932e922fd92f2ee36 (diff)
downloadports-b8c51e91739cb74756810339db7beef80b96ed0c.tar.gz
ports-b8c51e91739cb74756810339db7beef80b96ed0c.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ettercap/Makefile100
-rw-r--r--net-mgmt/ettercap/files/patch-configure (renamed from net-mgmt/ettercap/files/patch-ab)0
2 files changed, 37 insertions, 63 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index f277691755a9..054bf340a8fa 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -5,50 +5,37 @@
# $FreeBSD$
#
-PORTNAME= ettercap
-PORTVERSION= 0.7.3
-PORTREVISION= 0
+PORTNAME= ettercap
+PORTVERSION= 0.7.3
DISTVERSIONPREFIX= NG-
-PORTEPOCH= 1
-CATEGORIES= net-mgmt security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
- ${MASTER_SITE_PACKETSTORM:S:%SUBDIR%:sniffers/ettercap:}
+PORTREVISION= 0
+PORTEPOCH= 1
+CATEGORIES= net-mgmt security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
+ ${MASTER_SITE_PACKETSTORM:S:%SUBDIR%:sniffers/ettercap:}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= marcus@corp.grupos.com.br
COMMENT= A network sniffer/interceptor/injector/logger for switched LANs
BUILD_DEPENDS= ${LOCALBASE}/include/libnet/libnet-types.h:${PORTSDIR}/net/libnet-devel
-.if !defined(WITHOUT_PCRE)
-LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
-.endif
+OPTIONS= GTK "Build with GTK2+ GUI" on \
+ ICONV "Build with support for UTF-8" on \
+ PLUGINS "Build with ettercap plugins" on \
+ SSL "Build with support for SSH1 and SSL decryption" on \
+ PCRE "Build with PCRE regexps in filters" on
+
+WANT_GNOME= yes
GNU_CONFIGURE= yes
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
-.if !defined(WITHOUT_GTK)
-USE_GNOME= glib20 atk pango gtk20
-PKGNAMESUFFIX= -gtk2
-.endif
-.if !defined(WITHOUT_ICONV)
-USE_ICONV= yes
-.endif
-.if !defined(WITHOUT_PLUGINS)
-USE_LIBLTDL= yes
-.endif
-.if !defined(WITHOUT_SSL)
-USE_OPENSSL= yes
-.endif
MAN5= etter.conf.5
MAN8= ettercap.8 ettercap_curses.8 etterfilter.8 etterlog.8
DOCS= AUTHORS CHANGELOG README README.BINARIES README.BUGS \
README.CVS README.PLATFORMS THANKS TODO TODO.TESTING \
doc/capture doc/decoders doc/dissectors doc/threads
-.if !defined(WITHOUT_PLUGINS)
-MAN8+= ettercap_plugins.8
-DOCS+= doc/plugins
-.endif
.include <bsd.port.pre.mk>
@@ -65,56 +52,43 @@ CONFIGURE_ARGS+= --with-libpcap=${LOCALBASE}
.endif
.if !defined(WITHOUT_GTK)
+USE_GNOME= glib20 atk pango gtk20
+PKGNAMESUFFIX+= -gtk2
CONFIGURE_ARGS+= --enable-gtk
.else
CONFIGURE_ARGS+= --disable-gtk
.endif
+
.if !defined(WITHOUT_ICONV)
+USE_ICONV= yes
CONFIGURE_ARGS+= --with-iconv=${LOCALBASE}
.endif
+
.if !defined(WITHOUT_PCRE)
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-libpcre=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-libpcre
.endif
+
.if !defined(WITHOUT_PLUGINS)
-PLIST_SUB+= PLUGINS=""
+USE_LIBLTDL= yes
+MAN8+= ettercap_plugins.8
+DOCS+= doc/plugins
CONFIGURE_ARGS+= --enable-plugins
+PLIST_SUB+= PLUGINS=""
.else
CONFIGURE_ARGS+= --disable-plugins
PLIST_SUB+= PLUGINS="@comment "
.endif
+
.if !defined(WITHOUT_SSL)
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.else
CONFIGURE_ARGS+= --without-openssl
.endif
-pre-everything::
-.if !defined(WITHOUT_GTK) || !defined(WITHOUT_ICONV) || \
- !defined(WITHOUT_PCRE) || !defined(WITHOUT_PLUGINS) || \
- !defined(WITHOUT_SSL)
- @${ECHO_MSG} ""
- @${ECHO_MSG} "You may use the following build option(s):"
- @${ECHO_MSG} ""
-.if !defined(WITHOUT_GTK)
- @${ECHO_MSG} "WITHOUT_GTK=yes builds without GTK2+ GUI"
-.endif
-.if !defined(WITHOUT_ICONV)
- @${ECHO_MSG} "WITHOUT_ICONV=yes builds without support for UTF-8"
-.endif
-.if !defined(WITHOUT_PCRE)
- @${ECHO_MSG} "WITHOUT_PCRE=yes builds without support for perl regexps in filters"
-.endif
-.if !defined(WITHOUT_PLUGINS)
- @${ECHO_MSG} "WITHOUT_PLUGINS=yes builds without ettercap plugins"
-.endif
-.if !defined(WITHOUT_SSL)
- @${ECHO_MSG} "WITHOUT_SSL=yes builds without support for SSH1 and SSL decryption"
-.endif
- @${ECHO_MSG} ""
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
@@ -124,14 +98,14 @@ post-patch:
post-install:
@${INSTALL_DATA} ${WRKSRC}/share/etter.conf \
${PREFIX}/etc/etter.conf.sample
-.if !exists(${PREFIX}/etc/etter.conf)
- @${INSTALL_DATA} ${WRKSRC}/share/etter.conf ${PREFIX}/etc/etter.conf
-.endif
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
-.endfor
-.endif
+. if !exists(${PREFIX}/etc/etter.conf)
+ @${INSTALL_DATA} ${WRKSRC}/share/etter.conf ${PREFIX}/etc/etter.conf
+. endif
+. if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+. endfor
+. endif
.include <bsd.port.post.mk>
diff --git a/net-mgmt/ettercap/files/patch-ab b/net-mgmt/ettercap/files/patch-configure
index 77db4c590bf0..77db4c590bf0 100644
--- a/net-mgmt/ettercap/files/patch-ab
+++ b/net-mgmt/ettercap/files/patch-configure