aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-05-04 07:36:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-05-04 07:36:14 +0000
commit0cc0999d00edabafd05dd054c53772d14a45975e (patch)
treecc1cc01dc550699b4049cebe224e672fdc435cc5 /net-mgmt
parent0a90f4b41622cd1f846b8eda6ed2d12ce166ef44 (diff)
downloadports-0cc0999d00edabafd05dd054c53772d14a45975e.tar.gz
ports-0cc0999d00edabafd05dd054c53772d14a45975e.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/net-snmp4/Makefile1
-rw-r--r--net-mgmt/net-snmp4/files/patch-hr_swrun.c18
2 files changed, 17 insertions, 2 deletions
diff --git a/net-mgmt/net-snmp4/Makefile b/net-mgmt/net-snmp4/Makefile
index a65333dd0f28..5429c52acc6c 100644
--- a/net-mgmt/net-snmp4/Makefile
+++ b/net-mgmt/net-snmp4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ucd-snmp
PORTVERSION= 4.2.7
+PORTREVISION= 1
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= net-snmp
diff --git a/net-mgmt/net-snmp4/files/patch-hr_swrun.c b/net-mgmt/net-snmp4/files/patch-hr_swrun.c
index 48840940fbba..c5e9239ae19f 100644
--- a/net-mgmt/net-snmp4/files/patch-hr_swrun.c
+++ b/net-mgmt/net-snmp4/files/patch-hr_swrun.c
@@ -1,5 +1,5 @@
--- agent/mibgroup/host/hr_swrun.c.orig 2006-06-06 08:11:59.000000000 +0000
-+++ agent/mibgroup/host/hr_swrun.c 2008-04-30 11:30:47.000000000 +0000
++++ agent/mibgroup/host/hr_swrun.c 2008-05-04 07:06:22.000000000 +0000
@@ -549,7 +549,7 @@
string[ sizeof(string)-1 ] = 0;
#endif
@@ -36,7 +36,21 @@
long_return = proc_table[LowProcIndex].ki_runtime / 100000;
#else
long_return = proc_table[LowProcIndex].kp_proc.p_uticks +
-@@ -1266,7 +1266,7 @@
+@@ -999,12 +999,8 @@
+ long_return = proc_buf->p_swrss;
+ #endif
+ #elif HAVE_KVM_GETPROCS
+-#if defined(freebsd3) && !defined(darwin)
+- #if defined(freebsd5)
++#if defined(freebsd6) || defined(freebsd7) || defined(__FreeBSD_version)
+ long_return = proc_table[LowProcIndex].ki_size/1024;
+- #else
+- long_return = proc_table[LowProcIndex].kp_eproc.e_vm.vm_map.size/1024;
+- #endif
+ #else
+ long_return = proc_table[LowProcIndex].kp_eproc.e_vm.vm_tsize +
+ proc_table[LowProcIndex].kp_eproc.e_vm.vm_ssize +
+@@ -1266,7 +1262,7 @@
#elif defined(solaris2)
return proc_table[current_proc_entry++];
#elif HAVE_KVM_GETPROCS