aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-03-18 06:21:13 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-03-18 06:21:13 +0000
commit0fa193c992b593994b4ffe073b42310c8478ed86 (patch)
tree7f545b4f734c4d140303ebd56a1e00c1121e6fa8 /net-mgmt
parentf681514ee966a6d9ea2a3c8dff919d11de7cba1d (diff)
downloadports-0fa193c992b593994b4ffe073b42310c8478ed86.tar.gz
ports-0fa193c992b593994b4ffe073b42310c8478ed86.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/check_multi/Makefile37
-rw-r--r--net-mgmt/check_multi/distinfo3
-rw-r--r--net-mgmt/check_multi/pkg-descr17
-rw-r--r--net-mgmt/check_multi/pkg-plist10
5 files changed, 68 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 4634cd829c52..40a889d5860d 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -38,6 +38,7 @@
SUBDIR += cdpr
SUBDIR += cfgstoragemk
SUBDIR += cflowd
+ SUBDIR += check_multi
SUBDIR += check_snmp_pkgvuln
SUBDIR += chillispot
SUBDIR += choparp
diff --git a/net-mgmt/check_multi/Makefile b/net-mgmt/check_multi/Makefile
new file mode 100644
index 000000000000..e8c899e7745e
--- /dev/null
+++ b/net-mgmt/check_multi/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: check_multi
+# Date created: 18 Mar 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= check_multi
+PORTVERSION= 0.19
+CATEGORIES= net-mgmt
+MASTER_SITES= http://my-plugin.de/${PORTNAME}/
+#PKGNAMEPREFIX= nagios-
+DISTNAME= ${PORTNAME}-${PORTVERSION}.current
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= A multi purpose wrapper plugin for Nagios
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+PLUGIN_DIR= libexec/nagios
+
+do-configure:
+ ${REINPLACE_CMD} -e "s|/usr/bin/perl|${PERL5}|" \
+ ${WRKSRC}/check_multi
+
+do-install:
+ -${MKDIR} ${PREFIX}/${PLUGIN_DIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/check_multi ${PREFIX}/${PLUGIN_DIR}/
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ @${TAR} -C ${WRKSRC}/contrib -cf - . | ${TAR} -C ${EXAMPLESDIR} -xf -
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/check_multi/distinfo b/net-mgmt/check_multi/distinfo
new file mode 100644
index 000000000000..a41b885950d8
--- /dev/null
+++ b/net-mgmt/check_multi/distinfo
@@ -0,0 +1,3 @@
+MD5 (check_multi-0.19.current.tgz) = 0148abaccf51ef93c4acdf5735872011
+SHA256 (check_multi-0.19.current.tgz) = beca8b28ffb0cdd95d786b3e36d9ce6f2fbd633063499303f8e8ea43cf82fe02
+SIZE (check_multi-0.19.current.tgz) = 27113
diff --git a/net-mgmt/check_multi/pkg-descr b/net-mgmt/check_multi/pkg-descr
new file mode 100644
index 000000000000..9be4ab6a9787
--- /dev/null
+++ b/net-mgmt/check_multi/pkg-descr
@@ -0,0 +1,17 @@
+check_multi is kind of a wrapper plugin which takes benefit of the
+Nagios 3.x capability to display multiple lines of plugin output.
+It calls multiple child plugins and displays their output in the
+long_plugin_output. A summary is given in the standard plugin output.
+The child return code with the highest severity becomes the parent
+(check_multi) plugin return code.
+
+The configuration is very simple: a NRPE-stylish config file contains
+a tag for each child plugin and then the check command line.
+
+check_multi can cover complex Business Process Views - using a builtin
+state evaluation mechanism. The second benefit is cluster monitoring
+with no need for extra services. All you need is provided by check_multi.
+
+LICENSE: GPL2 or later
+
+WWW: http://www.my-plugin.de/wiki/projects/check_multi/start
diff --git a/net-mgmt/check_multi/pkg-plist b/net-mgmt/check_multi/pkg-plist
new file mode 100644
index 000000000000..7b06ad68adac
--- /dev/null
+++ b/net-mgmt/check_multi/pkg-plist
@@ -0,0 +1,10 @@
+libexec/nagios/check_multi
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/check_multi.cmd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_example/download.cfg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_example/download.cmd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_example/download_my-plugin.cmd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cluster_example/download_sourceforge.cmd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notify_service_html
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/cluster_example
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrmtry libexec/nagios